Xdsl (Xbox Damn Small Linux)

Discussion in 'Microsoft Xbox' started by TeamScriptKiddies, Jul 30, 2015.

  1. TeamScriptKiddies
    OP

    TeamScriptKiddies Licensed Nintendo (indie) Game Developer

    Member
    1,887
    1,311
    Apr 3, 2014
    United States
    Planet Earth :P
    Hey everyone, I just got my original xbox back. I gave it to my bf a couple of years ago and he never used it so he gave it back XD. Anyways I softmodded it forever ago using the splinter cell method and have Evox Dashboard installed (yes I know its dated, but I could care less as I'm mainly using this for linux :P).

    Anyways so I got Xdsl v0.6 (what appears to be the last stable version) installed as a loopback install which is great! It runs excellent as far as performance goes no complaints there (DSL FTW). Problem is this is pretty outdated, so I went through the process of trying to update everything and enable APT etc, but many of the options failed due to the location of files moving/not being hosted anymore. All I got to update was firefox to GTK v2 and flashplayer 9, everything else failed lol. I DID find this beta version of Xdsl v 0.7 here: http://forums.xbox-scene.com/index.php?/topic/667771-xdsl-07-beta-released/ but haven't tried it yet. Has anyone tried this here? Any luck getting APT enabled at least on this version? If I can at least get APT up and running, that would be great! I can work with that to get everything I want updated and install all my software etc.

    UPDATE: I got the myDSL extension browser (package manager for dsl) up and running again and I'm still on xdsl 0.6 :P. I did manage to restore dpkg and apt-get but it was causing a conflict with myDSL and it trashed my install. Had to reformat and start over but not myDSL is working. Still pretty neat I guess :P. In my spare time, I plan on upgrading this version of xdsl to make it more usable for those who are interested :P

    UPDATE 2: Just managed to get lxdoom to run weeeeeeee! Runs full speed and everything. This is pretty neat :) :P. Xmame runs fine as long as you launch it from the GUI and not the terminal

    UPDATE 3: Got both APT-GET running and mydsl extension browser side by side :). So now apps for debian or dsl can be installed (for the most part). Conflict has been resolved.

    UPDATE 4: APT-GET and mydsl are still fighting one another apparently. Just doesn't seem that way at first, until you try to launch an application/package installed from either package manager. That being said, I've temporarily removed the APT-GET functionality until I can figure out what the issue is.

    Here's a fun video of me playing doom under XDSL:

    :P
     
    Last edited by TeamScriptKiddies, Aug 15, 2015 - Reason: yet another update :P
    DinohScene likes this.