White Screens for almost every DS game

Discussion in 'CycloDS' started by apb407, Jan 18, 2009.

Jan 18, 2009
  1. apb407
    OP

    Member apb407 GBAtemp Fan

    Joined:
    Feb 27, 2007
    Messages:
    496
    Country:
    United States
    Hey guys i just recently bought a Cyclo DS and I am a sorta experienced user as i have had a EZ Flash 5 (lost) and a EZ Flash 4 lite (sold). Now i bought a Cyclo DS from Realhotstuff.com and it came within 5 days and i was very happy bout, i even got my Cyclo DS set up within like 10 min. Now i copied over the exact games i had used for my EZ Flash V into my Cyclo DS but most of them are not working. I am using the newest firmware 1.53 , and have battery saver disabled, cheats disabled.

    The weird thing is some games and most others dont here is a list of some of them that i have tried that work and dont. Some Games also just go to Black Screens

    Working

    Daigasso Band Bro
    Super Mario 64 DS
    Advance Wars DS
    MLB PPW 08
    Apollo Justice
    LOZ PH


    Not Working

    Ouendan 1
    Ouendan 2
    Jump Ultimate Stars
    Sonic Rush Adventure
    Nanostray
    Kirby: Canvas Curse
    Electroplankton
    Elite Beat Agents
    Wario Ware Touched
    Eyeshield 21 DS Max Devil Power

    and probably many more ( i sorta am forgetting some of them)

    I have used two different micro sd cards. One of them was a 2 gig generic card i got with my Cyclo DS as a promotional offer from realhotstuff.com and the other was a 1gig Kingston Micro Sd card which i had used with my old EZ Flash V as well

    Any ideas or help ?
     
  2. Saturnplanet5

    Member Saturnplanet5 GBAtemp Advanced Fan

    Joined:
    Aug 8, 2006
    Messages:
    652
    Country:
    Australia
    Or try deleting the CycloDS folder from your MicroSD card. It should be rewritten the next time you boot up your CycloDS.
     
  3. damnesiac

    Newcomer damnesiac Member

    Joined:
    Dec 26, 2008
    Messages:
    37
    Location:
    melb.vic.au
    Country:
    Australia
    1.53 is pretty buggy, try 1.51.
     
  4. apb407
    OP

    Member apb407 GBAtemp Fan

    Joined:
    Feb 27, 2007
    Messages:
    496
    Country:
    United States
    Yes i went back to 1.51 also i think it might have been my roms that were the problem. I had backed up all the Roms and saves from my EZ Flash about 2 months before i lost it and most of those did not work on the Cyclo but when i went to my library of ROMS all of those work perfectly.
     
  5. DeMoN

    Member DeMoN GBAtemp Guru

    Joined:
    May 12, 2004
    Messages:
    7,647
    Country:
    United States
  6. apb407
    OP

    Member apb407 GBAtemp Fan

    Joined:
    Feb 27, 2007
    Messages:
    496
    Country:
    United States
    really ? thats weird most of the saves i used in my ez flash work with the games.......
     

Share This Page