When a new FW version comes out, when do I update Luma?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Eradigon, Jul 6, 2016.

  1. Eradigon
    OP

    Eradigon Member

    Newcomer
    36
    21
    Jul 4, 2016
    watching you sleep
    Sorry if this is a noob paradise-type question or answered in the stickies, I looked but I couldn't find anything and this has kind of been bugging me.
    So, I'm running A9LH on sysnand with Luma, currently on FW 11.0. I have the Luma3DS Updater installed from the guide (I've heard about StarUpdater, not sure what the advantage is though), but I'm worried about when 11.1 (or whatever the next version is) comes out. Do I update Luma as soon as it comes out, or do I need to wait for a Luma update (and where can I check to see if one is released if so)? Do I update Luma first, or the 3ds FW first. If I mess something up, will A9LH protect me? Is there any risk of removing Luma and updating my sysnand (removing downgrade capability etc.)?
     
    alpha_noj likes this.
  2. Ar5chK3ks

    Ar5chK3ks GBAtemp Regular

    Member
    132
    14
    Mar 14, 2016
    Gambia, The
    Usually if a new Version comes out (for Example: 11.1) there will be a thread on this forum like this: "Update 11.0 and Homebrew). This thread has most things listed with a comment if it still works or not. You should also see if Luma3DS needs a update to run the new Version. You can most the time find that out by looking on the github of Luma3DS.

    EDIT: if Nintendo finds a way to break A9LH you are probably not save if you update. But that is very unlikely and will also be stated in that thread I talked about above. Otherwise if Nintendo doen't find anyway/doesn't care you should be good since Luma protects A9LH.
     
    Last edited by Ar5chK3ks, Jul 6, 2016
    smileyhead likes this.
  3. Eradigon
    OP

    Eradigon Member

    Newcomer
    36
    21
    Jul 4, 2016
    watching you sleep
    Thanks, but what order do I update Luma in when that does happen? (Luma first, or FW first?)
     
  4. nero99

    nero99 GBAtemp Addict

    Member
    2,021
    936
    Sep 18, 2014
    United States
    update luma first if you're using star updater or luma updater. It really doesn't matter as long as you update luma to the latest.
     
  5. Ar5chK3ks

    Ar5chK3ks GBAtemp Regular

    Member
    132
    14
    Mar 14, 2016
    Gambia, The
    Both ways should work. But I would recommend to update Luma first with the App and then update the FW since it most likely works with the older version. If you update first it could be that you need to update Luma manually by putting your SD in your computer and put all needed files ln there from Git
     
  6. Eradigon
    OP

    Eradigon Member

    Newcomer
    36
    21
    Jul 4, 2016
    watching you sleep
    Alright, thanks. I just didn't want to do something wrong and break stuff.
     
  7. alpha_noj

    alpha_noj GBAtemp Regular

    Member
    276
    58
    May 29, 2009
    United States
    Glad someone else asked this, as I just followed Plailect's guide and it doesn't really say. Also, as long as I followed his guide, A9LH is protected correct? Aside from Nintendo doing something goofy, that is.
     
  8. Ar5chK3ks

    Ar5chK3ks GBAtemp Regular

    Member
    132
    14
    Mar 14, 2016
    Gambia, The
    Well Luma protects Firm0 and Firm1(that is where A9LH takes effect) so if Nintendo theoretically finds a way around this or something else "goofy" it is safe
     
  9. Swiftloke

    Swiftloke Hwaaaa!

    Member
    1,770
    1,525
    Jan 26, 2015
    United States
    Nowhere
    Yes. Luma (and any good cfw for that matter (*gateway*)) will protect firm0 and firm1 before jumping to regular boot, ensuring a9lh remains protected, something which as stated above gateway does not do. Not sure about the garbage key store though, but as we've been able to update to 11.0, I assume it's protected too. Do you know, @Aurora Wright?