USB Loader GX Ripping Games Incorrectly

Discussion in 'Wii U - Hacking & Backup Loaders' started by Belickade, Apr 20, 2015.

  1. Belickade
    OP

    Belickade Member

    Newcomer
    13
    0
    Apr 20, 2015
    Canada
    I've got a 2TB HDD (FAT32 32kb cluster size) that is giving me nothing but problems when attempting to use the install function within USB Loader GX. Regardless of what game I install, none of them work. I finally decided to try installing a game onto an 8GB USB stick and noticed a rather large size difference when compared to those installed onto the HDD.

    For instance, when installing No More Heroes onto the 2TB HDD, after installation, the game is only around 400MB. When Installing onto the USB stick, 3+GB. Copying the 3GB version onto the HDD allows the game to play fine.

    Why is my HDD incorrectly ripping games? I'm glad to have found a workaround, but, ripping my entire Wii collection to a 8GB stick, and then back to the HDD is going to take ages. I've tried reformatting the drive, but it still does this. Could it be because the HDD is USB3? Any suggestions?
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,961
    762
    Mar 2, 2015
    United States
    USB 3.0 is backwards compatible with 2.0. NMH may be one of the games that doesn't rip properly. I've always just used CleanRip then made the WBFS files with Wii Backup Manager.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,077
    8,586
    Oct 27, 2002
    France
    Engine room, learning
    That's strange that it dumps differently.
    There were an issue when dumping a game on NTFS partition with SD card inserted : it split the game even if asked not to split it.
    so I did a modification in the partition format detection in a recent revision of the loader. Maybe it affects the dump size? (it shouldn't, but a bug is always possible).
    it should auto-detect split size at 4GB if you use a FAT partition.

    Could you go to Settings > HDD settings > Split setting : check if you are on 2GB.
    Let me know if editing the split size helps in any way or changes the dump size.
    Maybe it stops instead of splitting.