USB Loader GX + Nintendont = Back to System Menu

Discussion in 'Wii U - Hacking & Backup Loaders' started by solarsaturn9, Oct 8, 2014.

  1. solarsaturn9
    OP

    solarsaturn9 GBAtemp Regular

    Member
    109
    37
    Oct 29, 2012
    United States
    Hi there.

    Let me preface this question by saying I have searched for an answer to this problem before posting.

    I have updated to the latest version of USB Loader GX. I have never tried to use a Gamecube loader through USB Loader GX or standalone for that matter. My Wii games work just fine from USB Loader but when I try to run a Gamecube game using Nintendont I get sent back to the Wii system menu. There is not green flash or loading dialogue or anything.

    Checklist:
    - Latest version of USB Loader GX r1232
    - Latest version of Nintendont r167 (In sd:/apps/nintendont/ )
    - Both Gamecube and Wii backups are in usb:/ and follow the usb:/wbfs/Game [GameID] naming convention
    - Gamecube backups are names "game.iso" as per Nintendont specification
    - Loading Wii backups work
    - Changed settings to use Nintendont as the Gamecube loader
    - Double checked the directory settings for Nintendont in USB Loader is sd:/apps/nintendont/

    Still no luck. Has anyone else had this problem? I think there should be a troubleshooting section/thread for this type of thing.
     
    wiitf likes this.
  2. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah
    Well since this is clearly a Nintendont issue I'd say you should actually post it in the Nintendont Sticky. but whatever.

    Have you tried launching through nintendont and not nintendont through usb loader? Im thinking either your Nintendont is set up incorrectly, or you have incompatible versions of either app. I know you checked it, but what happens if you only use nintendont?
     
    solarsaturn9 likes this.
  3. solarsaturn9
    OP

    solarsaturn9 GBAtemp Regular

    Member
    109
    37
    Oct 29, 2012
    United States

    I tried running Nintendont by itself and it was giving me an AHBProt error which I googled and from what I understand this error occurs when you don't have a valid xml file... which is strange. Anyway, I looked and saw that there was another revision of Nintendont released so I updated the boot.dol, downloaded the meta.xml and updated the contents to reflect the actual revision (it was way back on r22 or something).

    I tried loading Nintendont again and it said it couldn't find a FAT formatted device or it couldn't find a "games" folder. Here is where I made my mistake. If you have USB Loader GX and you launch Wii backups from a "wbfs" folder you should NOT put your Gamecube backups in the "wbfs" folder. Make a separate folder called "games" (I don't think it necessarily needs to be called games as you can change the directory in the settings of USB Loader GX) and put your Gamecube backups in that folder. Then I was able to launch Gamecube games from Nintendont itself.

    Lastly, if you want Gamecube games to show up in the list in USB Loader GX you have to click on the little icon that looks like an NES and make sure "GC Games" is checked.

    Now everything seems to be working correctly. Thanks for the suggestion, EmceeKerser!
     
  4. EmceeKerser

    EmceeKerser GBAtemp Maniac

    Member
    1,374
    503
    Jun 3, 2014
    The fuckin' Blue Mountains brah

    Glad everything worked out!