Homebrew Usb Loader GX external hdd trouble

machine_

Member
OP
Newcomer
Joined
May 26, 2022
Messages
6
Trophies
0
Age
21
Location
new york
XP
9
Country
United States
I'm having this issue with usb loader gx not reading my external hard drive (wd elements 2tb ntfs) and its driving me insane. Basically it works great for a while, then after some time I would open the app, it would initialize the drive and then flash "waiting for hdd" and count down from 17. I would scramble over the internet for a few hours trying to fix it until it just fixed itself after reformatting my whole sd card. Then after that the same issue happened again after a few hours. Any ideas?
 
Last edited by machine_,

jeannotte

Well-Known Member
Member
Joined
Jun 15, 2016
Messages
3,717
Trophies
1
Age
51
XP
3,421
Country
France
I'm having this issue with usb loader gx not reading my external hard drive (wd elements 2tb ntfs) and its driving me insane. Basically it works great for a while, then after some time I would open the app, it would initialize the drive and then flash "waiting for hdd" and count down from 17. I would scramble over the internet for a few hours trying to fix it until it just fixed itself after reformatting my whole sd card. Then after that the same issue happened again after a few hours. Any ideas?
Hello,

please post a syscheck report here (maybe you are missing some cios and see if your hack is up to date)

what version of GX are you using?

Have you tried the modified GX version of @blackb0x ==> https://gbatemp.net/threads/usb-loader-gx.149922/page-1316#post-8856063

recommend ==> FAT32 external hard drive and use """ wii backup manager "" to manage your games
 
  • Like
Reactions: CoolMe

machine_

Member
OP
Newcomer
Joined
May 26, 2022
Messages
6
Trophies
0
Age
21
Location
new york
XP
9
Country
United States
Hello,

please post a syscheck report here (maybe you are missing some cios and see if your hack is up to date)

what version of GX are you using?

Have you tried the modified GX version of @blackb0x ==>

recommend ==> FAT32 external hard drive and use """ wii backup manager "" to manage your games
I was using the version of gx that came with modmii and was working perfectly for a while. Updating through homebrew browser and trying the custom version you linked didn't change anything either. My hard drive is formatted to ntfs so I can play the bigger wii games and was working perfectly since its supported by gx. I also just create the wbfs layouts manually. I haven't changed anything with the hard drive since it stopped working so I don't think its the format or anything actually on it. Does the hard drive need more power maybe? I keep seeing this online but seems to only be an issue for the wii u. It is currently being powered with the one usb cable that comes with it through port 0 and has worked for everything including the wii up until this point. I installed every cios through modmii and usbloader is currently running on 249. I am able to create a syscheck but its not uploading to the website for some reason. Let me know if theres an easier way I can share it with you or let me know if there's something I should look for on the report, thanks for your time.
Edit: found out how to post a syscheck, here it is:
[spoilers]
SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.3U (v513)
Priiloader installed
Drive date: 07.14.2008
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x21
Console ID: 90159473
Console Type: Wii
Shop Channel Country: United States (49)
Boot2 v4
Found 87 titles.
Found 48 IOS on this console. 7 of them are stubs.

IOS3 (rev 65280): Stub
IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS51 (rev 4864): Stub
IOS52[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS61 (rev 5662): No Patches
IOS62 (rev 6430): No Patches
IOS70[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS80[60] (rev 65535, Info: ModMii-IOS60-v6174): Trucha Bug, NAND Access
IOS222 (rev 65280): Stub
IOS223 (rev 65280): Stub
IOS249[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS250[56] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS251[38] (rev 65535, Info: d2x-v10beta52): Trucha Bug, ES Identify, NAND Access
IOS254 (rev 65281): BootMii
BC v6
MIOS v10
Report generated on 05/07/2017.[/spoilers]
 
Last edited by machine_,

machine_

Member
OP
Newcomer
Joined
May 26, 2022
Messages
6
Trophies
0
Age
21
Location
new york
XP
9
Country
United States
No. No NTFS partition, at all.
No.

Also, not all hard drives are compatible.
There's still that possibility.
Ok just reformatted my whole drive to fat32... same error, ntfs is supported on usb loader gx btw. Also like I said in the post it worked perfectly for about a day. It hangs at reinitializing devices for a second then says "waiting for hdd" and counts from 17.
 

JuanBaNaNa

Immature and biased ¯\_(ツ)
Member
Joined
Dec 17, 2019
Messages
2,880
Trophies
2
Age
28
Location
the 90's 💙
XP
5,239
Country
Mexico
Ok just reformatted my whole drive to fat32... same error, ntfs is supported on usb loader gx btw. Also like I said in the post it worked perfectly for about a day. It hangs at reinitializing devices for a second then says "waiting for hdd" and counts from 17.
Ugh, hate USB Loader GX.

My last advice would be: Try with CFG USB Loader instead.

If that doesn't work, then I'm out of ideas, and might think the drive is defective... which to be honest is unlikely given the amounf of threads from people having troubles with USB Loader GX.
 

machine_

Member
OP
Newcomer
Joined
May 26, 2022
Messages
6
Trophies
0
Age
21
Location
new york
XP
9
Country
United States
Ugh, hate USB Loader GX.

My last advice would be: Try with CFG USB Loader instead.

If that doesn't work, then I'm out of ideas, and might think the drive is defective... which to be honest is unlikely given the amounf of threads from people having troubles with USB Loader GX.
I just tried that and cfg loader can see it as a usb mass storage device but it just ends up saying device is not responding, so maybe it is a problem with the hard drive. I checked and scanned it but nothing came up. Are you supposed to use something else to keep the drive powered? Im just using the usb cable it came with and its worked with everything including the wii up until this point.
 

JuanBaNaNa

Immature and biased ¯\_(ツ)
Member
Joined
Dec 17, 2019
Messages
2,880
Trophies
2
Age
28
Location
the 90's 💙
XP
5,239
Country
Mexico
I just tried that and cfg loader can see it as a usb mass storage device but it just ends up saying device is not responding, so maybe it is a problem with the hard drive. I checked and scanned it but nothing came up. Are you supposed to use something else to keep the drive powered? Im just using the usb cable it came with and its worked with everything including the wii up until this point.
Have you tried another cable? Maybe it's failing at supplying the needed voltage.
As far as I know, it should work with the Wii as long as it requires 5 volts.

IOS58 allows you to use the near-the-edge port as USB 2.0 but I'm not sure if that adds voltage too.
 
  • Like
Reactions: machine_

machine_

Member
OP
Newcomer
Joined
May 26, 2022
Messages
6
Trophies
0
Age
21
Location
new york
XP
9
Country
United States
Have you tried another cable? Maybe it's failing at supplying the needed voltage.
As far as I know, it should work with the Wii as long as it requires 5 volts.

IOS58 allows you to use the near-the-edge port as USB 2.0 but I'm not sure if that adds voltage too.
That worked! I just switched the cable for a regular android charger and it loaded. Thanks, never would have thought to check that. Thanks for the help!
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    DEMONGreninjaPG @ DEMONGreninjaPG: kennies your honry