Upshoot in DSI errors and freezing

Discussion in 'Wii - Hacking' started by Dr. Hobo, Jun 27, 2011.

Jun 27, 2011
  1. Dr. Hobo
    OP

    Newcomer Dr. Hobo Member

    Joined:
    Sep 14, 2009
    Messages:
    29
    Country:
    United States
    Recently I've noticed that a lot of my homebrew apps have been crashing or just plain freezing (well, more than usual). I saw it a lot first in the port of Super Mario War, so I just figured it was a problem with that one app, but VBAGX, FCEUGX, Mplayer CE and WiiMC have been crashing and/or freezing a lot too. Also, when they do crash, the automatic 8-second reload no longer works, and neither does hitting reset. I've got to hold the power button and do a hard shut down. I'm fairly sure the apps are all up-to-date and I haven't updated any hacks or anything that could have broken these apps in ages. Any help would be appreciated.

    I'm running 4.2u which I think I updated with Waninkoko's updater and my hbc is up-to-date. I can't really think of anything else that's pertinent (I've been away from the scene for so long I've forgotten what's important and what isn't), but let me know if you need more info.
     
  2. VashTS

    Member VashTS Beat it, son

    Joined:
    Mar 14, 2009
    Messages:
    3,653
    Location:
    Upstate NY
    Country:
    United States
    try reinstalling ios58 and ios 202 using the wiimc installer. other than that, maybe try restoring an earlier nand backup if you have bootmii as boot 2. other wise do a fresh install of all softmods. just update the hbc to latest version, then update from nintendo. you could do it with nusad as well. you can simulate a system update and install all the wads.

    i have a similar issue with my main wii not playing dvd movies. it code dumps everytime. but my bedroom wii plays dvds just fine. havent got around to figuring it out but i think reinstalling some files will help.
     
  3. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    it has nothing to do with ios but hbc when network is disconnected

    solution: remove the line from meta.xml files
     
  4. lulwut

    Member lulwut GBAtemp Fan

    Joined:
    Mar 19, 2010
    Messages:
    331
    Country:
    Japan
    that makes no sense

    why would all his apps have that flag set?

    2 apps of his list dont need nor have it in their meta.xml and they still crash
     
  5. tueidj

    Member tueidj I R Expert

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
    Both VBAGX and FCEUGX have it so they can load roms from DVD. And yes, it's pretty dumb considering hardly anyone does that (or is even able to, since new wiis have incompatible hardware). An "opt-in" approach would be better.
     
  6. lulwut

    Member lulwut GBAtemp Fan

    Joined:
    Mar 19, 2010
    Messages:
    331
    Country:
    Japan
    yes but Mplayer CE doesn't (unless he changed that himself) and neither does Super Mario War
     
  7. tueidj

    Member tueidj I R Expert

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
    MPlayer CE does (why wouldn't it, it plays DVDs).
     
  8. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    MplayerCE, WiiMC, FCEUGX and VBAGX have it as mentionned above

    This leaves only SMW that does not have it by default but who knows, copy-paste can do wonders...

    Anyway, I was just giving the most common case for unrecoverable DSI exceptions since the same question pops up very frequently
    I'm pretty sure this will fix his problem with the emulators & media players, SMW could have a very different issue

    Other possibilities I experimented that cause such crashes/hangs:

    - incompatible USB device or memory card plugged in -> remove it
    - apps compiled with a bugged libogc version that crashed when connecting classic controller in wiimote other than #1 -> apps need to be updated
     
  9. tueidj

    Member tueidj I R Expert

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
    Right, there was a period of about 3 months last year when libogc's wiiuse port was broken and liable to crash if more than one wiimote was connected. That's probably not the case here (looks like SMW was built before then) but I'm sure there's still some affected apps floating around.
     
  10. lulwut

    Member lulwut GBAtemp Fan

    Joined:
    Mar 19, 2010
    Messages:
    331
    Country:
    Japan
    when did Mplayer CE get an edit for that then. mustve missed that then
     
  11. Dr. Hobo
    OP

    Newcomer Dr. Hobo Member

    Joined:
    Sep 14, 2009
    Messages:
    29
    Country:
    United States
    Well removing the ios reload tag seems to have worked for the apps that had it, thanks Jacobeian!

    The problem is SMW doesn't have that in the meta.xml file. I tried deleting everythingand putting a fresh copy of it on my sd card, but it still froze after I was playing for a while.

    I haven't plugged anything new into the wii in ages and I don't even own a cc. The app hasn't been updated in forever, but when I went to the google code site I saw that the source had been updated recently. I tried compiling it, but I've never done it before and I have no clue what I'm doing so I was unsuccessful. But even if this updated source fixed my problems, its still weird that I've never had a problem with the app before and now it freezes every time I play.
     

Share This Page