Upgrading Browser on SysNand from 9.2.0-9e -> 9.2.0-30e

Discussion in '3DS - Flashcards & Custom Firmwares' started by 75mak, Oct 30, 2015.

  1. 75mak
    OP

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    OK, this might seem like a wierd request, but what I would like to do is use ninjhax v1.

    My problem I have found is that ninjhax version 1 never works with any browser version below 10 above sysnand 5.

    so 4.5.0.7e is fine on ninjhax.... but as soon as the sysnand is 5 or over and the browser is still below 10 then most likely is ninjhax freezes on 70%. This info has come through a lot of experiance with many old3ds'. Even if smealum website says it should work I can say with great certainty it doesn't under the conditions i described (i.e. sysnand over 5 and browser below 10)

    So what I wish to do, is just update my browserto any version above 10, I have requested 30 as that's one of the latest on 9.2. I have access to rxtools 2.6 (i can't use rxtools 3.0 for now)

    What would be the easiest way to just upgrade the browser - would going into sysnand in rxmode be any good?

    Is there a quick and easy way to upgrade the browser just using rxtools 2.6 and fbi?
     
  2. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Yes just install whatever browser cia you want with fbi and -20 came with 9.2
     
    Last edited by Ronhero, Oct 30, 2015
    75mak likes this.
  3. TheKawaiiDesu

    TheKawaiiDesu Ball of Kawaiiness

    Member
    1,429
    1,497
    Aug 23, 2015
    Korea, North
    Lowee
    Wait, 30? Isn't the last Spider / Skater "version" 28?
     
  4. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    I think op wants -20 seeing how 1.x is -7 through -20 and 2.x is for no browser and -21 and higher
     
    75mak and TheKawaiiDesu like this.
  5. 75mak
    OP

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    just to make sure.... i downloaded this .cia, SpiderV1.7567EUR-0004003000009D02.cia

    from that iso site. if i inject fbi into sysnand, then run rxmode (using rxtools 2.6) in sysnand, run the h&s app - which runs fbi - then install that .cia on NAND not sd card..... it should update my browser version?

    Note: i will be running rxmode and not devmode - it won't brick the console will it?
     
  6. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Needs to be dev mode
     
  7. 75mak
    OP

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    does rxtools 2.6 have a devmode option? if it does, i can't see it
     
  8. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    It waa added in 2.5 so yes 2.6 should have it
     
  9. 75mak
    OP

    75mak GBAtemp Fan

    Member
    389
    111
    Nov 10, 2011
    looks like devmode was removed in 2.6, it was put back in 3.0

    — Posts automatically merged - Please don't double post! —

    that iso site says SpiderV1.7567EUR-0004003000009D02.cia can be installed using fbi on nand? i'm confused whether this means rxmode in sysnand or not?
     
    MelonGx likes this.
  10. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    It really should be installed in dev mode, try to use the 2.5 version then
     
  11. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,314
    1,712
    May 30, 2015
    United States
    It's just a CIA, not like you're updating the system version.... you SHOULD be able to do it in regular rxmode as a bad browser version won't brick anything... any real reason it should be done in devmode? I'm not trying to be mean just wonder what your reasons are
     
  12. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Because with system apps they need to be properly signed to the ticket and with firm launch the ticket is not written properly
     
  13. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,314
    1,712
    May 30, 2015
    United States
    is that why updating bricks when used with firmlaunch?
     
  14. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Yes
     
    MelonGx likes this.
  15. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,314
    1,712
    May 30, 2015
    United States
    interesting... so this is why you can simply install all of the CIAs with DevMenu and it works properly but not with FBI
     
  16. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    If you use the GW version of dev menu it should work

    Edit try devmenu r37904 @dark_samus3
     
    Last edited by Ronhero, Oct 30, 2015