Unsupported launcher (argc = 0)

Discussion in '3DS - Homebrew Development and Emulators' started by Giodude, Jun 5, 2017.

  1. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    In updating to luma3ds 8.0, i had to update b9s as well. After doing that, i replaced the boot.firm, and rebooted. Even though i downloaded the latest version of luma and put the newest boot.firm on the root of my sd card, it still throws the error "Unsupported launcher (argc = 0)", which is supposed to happen when using an outdated version of luma with the newest b9s. This same error happened when i updated b9s before updating luma so i know the update was successful. What could i be doing wrong?
     
    Quantumcat likes this.
  2. jupitteer

    jupitteer GBAtemp Lurker

    Member
    670
    444
    Feb 17, 2017
    Antarctica
    Inkopolis
    Did you update b9s to 1.2, or 1.1? If 1.1, you need 1.2 to run luma 8.
     
  3. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    Definitely 1.2. i have no other b9s zips.
     
  4. jupitteer

    jupitteer GBAtemp Lurker

    Member
    670
    444
    Feb 17, 2017
    Antarctica
    Inkopolis
    Unless you're not using Luma 8, you must have either used b9s 1.0 or 1.1.
     
  5. Xyphoseos

    Xyphoseos Hack or no games

    Member
    746
    66
    Jun 29, 2016
    France
    B9S 1.2 work only with Luma 8.0, if you have an other version, it give this error
     
  6. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
    Did you copy over the new B9S AND the new Luma3DS at the same time and then receive this error? As you were already told, you can't do that. The latest Luma3DS needs B9S 1.2 to be installed BEFORE copying it over to the SD card. So either copy back the previous version of Luma3DS, install the new B9S, then copy new version of Luma, or run safeb9sinstaller as boot.firm, install it, then copy over new luma.
     
  7. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    I downloaded luma 8.0 twice to make sure.
     
  8. jupitteer

    jupitteer GBAtemp Lurker

    Member
    670
    444
    Feb 17, 2017
    Antarctica
    Inkopolis
    Are you absolutely sure that you installed b9s 1.2 with safeb9sinstaller and not, say, 1.1?
     
  9. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    Pretty sure
    [​IMG]

    — Posts automatically merged - Please don't double post! —

    As stated in the op, i updated b9s, got the error on an older version of luma to make sure it updated, then i updated it to 8.0 and got the error.
     
  10. jupitteer

    jupitteer GBAtemp Lurker

    Member
    670
    444
    Feb 17, 2017
    Antarctica
    Inkopolis
    That's the only explanation. Unless you put Luma 7.1 in by accident. That's the only way you'd get that error.
     
  11. LinkFan16

    LinkFan16 I link them all

    Member
    405
    98
    Mar 15, 2009
    Gambia, The
    do you have luma installed to ctrnand as well? if so make sure to update luma in ctrnand as well using godmode9 as described at 3ds.guide. also make sure you placed the boot.firm of luma 8.0 in the root of your sd card
     
  12. jupitteer

    jupitteer GBAtemp Lurker

    Member
    670
    444
    Feb 17, 2017
    Antarctica
    Inkopolis
    Perhaps try deleting the luma config?
     
  13. Xyrenia

    Xyrenia Newbie

    Newcomer
    5
    0
    May 20, 2017
    Indonesia
    make sure you put luma3ds 8.0 on root of sdcard

    Sent from my 2014813 using Tapatalk
     
  14. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    Im downloading an md5 checker to make sure both files are the same.
     
    jupitteer likes this.
  15. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
    Just redownload luma3ds 8 and copy it over. If it still doesn't boot, copy back 7.x and see if that boots. If it does, your b9s didn't successfully update. Ionno why.

    It would only load from CTRNAND if the boot.firm on the sd card is incompatible.
     
    Last edited by OrGoN3, Jun 5, 2017
  16. Giodude
    OP

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,600
    1,005
    May 17, 2015
    United States
    New York
    The file was corrupted and it was booting from ctrnand. Thanks for the help.

    Edit: if that came out as sarcastic, that wasnt the intention.
     
    Last edited by Giodude, Jun 5, 2017