Unsigned driver woes

Discussion in 'Computer Software and Operating Systems' started by MichiS97, Oct 15, 2016.

  1. MichiS97
    OP

    MichiS97 "Leftist snowflake milennial"

    Member
    GBAtemp Patron
    MichiS97 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,318
    737
    Jun 14, 2011
    Gambia, The
    Bavaria
    Hi guys,

    I'm in desperate need of some advice. I need to install an unsigned driver on Windows 10 (64-bit system) and can do so by going into the advanced boot options and disabling the signature checks, basic stuff. My problem is that Windows completely rejects the driver (error code 52, which means it doesn't pass the sig check) when I boot normally after the driver was successfully installed using the advanced boot.
    I thought that it'd be pretty easy to solve this by just putting Windows into Test Mode which I have done and I've now got the test mode watermark on my desktop. However, this has done nothing to solve my problem, I still have to use the advanced boot option to install the driver and I have to re-install it everytime I reboot my PC, which is incredibly annoying as one might guess, especially since the drivers are for my speakers (unlocked Realtek drivers that make me able to have surround output from my mainboard).

    I'd be incredibly grateful if someone could help me, thanks in advance.
     
    Last edited by MichiS97, Oct 15, 2016
  2. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,685
    10,686
    Jul 11, 2009
    United States
    I forgot
    You can permanently disable driver sig enforcement if you'd like which should fix your problem, so long as you're aware of the consequences.

    Just open CMD prompt as an admin and type in "bcdedit.exe /set nointegritychecks on"

    That should permanently disable driver sig enforcement, and then Windows shouldn't continue pestering you about it. Though it is an odd issue, I've never had the problem myself. I know the Anniversary update made more strict driver sig changes but I don't think that should be the problem.

    EDIT: Oh duh, it could also be Secure Boot causing the issue too, I nearly forgot about that. Try disabling Secure Boot in your BIOS, that should also fix it.
     
    MichiS97 likes this.
  3. MichiS97
    OP

    MichiS97 "Leftist snowflake milennial"

    Member
    GBAtemp Patron
    MichiS97 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,318
    737
    Jun 14, 2011
    Gambia, The
    Bavaria
    I tried the CMD prompt (pretty sure I already have before) and it didn't solve my problem. Due to my mainboard being rather old it doesn't even have an option for Secure Boot...

    EDIT: Problem solved! I downloaded a tool that lets you sign sys files.
     
    Last edited by MichiS97, Oct 15, 2016