Unlinking Nands broke GBA games?

Discussion in '3DS - Flashcards & Custom Firmwares' started by GreatCrippler, Jan 12, 2016.

  1. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Like the title says, I could use GBA games on RXtools before I unlinked my Nand, and Emunand, and now that they are unlinked, GBA games won't start, and I have to power down the system. What am I missing?
     
  2. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,111
    958
    Jun 13, 2015
    United States
    California
    Install them in sysnand again.

    They need to be installed to both emunand and sysnand to be played in emunand if your nands are unlinked.
     
    Ailuros27 likes this.
  3. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Yea, that's what google told me, but it isn't working. Using FBI to put them on both sysnand, and emunand, but they still just crash on Emunand. It says they are installing on Sys, but I can't find them there. Dunno. :(
     
  4. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,111
    958
    Jun 13, 2015
    United States
    California
    Ok Noob question time...

    How are you doing it?
    Can you explain it to me?
     
  5. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    You're installing the CIAs from FBI while on sysnand, right? And you're installing them to the SD location?
     
  6. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,111
    958
    Jun 13, 2015
    United States
    California
    Are you booting emunand > FBI > installing them to NAND to install the in sysnand?

    Because if you are doing that is wrong...

    You have to boot sysnand > FBI > Install to SD.
     
  7. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    To clarify, the "NAND" install location for FBI does not mean sysnand. NAND just means NAND, as in the place where system titles are located. Emunand and sysnand both have a NAND, and you should not be installing things there unless you know what you're doing and have a very specific reason for doing so. Games are installed to SD, always (Exception: DSiWare).
     
    Last edited by Townsperson, Jan 12, 2016
  8. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Ok, So when I open sysnand, FBI is no longer there since I unlinked. It's in my HBL, and Emu, but not the generic Sys. Do I need to do something to put it back there?
     
  9. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    You can install it from HBL. Just launch a CFW (rxTools, Reinand, etc) into Sysnand, load HBL, and install FBI.cia from FBI.3dsx

    If that doesn't work, you can inject it into Health&Safety using Decrypt9.
     
    Last edited by Townsperson, Jan 12, 2016
  10. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Yea, been trying that from Pasta. Current steps taken were.

    1. Launch Cubic Ninja.
    2. Launch Pasta.
    3. Launch Cubic Ninja.
    4. Launch FBI
    5. Install FBI on Nand
    6. Restart System.
    7. Nothing New available.
     
  11. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    Install FBI to SD. Not NAND. Never NAND.
     
  12. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    It's already available on the SD from Emunand. I can boot into it just fine from RXtools, but when I install the GBA games from there it doesn't work. Tony_93 also said that it wouldn't work that way. I really feel like I am missing something obvious here, but its just not clicking. >.<
     
  13. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    SD is not emunand. SD is just your SD card. Sysnand uses SD to store titles, and emunand uses SD to store titles. The NAND location in FBI is only for system titles and DSiWare. If you're installing an application (Like FBI or Sysupdater) or a game (3DS CIA or a VC title), it goes on SD.

    So install FBI to SD while in Sysnand, and then use that FBI to install your GBA games (Also while in Sysnand) to SD. After that, you should be able to boot them (From emunand or sysnand).
     
    Last edited by Townsperson, Jan 12, 2016
  14. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    I get all of that, sorry if I am terming things poorly, but it's not working from the SD card. It's installed there, and can be seen from Emunand. It just won't launch from Emunand.

    Edit: Suppose it's worth clarifying, I can only install to SD while in Emunand. It errors from HBL
     
    Last edited by GreatCrippler, Jan 12, 2016
  15. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    FBI or GBA games? You need to install both to emunand and sysnand (FBI needs to be on sysnand to install CIAs to Sysnand). GBA games won't work if they aren't installed (to SD) in both Sysnand and emunand.
     
  16. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Yea, sorry tried to clarify with an edit. I can't get FBI to install to the SD in sysnand. It errors from HBL. Looking at Decrypt 9 now
     
  17. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    What error?

    You can use Decrypt9, but installing FBI to Sysnand should be far less complicated than emunand (Because HBL should work to install so long as you're running sysnand in CFW; Usually emunand requires the injection).
     
    Last edited by Townsperson, Jan 12, 2016
  18. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    OK, Photo not loading >.<


    Edit: That's from Pasta. If I use CN to try and launch HBL from RXtools, it opens my browser and locks the system. >.>
     
    Last edited by GreatCrippler, Jan 12, 2016 - Reason: Personal info showing
  19. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    Boot into sysnand, go to system settings->data management->3ds software. It should start writing something to SD (A message will tell you). If that works, try installing FBI again.

    EDIT: Actually, you'll probably need to put a title.db file in your SD card if one doesn't exist (Which it probably doesn't). Check out a CFW install guide. You'll want to look at the "dbs" folder part.

    EDIT2: http://gbatemp.net/threads/tutorial...ncluding-emunand-coldboot-cia-manager.405589/
     
    Last edited by Townsperson, Jan 12, 2016
    GreatCrippler likes this.
  20. GreatCrippler
    OP

    GreatCrippler Greatness Fallen

    Member
    1,271
    163
    Mar 27, 2010
    United States
    Worked like a charm. You are officially my hero. Thanks so much. I am doing this all on a backup system until I have a better grip on all of this, so I don't fry my main setup. Thanks for the help and the patience, and the overall lesson.... *Bows Down*