1. ViewtifulV

    ViewtifulV Member
    Newcomer

    Joined:
    Nov 14, 2006
    Messages:
    34
    Country:
    United States
    It looks like the Smash cartridge I bought is 1.0.1, so am I just out of luck? Is there any way to "update" to a version less than 1.1.3?
     
  2. Cydget

    Cydget GBAtemp Fan
    Member

    Joined:
    Oct 1, 2015
    Messages:
    493
    Country:
    United States
    not unless you have a firmware less then or equal to 9.2
     
  3. Aboshi

    Aboshi Newbie
    Newcomer

    Joined:
    Feb 25, 2016
    Messages:
    6
    Country:
    United States
    I contacted yellows on github, he said that he used the updates when making the pcaps.
    So what it looks like to me is that the updates have a different offset than the physical cartridges.
    I really didn't feel like going through the motions and porting it for physical cartridge so I returned smash bros and just went with OOT3D and the r4i save game dongle. Makes life so much easier and only $40ish for both the game and dongle.
    As for shashbroshax I guess you can buy a copy on the e-shop and as long as its not downloading to the latest version you should be good to go with this hax.
     
  4. Rhodderz

    Rhodderz Newbie
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    4
    Country:
    I have the cartridge (EU) version at 1.1.0 and my N3DS is currently 10.6.0.31E, When i attempt to launch the exploit, after around 4 seconds it goes back to the home screen saying something happened and when you press ok it crashes and reboots. In short what am i doing wrong? i have tried both otherapp and ropbin (yes named them smashpayload.bin) but to know avail. Also tried a different SD card. Any ideas?
     
  5. Holy-Freak

    Holy-Freak Advanced Member
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    72
    Country:
    France
    Everytime i go to smash->group the game crash and my n3ds have to reboot. I've tried about 10h to get it work but it still doesn't want to launch the hack. Did I do something wrong?
     
  6. Rhodderz

    Rhodderz Newbie
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    4
    Country:
    Tried on another laptop and 2 different wireless cards and still same result. So goign to point it down to the exploit on the 3ds. |The fact that it crashes is a start, just doesnt seem to be loading the file on the SD card (no screen mess, just straight to home)
     
  7. godlover9000

    godlover9000 Member
    Newcomer

    Joined:
    Feb 3, 2016
    Messages:
    15
    Country:
    United States
    while he has not come out with 1.0.1 he has instructions on compiling the pcap on his github page and it appears that someone on this thread has compiled a 1.0.1 for the US version of the game: https://gbatemp.net/threads/anyone-tried-compiling-smashbroshax-for-1-0-1.417443/#post-6157151 . I have tried it and now I am able to get it to crash back to the home menu but It does not appear to be loading the smashpayload.bin file or starting boot.3dsx
     
  8. Rhodderz

    Rhodderz Newbie
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    4
    Country:
    On my version (1.1.0) i can get the game to crash to home using ANY of the broadcast packets.
     
  9. Rhodderz

    Rhodderz Newbie
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    4
    Country:
    So doing this with my own compile i still wasnt able to get the exploit to load. Got OOT coming with a Powersave so will use that and then see if i can debug this and see what is happening. I dobt it is patched as i have seen confirmed reports of others being successfull. That shall be tonight though.
     
  10. malaken

    malaken Member
    Newcomer

    Joined:
    Apr 20, 2015
    Messages:
    49
    Country:
    United States
    Already then. So i got the unbuntu working got it to send packs and all but i have 2 questions. 1. My wireless interface says wlp4s0 instead of wlan0 And a enp1s0 and lo is this a problem? 2. My game crashes everytime try to send packs and makes my system restart on 10.7. Did i do something wrong here or is it just a keep going till it works type thing?


    * ok found out its because my games version is 1.0.5 and it has troubles with that. Anything i can do like continue trying or should i just give up? Its an actual retail game card at 1.0.5. Is there a method for this?
     
    Last edited: Mar 18, 2016
  11. sausbaus

    sausbaus Advanced Member
    Newcomer

    Joined:
    Feb 9, 2015
    Messages:
    59
    Country:
    United States
    Trying to use a 1.0.1 JP pcap file for this and have been having issues. Running aireplay-ng normally gives me the "End of File" message right away, and following your full tutorial gives me the same result. Running your script with one of the other pcap files at least starts broadcasting packetst without the "End of File" message, but of course those wont work for 1.0.1. I thought maybe renaming my pcap file to one of the pre-existing ones and dropping in the resoruces folder might work, but that just causes smash to crash to the home menu. Got any ideas?

    Here's the pcap file for reference.
    https://mega.nz/#!LhwhSYRa!FeLXrnvBXgDw6BR7MBNytQ_DN3H-gbMmkYDxQo1d5Fw

    EDIT: Well I've remedied the "End of File" issue. Smashbroshax still crashes to the homemenu after triggering however. Is this more likely an issue with the payload or the pcap file?
     
    Last edited: Mar 19, 2016
  12. arfaxad

    arfaxad Newbie
    Newcomer

    Joined:
    Mar 19, 2016
    Messages:
    6
    Country:
    Can't watch the video it says this video is private.. I tried method when when I run smashhax.sh I get prompted to run the file and when I do nothing happens

    — Posts automatically merged - Please don't double post! —

    Can't watch the video it says private video, please I need to know what to do because smashhax doesn't open it prompts me Tu run the program but when I do nothing happens.. Help this is my only entry point to home brew, I'm using Ubuntu mate like I haveamac told us and I followed procedure but got stuck at 73 packages, I'm booting Linux from USB and I have a new 3ds XL with firmware 10.7 and my original game cartridge of smashbros(us) is version 1.0.1(I deleted the updates from version 1.1.5) I got the pcap for 1.0.1 but so far I get stuck at the 73.. I even tried the German or Dutch video tutorial of smashhax and got the same result , stuck at 73, help me
     
  13. Lemmiwinkles

    Lemmiwinkles Member
    Newcomer

    Joined:
    Mar 21, 2016
    Messages:
    11
    Country:
    United States
    Signed up to say I'm having the exact same issue as you. My cartridge is 1.1.0 (US) with N3DS 10.7.0.32U. Same thing with it going back to the homescreen then rebooting. Is there an issue with the pcap file for 1.1.0??
     
  14. Aboshi

    Aboshi Newbie
    Newcomer

    Joined:
    Feb 25, 2016
    Messages:
    6
    Country:
    United States
    I have already posted on this, Yellows8 already stated he only made the pacaps/payload with eshop version. So if you have a physical copy on one of the working version it will not work for you unless you find/change the offset or make a pcap/payload for the physical cart. if you somehow were able to install one of the working updates he created the pcap/payload for you would be fine and this would work, but that us 100% pointless because you would still need a way in the first place to install the game update (browserhax if you are 10.5 or lower).

    I ran into this issue with v 1.1.0 U and I really didn't feel like finding the correct offset and making the pcap/payload so I got rid of smash bros. I kind of want to get another copy and look into it again though as I have more time.

    So again If you have a physical copy this will not work! You will need to create a pcap/payload with the corrected offset for the physical cart.
     
    Last edited: Mar 21, 2016
  15. Lemmiwinkles

    Lemmiwinkles Member
    Newcomer

    Joined:
    Mar 21, 2016
    Messages:
    11
    Country:
    United States
    Ah ok, well that helps somewhat! I like a challenge so I'll look into it. Thanks for your help!
     
  16. Lemmiwinkles

    Lemmiwinkles Member
    Newcomer

    Joined:
    Mar 21, 2016
    Messages:
    11
    Country:
    United States
    [​IMG]

    Well... that was easier than expected. Okay, so in the end my original SD card (with all my saved etc) had the 1.1.2 update (my cartridge is 1.1.0) so I ran the Smashhax with that instead (selecting 1.1.2 instead) and it worked instantly. So if you have a 1.1.0 cartridge, you need to have the 1.1.2 update and run that pcap file instead.
     
  17. Lemmiwinkles

    Lemmiwinkles Member
    Newcomer

    Joined:
    Mar 21, 2016
    Messages:
    11
    Country:
    United States
    Triple posting, but this helps anyone Googling or looking up this thread. After two days I was finally about to downgrade to 9.2 using Smashhax. My method was to downgrade to 10.5 first then use Menuhax from there to downgrade to 9.2. For some reason my 1.1.0 Smash Bros cartridge (with 1.1.2 update) would not allow a downgrade to start, apparently due to Smash Bros requiring a higher firmware than 9.2 to start. Downgrading to 10.5 (using files from a certain Chaos website) and sysupdater (safesysupdater checks for 9.2 MD5's and throws errors) allowed me to rely on menuhax which then allowed me to downgrade to 9.2 flawlessly!

    edit: ended up with a frankenfirmware and couldn't instal emuNAND9 but got lucky in that the browser/settings and menuhax was still able to work. Re-did the downgrade in sysupdater (instead of safesysupdater) without having to upgrade or recover. Now got emuNAND9 installed.
     
    Last edited: Mar 22, 2016
  18. Holy-Freak

    Holy-Freak Advanced Member
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    72
    Country:
    France
    Is there no way to run the hax in 1.1.0 ?
     
  19. Lemmiwinkles

    Lemmiwinkles Member
    Newcomer

    Joined:
    Mar 21, 2016
    Messages:
    11
    Country:
    United States
    If it's a 1.1.0 cartridge then no. The pcap files were compiled using the 1.1.0 eshop update which appear to differ from a stock 1.1.0 cartridge. I got lucky in that I hadn't updated to 1.1.3 and my SD card had the 1.1.2 update which worked.
     
  20. Guriam

    Guriam Member
    Newcomer

    Joined:
    Mar 24, 2016
    Messages:
    40
    Country:
    How can I know which version of Smash I have?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - [Tutorial], smashhax, Using