Discussion To those thinking about updating

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Peabutt, Jun 14, 2018.

  1. Peabutt
    OP

    Peabutt Advanced Member

    Newcomer
    2
    Nov 2, 2017
    United States
    [​IMG]

    To anyone who has been debating on whether or not to update I would hold out a bit longer, especially if you are on 1.0 - 3.0.
    rajkosto has a way to update without burning your fuses and you will be able to downgrade back down if you have a proper NAND backup.
    He should be releasing it in a few days so I would wait if I were you.

    From my understanding though you will have to autoRCM in order for this to work, just fyi.

    EDIT: "Deja Vu has been shown to work up to 4.1" as confirmed by Draxzelex via SciresM below. So if you are still on 4.1.0 or below it might be important to wait as well and make a NAND backup of that firmware.

    EDIT 2: https://gbatemp.net/threads/how-to-...nofficially-without-burning-any-fuses.507461/ Here you go.
     
    Last edited by Peabutt, Jun 15, 2018
    Centergaming, PuNKeMoN, Fuk and 12 others like this.
  2. slaphappygamer

    slaphappygamer Frizzle Fry

    Member
    5
    Nov 30, 2008
    United States
    Aptos, California
    How can updating your firmware burn out fuses? How common is that?
     
  3. SwitchGuy

    SwitchGuy Member

    Newcomer
    1
    May 17, 2018
    United States
    I'm on 4.1, but this is great news. I'd love to be able to move between firmwares in the future without blowing fuses.
     
  4. Draxzelex

    Draxzelex GBAtemp Advanced Maniac

    Member
    7
    Aug 6, 2017
    United States
    New York City
    EmuNAND is still a better option as it lets you run backups separately from SysNAND mitigating the chance for bans, but I guess this could be useful to tide people over until it is released.
     
  5. gog3

    gog3 Advanced Member

    Newcomer
    2
    Dec 30, 2013
    United States
    Updating burns out efuses. It's how Nintendo prevents downgrading. It's very common.
     
  6. slaphappygamer

    slaphappygamer Frizzle Fry

    Member
    5
    Nov 30, 2008
    United States
    Aptos, California
    I now understand that. Thanks for the info.
     
  7. mrtzera

    mrtzera Member

    Newcomer
    1
    May 25, 2018
    Brazil
    only for 1.0.0 and 3.0.0 or between 1.0.0 and 3.0.0?
     
    Centergaming and slaphappygamer like this.
  8. huma_dawii

    huma_dawii GBAtemp Advanced Maniac

    Member
    6
    Apr 3, 2014
    United States
    Florida
    People who is above 4.1.0 can update right? Cause we are pretty much out of luck right now....

    — Posts automatically merged - Please don't double post! —
     
  9. Peabutt
    OP

    Peabutt Advanced Member

    Newcomer
    2
    Nov 2, 2017
    United States
    It will work on all firmwares but...
    1. You need a NAND backup from your switch of the firmware you are trying to downgrade to.
    2. You need to have used this method to update in order to keep your fuses from burning out to be able downgrade back down. For instance, my fuses are burnt up to 3.0 so I can't downgrade back down to 1.0, not to mention I don't have a NAND backup of my switch from 1.0. But if I use this method I could update to the current firmware and then be able to downgrade back down to 3.0 because I didn't burn any more of my fuses when updating.
    3. Its most useful for 1.0 - 3.0 firmware users as it allows them to update without burning out the fuses that keep you from downgrading back down. 1.0 - 3.0 firmwares should be getting a unteathered softmod.

    Well, it would work if you ever wanted to be able downgrade back down to 4.1.0 but that would be kinda pointless as there is nothing special that about that firmware. Up to you really.

    EDIT: "Deja Vu has been shown to work up to 4.1" as confirmed by Draxzelex via SciresM below. So I would wait to update till this is released and make a NAND backup of our 4.1.0 just in case.

    — Posts automatically merged - Please don't double post! —

    Agreed, but this can be useful for temporally being able to update to obtain game updates and play newer games until all of that is ready. I deleted my game updates without realizing it and can't play my carts right now so this is very useful for me atm XD.
     
    Last edited by Peabutt, Jun 14, 2018
    RealSpyKitty and mrtzera like this.
  10. Draxzelex

    Draxzelex GBAtemp Advanced Maniac

    Member
    7
    Aug 6, 2017
    United States
    New York City
    Also, this can also apply to 4.1 users (like myself) as Deja Vu has been shown to work up to 4.1. However it hasn't been released yet because it is not known whether it has been patched out or not in 5.X. If it hasn't, it may be a very long time before it sees the light of day but if it is, then I won't need my paperclip anymore.

    EDIT: Fuck it, I'm sold. Since Atmosphere's ETA is nowhere to be seen, this will be the only way I can play Smash and keep onto my 4.1. Just tell me when rajkosto delivers.
     
    Last edited by Draxzelex, Jun 14, 2018
    Doneo, RealSpyKitty and Peabutt like this.
  11. Peabutt
    OP

    Peabutt Advanced Member

    Newcomer
    2
    Nov 2, 2017
    United States
    Thanks for that, I updated the post with that info as I was unaware of that.
     
  12. Draxzelex

    Draxzelex GBAtemp Advanced Maniac

    Member
    7
    Aug 6, 2017
    United States
    New York City
    Just so I don't get all the credit, this is the softmod I am referring to (all credit should go to SciresM)
     
    Peabutt likes this.
  13. The3rdknuckles

    The3rdknuckles GBAtemp Fan

    Member
    2
    Dec 30, 2015
    United States
    Now if we could use other people’s NAND backups I would cry.
     
  14. Peabutt
    OP

    Peabutt Advanced Member

    Newcomer
    2
    Nov 2, 2017
    United States
    I fixed the post in order to give you both credit. Him for discovering that it still works up to 4.1 and you for pointing it out to me in this thread.

    — Posts automatically merged - Please don't double post! —

    Wouldn't matter right now anyways if you blew those fuses. Can't downgrade back down if the fuse is blown. Now maybe in the future we could bypass the fuse being blow to downgrade that but that might be awhile.
     
    Last edited by Peabutt, Jun 14, 2018
  15. DKB

    DKB what

    Member
    9
    GBAtemp Patron
    DKB is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    May 29, 2015
    United States
    New York City, Manhattan
    That's going to be a big hell no, for like, ever. That would be awesome, but, ain't that still not even possible on the 3DS? Not sure, haven't looked at 3DS homebrew in forever.
     
  16. Lacius

    Lacius GBAtemp Guru

    Member
    13
    May 11, 2008
    United States
    Atmosphere will likely be finished long before December, so you probably don't need to get so dramatically impatient.
     
  17. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    9
    Jan 2, 2009
    Germany
    Maybe I'm just not creative enough, but for what would anyone want to update their firmware and then want to come back to the firmware they previously had?
     
  18. DKB

    DKB what

    Member
    9
    GBAtemp Patron
    DKB is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    May 29, 2015
    United States
    New York City, Manhattan
    Coldboot. Maybe? Prob will happen on later versions anyways.. That's..about it..I guess. There's next to no point. I guess superiority reasons as well? Maybe?
     
  19. Lacius

    Lacius GBAtemp Guru

    Member
    13
    May 11, 2008
    United States
    Untethered warmboot exploits on 1.0.0-4.1.0 and possible untethered coldboot exploits on 1.0.0-3.0.2.
     
  20. Peabutt
    OP

    Peabutt Advanced Member

    Newcomer
    2
    Nov 2, 2017
    United States
    Also to be able to play current games and get game updates until coldboot stuff is ready. I deleted my game cart updates so I cant play any of my games right now and this would fix that.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice