[Theory] Possible method to downgrade from 11.0 without hardmod/DSiWare

Discussion in '3DS - Homebrew Development and Emulators' started by C0mm4nd_, Oct 14, 2016.

?

Is this possible?

Poll closed Oct 15, 2016.
  1. Yes

    1.5%
  2. No

    98.5%
Thread Status:
Not open for further replies.
  1. C0mm4nd_
    OP

    C0mm4nd_ Aspirant Wii U homebrew dev :P

    Member
    697
    337
    Oct 9, 2016
    Italy
    I've been thinking about this thing:
    3DS takes files for upgrade from internet, right?
    If we redirect the search to a custom site (such as tubehax) we can made that 3DS believes that the downgrade files (9.2/10.7) are 11.1.0-34 files
    Is this possible?
    (Sorry for my English, I'm Italian :P)
     


  2. Boogieboo6

    Boogieboo6 @realDonaldTrump

    Member
    944
    1,277
    Jul 30, 2015
    United States
    I think the files would be checked by the console before applying the update. It would throw away the improper files. If this was possible, it would have been done very long ago.
     
  3. TotalInsanity4

    TotalInsanity4 GBAtemp Supreme Overlord

    Member
    7,094
    7,085
    Dec 1, 2014
    United States
    Under a rock
    People have already thought of this, the 3DS and Wii U check version numbers and you can't change those without breaking the signature used to verify them
     
  4. Autz

    Autz GBAtemp Advanced Fan

    Member
    564
    260
    Feb 18, 2016
    Venezuela
    No, because it still has the firmware-list problem. If the system detects that you're trying to install a firmware < of 11.x then it will stop the update and you will be on the same place where you started.
     
  5. C0mm4nd_
    OP

    C0mm4nd_ Aspirant Wii U homebrew dev :P

    Member
    697
    337
    Oct 9, 2016
    Italy
    And with Cartridge is the same thing right?
     
  6. DeoNaught

    DeoNaught ¯\_(ツ)_/¯

    Member
    1,468
    1,289
    Aug 22, 2016
    United States
    Over there ;)
    I think the only way to do this is with a Hacked 3ds with Disabled sig checks, and probly no on the custom site(server), (if someone could explain this? always wondered why)
     
  7. C0mm4nd_
    OP

    C0mm4nd_ Aspirant Wii U homebrew dev :P

    Member
    697
    337
    Oct 9, 2016
    Italy
    I would also like to know how does 3DS updates work :mellow:
     
  8. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,625
    1,171
    Nov 19, 2015
    United States
    No. Emulating the server won't because the 3DS expects data via SSL/HTTPS aka Secure Server. Even if you made your own secure server it wouldn't work because the certificate with be different and / or invalid.

    YouTube on 3DS used HTTP so server emulation was possible aka TubeHax.
     
    XRaTiX, UraKn0x, Conn0r and 2 others like this.
  9. Joom

    Joom  ❤❤❤

    Member
    3,890
    2,618
    Jan 8, 2016
    United States
    I swear I see this same thread at least once a week.

    @dpad_5678, you can make your own update server using NTR and a certain PHP script. It can't be used for downgrading though.
     
  10. Justinde75

    Justinde75 VGM Addict

    Member
    1,653
    2,070
    Feb 14, 2016
    Germany
    Iwatodai Dorm
    Rip hopes and dreams
     
  11. DeoNaught

    DeoNaught ¯\_(ツ)_/¯

    Member
    1,468
    1,289
    Aug 22, 2016
    United States
    Over there ;)
    what if we could do a FrankinFirm that has 1.10 Firm but every thing else as a 9.2 files
     
  12. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,376
    564
    Nov 3, 2015
    Puerto Rico
    Nope, 3ds has a minimum version check on 11.0, so it won't work
     
  13. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,625
    1,171
    Nov 19, 2015
    United States
    So a new NATIVE_FIRM but old (other) firmware files? Dude that's like having the worst of both worlds. Unhackable 3DS but old system files and applications so you would have an old as shit 9.2 system that's not even CFW'able.
     
    gnmmarechal likes this.
  14. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,540
    2,719
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    huh, why would you even do that if it were possible? lmao
     
    TheVinAnator and dpad_5678 like this.
  15. TEINDTPA

    TEINDTPA Banned

    Banned
    128
    46
    Oct 6, 2016
    Mauritius
    Hell
    I got a better one for you! , use a BTTF* time machine and go 10 years in past and go start to work for Nintendo after many years of work you finally know how signature security works! now go back in future and leak all security you know = profit!

    (sorry for my intelligence ,I'm human :P )
    Back to the future*
     
    TheVinAnator and DeoNaught like this.
  16. ADS3500

    ADS3500 GBAtemp Fan

    Member
    329
    99
    Jul 27, 2016
    Canada
    So many people have asked about this and it's not possible. The only ways that downgrading without a hardmod or a second system can be possible in the future is either a primary Dsiware entry point, which might not even be possible, or an arm9 kernel exploit, which would make downgrading pointless.
     
    VeniaSilente likes this.
  17. metroid maniac

    metroid maniac An idiot with an opinion

    Member
    1,800
    718
    May 16, 2009
    It may be possible to inject DSiWare saves in the future - hard to say.

    An ARM11 kernel exploit for downgrading may also happen. It's at least as likely as an ARM9 exploit!
     
  18. ADS3500

    ADS3500 GBAtemp Fan

    Member
    329
    99
    Jul 27, 2016
    Canada
    Would an arm11 kernel exploit for downgrading even be possible? AFAIK the list of minimum versions is stored in arm9, so the only way around that would be by exploiting the arm9 kernel.
     
  19. metroid maniac

    metroid maniac An idiot with an opinion

    Member
    1,800
    718
    May 16, 2009
    ARM11 kernel exploit is how current downgrades to 9.2 work.

    I also thought briefly about other ways of exploiting DSiWare - Petit Computer is similar to Smile BASIC and has QR scanning. It seems exploitable from that, but the real hackers would need to get on that.
     
  20. ADS3500

    ADS3500 GBAtemp Fan

    Member
    329
    99
    Jul 27, 2016
    Canada
    It used to be possible to downgrade with arm11 kernel exploits, but it's not anymore. In the 11.0 update, Nintendo added a list that's stored in arm9 that prevents files from a lower firmware from being installed, and the only way around the list is by exploiting the arm9 kernel which would make downgrading pointless. You can read more about it here: https://gbatemp.net/threads/why-the...simple-explanation-for-the-rest-of-us.441373/
     
    Swiftloke likes this.
Thread Status:
Not open for further replies.