The Definitive vWii Hacking Guide!

Discussion in 'Wii U - Hacking & Backup Loaders' started by CJB100, May 9, 2016.

  1. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    one thing that I had to do was plug the supplementary power cable from the y cable into it's own power source such as a usb power plug. When I would plug both ends to the wiiu it seems like the wiiu wasn't providing enough power to the drive and caused errors. Besides that just make sure you follow the guide to a t.
     
  2. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    I will try the 2nd end of the Y cable in an external USB power brick when I get home, but I would think this would be an "all or nothing" situation -- if it was a power issue, I wouldn't expect it to be able to sufficiently read the boot screen, or the contents of the disk in the first place.

    That's the worst part -- I did. I even reinstalled the aforementioned prior to posting, as what was more likely the issue -- me or the post that's been around for X years... but now I'm at a loss :-)
     
  3. jeannotte

    jeannotte GBAtemp Advanced Fan

    Member
    6
    Jun 15, 2016
    France
    Hello,

    @ np247:

    Do you correctly connect the external hard drive to the back of the Wii U ??

    do not you have to invert usb ports ??
     
    Last edited by jeannotte, Oct 31, 2019
  4. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    All good. I even ended up reversing them just for kicks -- same result :-(
     
  5. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    So I tried every combination of USB port on the Wii, including using a USB power adapter on the Y cable... and now the drive won't detect in USB Loader GX at all anymore...

    I may end up wiping the disk and reformatting and trying again... but... everything did still look legit in Windows.

    Also -- I seemed to have the most luck with the front (2) USB ports rather than the (2) rear. When I went to change this from USB port 0, it said this was not possible due to not running Hermes.
     
  6. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    if possible try a different drive. Also make sure you have all the right files on the sd card.
    edit: come to think of it. I once replaced the sd card with a bigger one just to install a game to my wiiu that didn't fit on my original sd card then I forgot to put it back and I launched usbloadergx and I had the exact issue you had. so all the games were being read but would black screen after launch. I put the old sd card back and it fixed it. I'm not sure what the difference was with the sd cards.
     
    Last edited by comput3rus3r, Nov 1, 2019
    jeannotte likes this.
  7. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    Swapping drives I think is a bit of a moot point -- brand new WD 1TB drive with a generic enclosure and new Y cable. I did end up wiping it entirely, reformatted it again (use the partitioning/stealth guide on page 1) and re-copying over all Wii/GameCube games. I haven't had a chance to do much with it since I had to go to work this AM (and copying took forever).

    I will try the SD card route and post an update... I mean at this point... there are only so many variables right...

    Thank-you for the help thus far!
     
  8. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    yeah, i'm getting the feeling the issue is related to the sd card.
     
  9. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    Very possible. I'm eager to find out for sure.

    Piecing together some of the information from memory (it was 2+ years ago since I modded the WiiU), either this guide had been updated or I used something else to get the Homebrew Channel installed originally. Referencing this guide, I am about 99% sure I did "Installing the Homebrew Channel (Method 1)" on my 5.5.2 install (I don't recall seeing warnings indicating this would not work, or I wouldn't have done it). The Homebrew Channel is installed, lists the contents, etc. -- I'm able to play WiiU games that I loaded using Haxchi, etc. etc. -- however, I was wondering if that could somehow play into USB Loader GX not playing nice with the Homebrew Channel in the vWii?

    (I've loaded other things in the vWii before -- eg: cIOS Installers, etc. without issue -- so I think this is a slim chance, but figured I'd throw it out there)
     
  10. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    Well F.

    Tried a 1 GB SD card (from my Wii) and same thing.

    So current status is:
    - I can load Homebrew Channel (in vWii)
    - I can execute "USB Loader GX"
    - The only way a drive is detected within USB Loader GX is by using the front (2) USB ports (either configuration works)
    - Once a game is executed, it loads into a black screen. The console then becomes entirely unresponsive and has to have the power physically removed from the back.

    I've now tried different drives, SD cards, and Y cables...

    F.
     
  11. ignare

    ignare GBAtemp Regular

    Member
    3
    Feb 9, 2019
    United States
    When I go to USB Loader GX it turns my Wiimote to P2 for some reason. Also, it says it doesn't recognize my External HD even though my Wii U does (before making it hidden). It's on the top USB port on the back of the console like you indicated. What's the problem?
     
    Last edited by ignare, Nov 1, 2019
  12. comput3rus3r

    comput3rus3r GBAtemp Psycho!

    Member
    13
    Aug 20, 2016
    United States
    I'm fairly certain there's something missing in your sd card. double check to make sure all files are there and that the sd card is formatted properly. I say this because like I told you earlier when I swapped sd cards to be able to install a large game I just copied the necessary files to run wup installer but then I forgot about it and when I went to play a vwii game everything loaded up fine in usbloadergx untill i launched the game and got that black screen. At first I was like "wtf" but then I remember I had swapped the sd card. I put my old one back in and it worked again.

    — Posts automatically merged - Please don't double post! —

    You can't use the same hard drive for usbloadergx that you do with the wiiu. You need a separate one formatted properly.
     
    jeannotte likes this.
  13. np247

    np247 Newbie

    Newcomer
    1
    Sep 19, 2010
    Canada
    Hmm. In theory all I should need on the SD card is /apps/usb_loadergx though I thought?

    HBC and all cIOS are installed within vWii, and the game themselves are on the 2nd disk. I may be missing something here, but I thought that was all I would need.
     
  14. np247
    This message by np247 has been removed from public view by x65943, Nov 3, 2019, Reason: Dupe.
    Nov 3, 2019
Quick Reply
Draft saved Draft deleted
Loading...