Hacking Sysmodules not loading

Hephaestus

Well-Known Member
OP
Member
Joined
Sep 29, 2017
Messages
335
Trophies
0
Age
36
XP
1,319
Country
Korea, North
Just set up Atmosphere/Kosmos v13.2.1/0.9.3
Latest Switch Firmware, using Hekate ctcaer 5.0.1 as payload.

Activated Modules with Kosmos Toolbox, but now its stuck on the Nintendo Switch Logo during Boot.
Didnt know i couldnt just activate all at once.
Tried copying over my SD Files again, but it still doesnt boot.

Any way to fix this?
 
Last edited by Hephaestus,

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
19,038
Trophies
2
Age
29
Location
New York City
XP
13,468
Country
United States
Just set up Atmosphere/Kosmos v13.2.1/0.9.3
Latest Switch Firmware, using Hekate ctcaer 5.0.1 as payload.

Activated Modules with Kosmos Toolbox, but now its stuck on the Nintendo Switch Logo during Boot.
Didnt know i couldnt just activate all at once.
Tried copying over my SD Files again, but it still doesnt boot.

Any way to fix this?
Try running ReiNX
 

Hephaestus

Well-Known Member
OP
Member
Joined
Sep 29, 2017
Messages
335
Trophies
0
Age
36
XP
1,319
Country
Korea, North
Well, yeah. I know i can just run a different CFW.
Using SX OS as we speak, but i was kinda looking into actually trying out Atmosphere.
No luck tho. Doesnt get past the loading screen anymore now that i enabled all sysmodules.
Didnt know that was a bad idea and now i dont know how to disable that manually.
 

SomeGamer

Well-Known Member
Member
Joined
Dec 19, 2014
Messages
6,827
Trophies
1
XP
4,924
Country
Hungary
Well, yeah. I know i can just run a different CFW.
Using SX OS as we speak, but i was kinda looking into actually trying out Atmosphere.
No luck tho. Doesnt get past the loading screen anymore now that i enabled all sysmodules.
Didnt know that was a bad idea and now i dont know how to disable that manually.
If you have enabled hid-mitm, try disabling it,
 
Last edited by SomeGamer,

HeyItsJono

Breath of Fresh Heir
Member
Joined
Mar 26, 2011
Messages
213
Trophies
1
XP
285
Country
Have never done that before. Could you tell me how?
I just had this happen to me, and I personally don't think 'delete everything off your SD' is an acceptable firstline solution, so here's how to fix the specific problem!
Navigate to /atmosphere/titles on your SD Card and you'll find a bunch of folders with random letters/numbers. You want to find the folders for each sysmodule you enabled with Kosmos Toolbox and disable them. You do this by entering the right title folder, then going into the flags folder, and deleting the boot2.flag file in that folder. The way you find out which title folder you need to enter is by looking at the config for Kosmos Toolbox!

For example, I'd enabled "hid-mitm", and looking at that config page you see this:
Code:
{
    "sysmodules" : [
        {
            "name"  : "sys-ftpd",
            "tid"   : "420000000000000E",
            "requires_reboot": false
        },
        {
            "name"  : "nxsh",
            "tid"   : "43000000000000FF",
            "requires_reboot": false
        },
        {
            "name"  : "sys-netcheat",
            "tid"   : "430000000000000A",
            "requires_reboot": false
        },
        {
            "name"  : "hid-mitm",
            "tid"   : "0100000000000FAF",
            "requires_reboot": true
        },
        {
            "name"  : "sys-clk",
            "tid"   : "00FF0000636C6BFF",
            "requires_reboot": false
        },
        {
            "name"  : "ldn_mitm",
            "tid"   : "4200000000000010",
            "requires_reboot": true
        },
        {
            "name"  : "emuiibo",
            "tid"   : "0100000000000352",
            "requires_reboot": true
        },
        {
            "name"  : "ojds-nx",
            "tid"   : "0100000000000901",
            "requires_reboot": false
        }
    ]
}

Looking at that, I can see the name of the folder for "hid-mitm" is "0100000000000FAF", so on my SD card I go to atmosphere/titles/0100000000000FAF/flags and delete the boot2.flag file from that folder. This disables the hid-mitm module. So go through and do that for all the modules you enabled - for me it was hid-mtm, ldn_mitm, emuiibo, and sys-ftpd. After that, put your sd back in your switch, and try booting again - it should work!
 

Hephaestus

Well-Known Member
OP
Member
Joined
Sep 29, 2017
Messages
335
Trophies
0
Age
36
XP
1,319
Country
Korea, North
I just had this happen to me, and I personally don't think 'delete everything off your SD' is an acceptable firstline solution, so here's how to fix the specific problem!
Navigate to /atmosphere/titles on your SD Card and you'll find a bunch of folders with random letters/numbers. You want to find the folders for each sysmodule you enabled with Kosmos Toolbox and disable them. You do this by entering the right title folder, then going into the flags folder, and deleting the boot2.flag file in that folder. The way you find out which title folder you need to enter is by looking at the config for Kosmos Toolbox!

For example, I'd enabled "hid-mitm", and looking at that config page you see this:
Code:
{
    "sysmodules" : [
        {
            "name"  : "sys-ftpd",
            "tid"   : "420000000000000E",
            "requires_reboot": false
        },
        {
            "name"  : "nxsh",
            "tid"   : "43000000000000FF",
            "requires_reboot": false
        },
        {
            "name"  : "sys-netcheat",
            "tid"   : "430000000000000A",
            "requires_reboot": false
        },
        {
            "name"  : "hid-mitm",
            "tid"   : "0100000000000FAF",
            "requires_reboot": true
        },
        {
            "name"  : "sys-clk",
            "tid"   : "00FF0000636C6BFF",
            "requires_reboot": false
        },
        {
            "name"  : "ldn_mitm",
            "tid"   : "4200000000000010",
            "requires_reboot": true
        },
        {
            "name"  : "emuiibo",
            "tid"   : "0100000000000352",
            "requires_reboot": true
        },
        {
            "name"  : "ojds-nx",
            "tid"   : "0100000000000901",
            "requires_reboot": false
        }
    ]
}

Looking at that, I can see the name of the folder for "hid-mitm" is "0100000000000FAF", so on my SD card I go to atmosphere/titles/0100000000000FAF/flags and delete the boot2.flag file from that folder. This disables the hid-mitm module. So go through and do that for all the modules you enabled - for me it was hid-mtm, ldn_mitm, emuiibo, and sys-ftpd. After that, put your sd back in your switch, and try booting again - it should work!

I honestly didnt see this reply. You are a lifesaver. Will try it out later!

EDIT: Tried it out yesterday and it worked like a charm!
You really saved my bacon. Thank you so much!
 
Last edited by Hephaestus,

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    T @ Texasauras: SOLILOQUY