SX OS 2.2 Broke USB C Ethernet?

Discussion in 'Switch - Backup Loaders & Modchips' started by jakkal, Oct 18, 2018.

  1. jakkal
    OP

    jakkal GBAtemp Addict

    Member
    12
    Apr 27, 2018
    United States
    Can someone confirm. I have 2 switches right?
    the first switch is on on sx os 2.1 - Ethernet works fine
    second switch is on 2.2 (with usb loading) - Broken ethernet

    I boot the second switch in OFW mode - Ethernet works

    Can someone test and confirm that their Eth works fine with 2.2

    and if it does work, what brand ethernet adapter do you have?
     
  2. johnsnow

    johnsnow Member

    Newcomer
    1
    Oct 7, 2018
    Australia
    2.2 beta broke USB Ethernet for me too
     
  3. lufeig

    lufeig GBAtemp Regular

    Member
    4
    Oct 22, 2009
    Brazil
    São Paulo, Brazil
    i used 2.2 beta on firmware 6.0.1: usb ethernet was broken

    2.2 beta on 5.1.0: usb ethernet working!
     
  4. subcon959

    subcon959 teh retro

    Member
    12
    Dec 24, 2008
    So, we can conclude that there is some incompatibility with 2.2 and 6.0.1?
     
  5. thaikhoa

    thaikhoa GBAtemp Advanced Maniac

    Member
    8
    Sep 16, 2008
    It might be that SX rewrote usb:fs so the original usb function might not work anymore.
     
    CymraegAce likes this.
  6. wurstpistole

    wurstpistole I got 8 warning points

    Member
    11
    Nov 19, 2015
    Gambia, The
    More likely that the USB XCI loading support has something to do with other stuff not working anymore via USB
     
Loading...