Still on 4.01 M33-2

Discussion in 'PSP - Games & Content' started by ocdetective, Oct 13, 2009.

  1. ocdetective
    OP

    ocdetective GBAtemp Advanced Fan

    Member
    601
    0
    Mar 19, 2008
    Malaysia
    OK, my son's UK PSP 2000 is still on 4.01 M33-2 and has been since December last year! He has been quite happily playing pre 2009 games via 2 x Sandisk 8GB pro duo sticks.
    However he would like to play some of the newer games eg FIFA 10. What are my options to play the newer games - can I simply use UMDGEN/Game Decrypter on a game by game basis or do I have to upgrade to GEN 5.50 B-2?
     
  2. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    i would recommend going onto GEN 5.50 B2.
    XGEN Updater Use this, it takes you to GEN B2 without all the hassle.
    FIFA 10 Needs 5.50 to be run too.
    Plus you get to play the other games (:
     
  3. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Handily many of the games actually seem to work on 4.01, and not on the later firmwares. Personally i'd suggest that you update to 5.00M33-6.
     
  4. ocdetective
    OP

    ocdetective GBAtemp Advanced Fan

    Member
    601
    0
    Mar 19, 2008
    Malaysia
    By later firmwares do you mean 5.50 GEN - otherwise you statement seems somewhat contradictory as 5.00M33-6 is later than 4.01M33-2?
    Is it possible to stick on 4.01 and just patch the games that need it on a one by one basis?
     
  5. zektor

    zektor GBAtemp Maniac

    Member
    1,325
    22
    Nov 29, 2005
    United States

    I can second this. No reason to be on an earlier firmware (even 5.00m33-6). GEN 5.50 B2 is rock solid, works great, and plays everything (well, except games that require a higher firmware than 5.50) Even then, there is game decrypter for most of those titles.
     
  6. Sinistral89

    Sinistral89 GBAtemp Regular

    Member
    238
    5
    Sep 12, 2009
    Sweden
  7. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Yes it is contrary, but it seems to hold true. With these latest games they appear to work on 4.01M33-2 following decryption despite requiring further modification to function on the newer 5.00M33-6.

    My advice still remains update to 5.00M33-6.
     
  8. ocdetective
    OP

    ocdetective GBAtemp Advanced Fan

    Member
    601
    0
    Mar 19, 2008
    Malaysia
    Just so that I am 100% clear re updating using the XGEN updater - it requires no special pandora battery - just a cfw of above 3.71 M33?
     
  9. themuddaload

    themuddaload Creepin' hardcore.

    Member
    1,099
    0
    May 4, 2008
    United States
    West of the equator Sex: sure
    yeah, it doesnt require a pandora to update, but you probably need all the ofw files between 4.01 and 5.5