Skyward Sword USB GX Loader Issue

Discussion in 'Wii - Hacking' started by ClimaxEmperor, Dec 26, 2011.

Dec 26, 2011
  1. ClimaxEmperor
    OP

    Newcomer ClimaxEmperor Member

    Joined:
    Apr 2, 2011
    Messages:
    13
    Country:
    United States
    Hey Everyone. I just got LOZ Skyward Sword for Christmas and I'm enjoying it but there are some problems. I accidentaly updated the Wii through the disc but the thing is that the hombrew channel is still in my Wii and it still works. Emulators and all are still working there are just 2 problems. The USB GX Loader doesn't work whenever I load it a message shows up and says: "Failed loading any cIOS. USB Loader GX requires at least cIOS 222 or 245-250. Exiting"

    Just to make matters worse, I tried to activate all the WAD managers I had and they all froze. Secondly, when I play skyward sword, the batteries on my Wiimote plus keeps dying on and off when I use the slingshot/ Dousing ability.

    Basically, I'm asking is there a way for me to fix the USB GX Loader? and my Wiimote?
     
  2. Crimsonclaw111

    Member Crimsonclaw111 GBAtemp Fan

    Joined:
    Apr 7, 2010
    Messages:
    387
    Country:
    United States
    I would just reinstall everything, starting with the HBC; cIOS was probably overwritten and IOS 58 is needed for best functionality at this moment, so far as I know. Especially with USB.
     
  3. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    IOS58 is needed only to launch channels on the Wii menu (Channel or Forwarder).
    If he updated his Wii to 4.3 then he already has IOS58. No need to confuse him with things he don't need to know.


    Just re-hack your Wii.
    The update replaced the cIOS by fake IOS so you can't use USBloader or Wad Managers anymore.


    Start by (re)installing IOS236
    Then install cIOS249
    Done

    All this steps are done automatically by ModMii Tutorial.
     
  4. Crozone

    Newcomer Crozone Member

    Joined:
    Oct 23, 2008
    Messages:
    28
    Country:
    Australia
    I found that simply rehacking your wii will not work (I've been at this for a few hours now). The 4.3 update replaces IOS 222/223 (usb 2.0 support) and 249/250 (iso emulation/loader support) with stubs. It also updates almost every other official IOS, including 15 and 36, overwriting the fakesign bug.

    If you simply delete IOS stub 249 with DOPMii and reinstall cIOS 249, skyward sword will still prompt you to update to 4.3 again, undoing the mod.

    Now, the obvious solution to this would be to bypass the official 4.3 installer and reinstall cIOS 249, except Skyward Sword itself appears to actually check that 4.3 is installed again after the "System Update" has run, and crashes to the System Menu if all the IOSs aren't up to date. At least, I could not find a way (with either preloader or USB Loader GX) to get it to run with any of the 4.3 IOSs altered.

    Anyway, the solution is simply to install cIOS 249, but in the slot of 248 so it doesn't get replaced with the nintendo stub (this is kind of fail on nintendos part, what did they think we were going to do?)

    I used this to install cIOS 249 into slot 248:

    d2x cIOS v7 Installer v3.1
    http://www.mediafire...wy4dvdyben3fj03

    Just select the latest version of the cIOS, use IOS 56 as a base, and install it in slot 248 instead of 249. - EDIT as per Cyan's suggestion

    Or go here: http://gwht.wikidot.com/d2x and install cIOS 247 and cIOS 248 if you want greater flexibility.

    Then, you should be able to configure USB Loader GX to use IOS slot 248 instead of IOS slot 249, and you're good to go.

    Also, if you need cIOS 222 for any reason, that can be installed in slot 202 without issues.

    The latest DOPMii (14.5), doesn't require trucha to gain NAND access (it uses AHBPROT), so you can use it to temporarily downgrade/patch IOS 36 if other homebrew needs it. (this is why your wad managers are crashing, they need the fakesign bug)
    EDIT: - Correction, like Cyan said, cIOS 236 should be installed to get around this issue (cIOS 236 is simply IOS 36 copied and modified with the trucha and some other functionality added. You probably shouldn't touch IOS36 once the system has been updated, although I did and it didn't cause any harm)

    And the reason your wiimote was crashing was because USB Loader was trying to load cIOS 249 when it had already been replaced by a stub, and the system was simply crashing (just in case you were wondering)

    Hope this helps!
     
  5. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    just a correction, use a base 56 in slot 248, not 37.
    56 has better read speed over USB.



    You need to install cIOS d2x based on IOS56, in a slot that you want (from 200 to 252).

    Usually, this is installed in slot 249 and 250, but nintendo check these slot and replace them with non working one.
    So, as Crozone suggested, you can install it in the slot 248.

    Then, when launching USBloaderGX, you will have to manually specify that you want to use 248 instead of 249, by editing the meta.xml and the cfg file.



    My suggestion would be to install the cIOS in the slot 249 as this is the most used slot for USBloaders.
    Then, launch the game using the USBloader (they can even launch Real game discs, and they don't prompt for update).
    But if you dump your games to HDD, it's even better (no laser constrain, faster game access for faster loading time, no need to swap disc every time you want to change games)
     
  6. the_randomizer

    Member the_randomizer The Temp's official fox whisperer

    Joined:
    Apr 29, 2011
    Messages:
    17,372
    Location:
    Unknown
    Country:
    United States
    Try CFG USB Loader, the game runs just fine on that.
     
  7. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    He doesn't have a problem to choose a loader, but a stubed cIOS problem caused by Nintendo.
    But thanks for trying to help.

    About telling the users to use a loader over another one, I recommend users to choose their own USBloader themselves, it's only a matter of tastes.
     
  8. ClimaxEmperor
    OP

    Newcomer ClimaxEmperor Member

    Joined:
    Apr 2, 2011
    Messages:
    13
    Country:
    United States
    UPDATE!!!: I followed both Cyan and Crozone's suggestions on how to fix my USB GX Loader and it worked. But I'm still having issues with my Wiimotion plus. I played Red Steel 2 for the first time in months and just like with skyward sword, it crashes during certain playstyles. Ironically they both crash when I'm using the sword. Also I tried to install cIOS 249 with the new installer and just like all the old ones the Wii keeps crashing. So pretty much my Wiimotion plus is still and issue. I'm still opening the floor to solutions but I'm starting to think that this is a battery problem.
     
  9. Crozone

    Newcomer Crozone Member

    Joined:
    Oct 23, 2008
    Messages:
    28
    Country:
    Australia
    Just to confirm, is this the Wii Motion Plus that's built into the controller, or the external one on a standard Wiimote? I'm not sure if there is a difference, I heard there may have been an IOS update to get the internal one to work (although I don't see why it would be different)

    Either way, did you modify any of the previous IOSs in your first softmod? (this is probably irrelevant, since most of them would have been replaced or stubbed by the nintendo LoZ SS installer, but I'm just trying to determine if it could be a software issue)
     
  10. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,433
    Location:
    Engine room, learning
    Country:
    France
    There's no IOS update needed at all.
    The only IOS to update and which is used when using an USBloader is the cIOS (249, 250, etc.), all other IOS version are irrelevant.


    Maybe it's a battery issue, but you know, the Sword's spirit doesn't stop calling you to tell you that the battery is low on power, one hour before it's really low, so you know when it's really low :P
    I'm using an external Motion+ and I don't have any problem, even with low battery.

    Are all your Wiimote/motion+/nunchuck retail from Nintendo?
     
  11. CheatFreak47

    Member CheatFreak47 Complex Donut

    Joined:
    Oct 11, 2011
    Messages:
    1,190
    Location:
    Michigan, USA
    Country:
    United States
    i doubt its a software issue, one of my motion accessories died and is doing the same thing. i bought a new wiimote+ and it works fine. try a different wiimotion plus or wiimote plus on it and see if it works.
     
  12. Lucif3r

    Member Lucif3r GBAtemp Maniac

    Joined:
    Sep 10, 2011
    Messages:
    1,464
    Country:
    Sweden

    Huh, how much power are your wiimotes using? :P
    I played for 6h straight after Fi started whining before the Wiimote died lol

    (sorry for ot)
     
  13. ramidavis

    Newcomer ramidavis Advanced Member

    Joined:
    Mar 26, 2009
    Messages:
    92
    Country:
    United States
    So, if my wii can paly other motion plus games like Sports Resort, using USB loader GX 2.2, then that loader should have no problem with Zelda, and the motion plus giving out issue is just a low battery and not a problem with ios or anything?
     

Share This Page