Should I upgrade the system's software or not?!

Discussion in 'Wii - Hacking' started by Collateral, Dec 2, 2008.

  1. Collateral
    OP

    Newcomer Collateral Newbie

    Joined:
    Dec 2, 2008
    Messages:
    2
    Country:
    Israel
    Hi, I was just trying the other say to access the Wii shop channel and then I got a message saying that I need to upgrade my version before I can use it.
    My current system version is 2.2, so should I upgrade it or not, and if not then why, and what can I do (if I want to get stuff from the shop)
    Thanks!
     
  2. harryk

    Member harryk GBAtemp Regular

    Joined:
    Oct 8, 2008
    Messages:
    207
    Country:
    Austria
    2.2 is pretty old. 3.2 would be good, but you can't get it from the Nintendo server without tricks.

    You can, however, install the shop upgrade and mii upgrade via homebrew packages.
     
  3. screamq3

    Member screamq3 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    188
    Country:
    United Kingdom
    read in the forums mate about updating, quite straight forward with the right guide [​IMG] get on 3.2 and put starfall on [​IMG]
     
  4. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    3.3 is also fine, why do people assume 3.2 is the best simply because of trucha signed discs? Well that and freeloader.

    http://wiibrew.org/wiki/System_Menu_3.3

    Look at what's affected, if you have no problems with no Freeloader (Gecko OS is a work around it says) then go to 3.3 VANILLA.

    3.3b screwed up a few things IIRC.

    I'm honestly tired of reading "3.2 is the best" simply because a small minority of people who use trucha signed discs, 3.3a is safe too for most people who don't use freeloaders (And even if that's the case you can use GeckoOS as a work around) or want to have an uncensored Manhunt 2, etc.

    The problem is that some WiFi games will not work with a friend unless you're on the same version, Mario Kart Wii has issues with 3.3 playing anyone below 3.3.

    If you need to access the shop channel:
    http://wiibrew.org/wiki/Wii_Shop_and_IOS51_installer
     
  5. gundalf

    Member gundalf GBAtemp Fan

    Joined:
    Sep 26, 2008
    Messages:
    365
    Location:
    Germany
    Country:
    Spain
    I dont think that trucha disc's are only for an "small minority of people" people important.
    Oh and dont forgett the WADs.
     
  6. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    What about them? WADs weren't affected by 3.3 vanilla. I even linked to the changes. And trucha discs seem like novelty for me and not enough to hold the general public from upgrading to 3.3. Especially when I just said Mario Kart Wii has issues with 3.3 with any Friend below it.
     
  7. gundalf

    Member gundalf GBAtemp Fan

    Joined:
    Sep 26, 2008
    Messages:
    365
    Location:
    Germany
    Country:
    Spain
    Ah was thinking wrong.
    Good to know that, for people who play with Wii Online.
     
  8. MrBubbles

    Member MrBubbles GBAtemp Fan

    Joined:
    Oct 19, 2007
    Messages:
    323
    Location:
    USA
    Country:
    United States
    If he wants to go to 3.2 that's fine, I just think 3.3 has a been given a negative reputation. The standard 3.3 only managed to kill the old TP hack and it was fixed in what...48 hours?

    Freeloader users can use GeckoOS so no need to spend money.

    Trucha-signed discs shouldn't stop most people from going to 3.3, but if they want to have 'the best' system it does have its down side. Mario Kart Wii as I said numerous times (Sorry for sounding like a broken record) will not work with 3.2. I believe Animal Crossing is the same, I am not sure though.
     
  9. trancepara

    Member trancepara GBAtemp Regular

    Joined:
    Oct 3, 2008
    Messages:
    124
    Country:
    United States
    Don't forget about Starfall, that only works on 3.2. :/
     
  10. ether2802

    Former Staff ether2802 we have the techno...!!

    Joined:
    Oct 14, 2007
    Messages:
    4,350
    Location:
    Pto. Vallarta
    Country:
    Mexico
    ....adn if you're installing the BUL channel, the NES channel, the qeriubqprv channel, the 91834y'981 channel, is good to be in 3.2 with Starfall, and not have the need of a ModChip...!!! [​IMG]
     
  11. EmperorOfCanada

    Member EmperorOfCanada GBAtemp Maniac

    Joined:
    Aug 4, 2008
    Messages:
    1,478
    Location:
    Canada
    Country:
    Canada
    Starfall is the reason 3.2 is so important (moreso for those who install wads) not only that but the skip disk update is nice too [​IMG]
     

Share This Page