Should I update my DSi to 1.4E now?

Discussion in 'Acekard' started by Kacee, Jan 2, 2010.

  1. Kacee
    OP

    Kacee Newbie

    Newcomer
    9
    0
    Jan 2, 2010
    Hello,

    My first post here, nice board.

    I ordered my Acekard 2i from DealExtreme and according to them the package will be arrived in about a week.

    Currently I'm using R4i from r4i-sdhc.com, first gen so incompatible with DSi firmware 1.4, it has firmware 1.3E currently. There are some rumors that Nintendo is rolling out firmware 1.5 and decided to block the flashcard again, which is very likely. So I want to update my DSi now to 1.4 and wait for the Acekard to arrived.

    However, that's mean I can't play any game after update.

    I know maybe nobody has the exact answer but is it safe to wait for about a week and still be able to update to 1.4 or maybe Nintendo will roll out their 1.5 firmware very soon?

    My DSi is EU version, current firmware is 1.3E, anyone have the same EU version can you confirm that Nintendo hasn't roll out 1.5 firmware?

    PS: I'm not a native English speaker so sorry if my English is broken.
     
  2. iFish

    iFish Slower than a 90s modem

    Member
    4,223
    159
    Jul 11, 2009
    Canada
    Montreal, QC
    if you have a ds litethen update not then update the ak2i after
     
  3. grimtooth

    grimtooth GBAtemp Regular

    Member
    101
    0
    Nov 28, 2009
    under the stairs
    Hey Kacee,
    the latest firmware is still 1.4, i use 1.4E myself. i doubt they will release 1.5 in the next week, so you should be save to stay with 1.3.
     
  4. Kacee
    OP

    Kacee Newbie

    Newcomer
    9
    0
    Jan 2, 2010
    Thanks a lot, that's good to know.
     
  5. rockstar99

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    no dont
     
  6. CannonFoddr

    CannonFoddr Regular GBATemp Lurker

    Member
    4,115
    68
    Sep 23, 2006
    Sitting by computer
    If you can live without the facebook app & the nintendo DSi Shop (& browser) then I suggest DON'T upgrade at all until we know for certain what 1.5 Firmware actually does

    Once we know what it does (& if it blocks flashcards again) then I suggest you still wait until AK brings out a fix for the 1.5 before upgrading - as I'm sure Ak will create a fix that allows you to upgrade the AK straight to 1.5 fix status
     
  7. Danny Tanner

    Danny Tanner GBAtemp Fan

    Member
    361
    0
    Dec 28, 2009
    United States
    New York
    I would update now. There's a fix for the Acekard 1.4 and not 1.5. We don't know (a) when 1.5 will be released or (b) how long after an acekard fix will come. You may get stuck with 1.3 for an indefinite amount of time once 1.5 is released.
     
  8. Hakoda

    Hakoda GBAtemp Addict

    Member
    2,133
    2
    Feb 2, 2008
    United States
    San Jose, CA
    Update your DSi to 1.4E AFTER your AK2i comes. When it does come, run the 1.4 AK2i update using your 1.3E DSi. Once the update for the AK2i is complete, update your DSi to 1.4E and wait for news on 1.5E.

    ~ Jon