1. justinkb

    justinkb GBAtemp Advanced Fan
    Member

    Joined:
    Oct 7, 2012
    Messages:
    621
    Country:
    Netherlands
    Because the save hook only is activated once the game is suspended by pressing home.
     
  2. justinkb

    justinkb GBAtemp Advanced Fan
    Member

    Joined:
    Oct 7, 2012
    Messages:
    621
    Country:
    Netherlands
    How do you mean press the home button repetitively?
     
  3. logon

    logon GBAtemp Regular
    Member

    Joined:
    Jun 8, 2008
    Messages:
    128
    Country:
    New Zealand
    I pressed the home button multiple times as fast as I could and then closed the software
     
  4. justinkb

    justinkb GBAtemp Advanced Fan
    Member

    Joined:
    Oct 7, 2012
    Messages:
    621
    Country:
    Netherlands
    Why? Press it once to suspend the app, then wait a few seconds for the save to get written to the sdcard.
     
  5. MadButch

    MadButch Advanced Member
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    51
    Country:
    Netherlands
    I just did that, and it hung after pressing close on the home screen (yes, I waited 10 seconds...)


    The text you quoted literally says "do NOT press home button"...

    I will try the power of on the main screen (start up screen) of the game next time...
     
  6. justinkb

    justinkb GBAtemp Advanced Fan
    Member

    Joined:
    Oct 7, 2012
    Messages:
    621
    Country:
    Netherlands
    Interesting, do you run it from emunand?
     
  7. logon

    logon GBAtemp Regular
    Member

    Joined:
    Jun 8, 2008
    Messages:
    128
    Country:
    New Zealand
    I can confirm this also happened to me. I was running on emunand 6.3 Europe
     
  8. MadButch

    MadButch Advanced Member
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    51
    Country:
    Netherlands
    My setup is emunand (same as system nand). So I haven't updated emunand to 6.3 yet (because I was reading posts about people still ending up on 6.3 system nand).

    I'm also having tons of trouble starting up now.. like 1 in 3 times my gateway will actually boot after selecting the ds profile. The other times it hangs with stripes on the screen.

    I'm actually thinking about going back to 1.2 fw due to this... But I'll try 6.3 emunand first, and see if that helps...
     
    f0rCe likes this.
  9. Railgun

    Railgun ( ' _ ' )
    Member

    Joined:
    Feb 20, 2006
    Messages:
    326
    Country:
    Gambia, The
    EmuNAND @ 6.3 (EU) here.
    As stated on the first page, I only have saving problems when I enter the GW-Mode not over the new Menu.
    If I press "L" on the DS-Settings and then launch the GW-Mode, Zelda saves fine with no crashes. Not even one! And I saved now like 50 times or more.
    If I launch the "autodetected" GW-Mode without pressing the L-Button first to get into the Menu, i can barely save. It will crash nearly all the time.
     
  10. temp1312

    temp1312 Advanced Member
    Newcomer

    Joined:
    Dec 3, 2013
    Messages:
    67
    Country:
    United States
    According to my uncertain knowledge from the internet I think the hook is not activated when the game is "suspended" but "closed", that's why you have to press X after press home.
    Pressing the power button will terminate the game without prompting, means the OS just did the "pressing X" operation for you automatically, the very operation provokes the hook to do the copy thing.
    Anyway, I don't have a card for testing, hope someone can compare the crash possibilities of below 4 means:
    1, Press HOME -> Press X
    2, Press HOME -> Just wait for 10 sec
    3, Press Power -> Touch to power off
    4, Press Power -> Press HOME to go back the home screen.
     
  11. rbdesigns

    rbdesigns Newbie
    Newcomer

    Joined:
    Sep 13, 2009
    Messages:
    4
    Country:
    United States
    So here's the way I found that works with saving:

    Save your game.
    When you're ready to leave the game press start and "quit".
    At the prompt saying all progress will be lost you say yes. This will send you back to the game's home screen. Wait a few seconds for good measure.
    Then press Power and wait a few seconds.
    Then I press Power Off.

    I have found it's pretty reliable.

    I did this with and without emunand and it works very well with both.
    If I end up crashing at some point I'll report on it.
     
  12. dagro

    dagro GBAtemp Regular
    Member

    Joined:
    Nov 20, 2013
    Messages:
    225
    Country:
    I am on normal gateway mode with 4.5 firmware on my 3ds just tried saving 6 times in a row by pressing the power off button and turning it off when prompted. It seems to save every single time. I am certain it saved everytime as I stood near pots and save bird and get 1 rupee each time before saving to know for certain.
     
  13. Runehasa

    Runehasa GBAtemp Regular
    Member

    Joined:
    Oct 12, 2007
    Messages:
    291
    Country:
    United States
    Has anyone had any saving issues not using the EMUNAND. I figured I would give that a try (Reformating my sd card) and letting it run like it has in the past. Just curious if anyone else has tried this and has had 100% success rate or not
     
  14. rbdesigns

    rbdesigns Newbie
    Newcomer

    Joined:
    Sep 13, 2009
    Messages:
    4
    Country:
    United States
    Yes, if I don't save the way I posted previously, I have issues. That's using AND not using the emuNand.
     
  15. bkifft

    bkifft avowed Cuthwaldian
    Member

    Joined:
    Jun 10, 2010
    Messages:
    613
    Country:
    Gambia, The
    duane, duane, duane... always quote your sources.
     
  16. Runehasa

    Runehasa GBAtemp Regular
    Member

    Joined:
    Oct 12, 2007
    Messages:
    291
    Country:
    United States
    Ok so playing from 4.5 doesnt seem to effect this saving problem one way or another. I am attempting to save using the power button method as posted earlier in this thread. Ill let you all know if it fails at some point.
     
  17. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,208
    Country:
    France
    As this problem doesn't occur with Zelda only, I edited the thread's title.
    It will prevent one thread per game ;)
     
  18. dagro

    dagro GBAtemp Regular
    Member

    Joined:
    Nov 20, 2013
    Messages:
    225
    Country:
    Noticed a slight problem when using this method usually when I want to save I press power > home > back into game (usually when battery is dying) but I can't do that in this case as the home section is not clickable and I smash home button but it just shows the power off button so I have to restart and relaunch gw
     
  19. Runehasa

    Runehasa GBAtemp Regular
    Member

    Joined:
    Oct 12, 2007
    Messages:
    291
    Country:
    United States

    Well as long as it still saves that is the most important thing. Hopefully the Gateway team will address this soon as this is a very annoying bug. I am still incredibly grateful to them for their hard work and hope the rest of you can remain the same even when frustrated.
     
  20. MadButch

    MadButch Advanced Member
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    51
    Country:
    Netherlands
    I tried the power button, and the system just hung after I clicked "power off" (again, after waiting at least 10 seconds).

    I updated my emunand to the latest fw (6.3 eu).
    Started the game, saved, quit, pressed home, waited for over 10 seconds, pressed close, system still hangs.

    So far, not good at all.

    But here is what I did find that works:
    Boot into gw mode (pick your poison, aka emunand or not).
    Start the game, immediately or asap save and quit.
    Wait a few seconds, press home.
    Wait 10 seconds, press close.

    If this doesn't hang your system, then just boot the game up again, and now you can play.
    This should be safe, as I've (so far) never had it hang on closing if it worked the first time.

    If it does hang, reboot your system and try the whole thing again.

    This is a hassle, but at least it seems to save reliably this way (again, if it works the first time, any following time seems to work as well).

    For zelda, I also started to close the game more often after saving. That way if it does go wrong (which hasn't happen so far), I've only lost my last sessions...

    Happy playing!
     
    n1ghty likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - problem, Gateway,