Safehax PM init failed

Discussion in '3DS - Homebrew Development and Emulators' started by Stephano, Apr 24, 2017.

  1. Stephano
    OP

    Stephano I love you Charlie

    Member
    1,197
    1,016
    Feb 18, 2016
    United States
    On the floor of the Engineering building
    So I'm following the guide trying to downgrade an O3ds on 9.5. I get into the homebrew launcher, successfully run udsploit, but when I try to run safehax, I Get [!] PM init failed every single time. Does anyone have any insight on this?
     
  2. Decooter

    Decooter Advanced Member

    Newcomer
    55
    4
    Jun 16, 2011
    United States
    Yes, I ran into this exact same issue while trying to follow the guide for my brother's o3ds on 10.3.

    It seems that udsploit doesnt actually work for older firmwares (and for some reason phialects guide doesn't cover this).

    The way I finally succeeded was by downloading an old version of 'fasthax' (the beta 4, jan 8th release) and old version of 'safehax' (version r19, jan 8th). You can find older releases on the same github the guide links to. Use fasthax instead of udsploit and follow the guide the rest of the way.

    Hope this helps you like it did for me. Also hopefully phialect will update his guide to reflect that the 11.3 methods don't work for certain older firmwares
     
    Last edited by Decooter, Apr 24, 2017
    Toscanelli and Quantumcat like this.
  3. Stephano
    OP

    Stephano I love you Charlie

    Member
    1,197
    1,016
    Feb 18, 2016
    United States
    On the floor of the Engineering building
    I used fasthax and i got a different error this time. I received the error, "Failed to read the arm9 payload!" When i tried another build of safehax, i still go the "PM init failed" error. :unsure:
    Edit: I forgot to rename my .bin file.....
    ugh, i'm dumb :rofl:
     
    Last edited by Stephano, Apr 24, 2017
  4. Decooter

    Decooter Advanced Member

    Newcomer
    55
    4
    Jun 16, 2011
    United States
    Glad it worked out for ya!
     
  5. Pokeeon

    Pokeeon Newbie

    Newcomer
    1
    0
    May 2, 2017
    United States
    Thank you sooo much for this, you saved me. Im on 10.1 on my o3ds and this worked. Thank you! Curious if you don't mind, how do you find out this works?
     
  6. Decooter

    Decooter Advanced Member

    Newcomer
    55
    4
    Jun 16, 2011
    United States
    I spent about 4 hours trying to diagnose the problem and tried just about everything until I stumbled upon that solution.

    Glad it's helping others
     
  7. AaronGH

    AaronGH Member

    Newcomer
    11
    3
    Apr 25, 2017
    Mexico
    Thanks a lot :)
     
  8. relminator

    relminator #AnyaBasic

    Member
    364
    20
    May 28, 2010
    Mine was 10.3.0 O3DS too and the steps in 3ds.guide worked perfectly.
    I had the PM init failed issue too which was fixed by turning the wifi on.