Run automatically emunand

Discussion in '3DS - Flashcards & Custom Firmwares' started by Virdoo, Feb 6, 2016.

  1. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    Can someone give me some tutorial how to run emunand automatically? I have tried one with menuhax, but after entering menuhax my screen stays black.
     
  2. Starkgod

    Starkgod Member

    Newcomer
    27
    4
    Feb 16, 2015
    United States
    Uhh. Are you on cfw or GW? I'm pretty sure there are tuts on this everywhere. I personally have only set it up on rxtools. I'm not entire sure if the process is the same across the board.
     
  3. Quantumcat

    Quantumcat Dead and alive

    Member
    11,551
    6,214
    Nov 23, 2014
    Australia
    Canberra, Australia
    Did you update your sysNAND after setting up menuhax? In this case you have to update your payload.
     
  4. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    I'm using RXtools 2.6, CFW, not GW. Also my Sysnand is on 9.2 and emunand on 10.5
     
  5. ScarletDreamz

    ScarletDreamz [Debug Mode]

    Member
    2,794
    1,200
    Feb 16, 2015
    United States
    California
    i don't know why, but, i was NEVER able to make menuhax booted RxTools.dat from RxTools 2.6, if that's the issue with you, use the latest nightly of RxTools, or switch to Reinand Mod, menuhax works great with those, i was never able to make it boot with rxtools.dat, someone said that i needed to look for the correct offset, which i didn't intended to, lolz.
     
  6. mitroux

    mitroux GBAtemp Regular

    Member
    263
    51
    Sep 12, 2007
    Macau
    you have to use one of the nighty rxtools to auto boot to emunand
     
  7. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    Yes, i did. But it still did the same.
     
  8. squee666

    squee666 Advanced Tech Pleb

    Member
    1,592
    897
    Sep 17, 2010
    Belfast
    yeah RXtools.dat is weird.

    When you use the latest nightlys you have to make it autoboot

    code.bin in the rxtools/sys folder or the .3dsx file in homebrew.

    this is with ctrboot
     
  9. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    I need whole process again, so can anyone provide me some tutorial? BTW. my sysnand is on 9.2 but emunand on 10.5
     
  10. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    So, still no help? Autoboot to emunand on 10.5?
     
  11. DKB

    DKB FUCK OFF

    Member
    GBAtemp Patron
    DKB is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,271
    1,232
    May 29, 2015
    United States
    New York City, Manhattan
    https://gbatemp.net/threads/ctrbootmanager-3ds-boot-manager-loader-homemenuhax.398383/

    That's what I use to autoboot into EmuNand..if you mean by autobooting..not touching it until it gets to that point. If that's what you mean, then, CtrBootManager is the best way to go to my knowledge. If you mean coldboot into it, that won't be happening, it's possible I heard, but I don't know any public methods.
     
    Last edited by DKB, Feb 7, 2016
  12. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    Thanks, I will check it now

    — Posts automatically merged - Please don't double post! —

    Guide says its only up to 9.2 version
     
  13. DKB

    DKB FUCK OFF

    Member
    GBAtemp Patron
    DKB is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,271
    1,232
    May 29, 2015
    United States
    New York City, Manhattan
    Yeah..you can only get emunand on 9.2.

    What version is your sysnand? If it's 10.5, you ain't getting emunand without a hardmod and a downgrade to 9.2.

    Otherwise, it supports emunand..until..whatever. Versions don't matter.
     
  14. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    Well, my sysnand is on 9.2 but emunand is on 10.5

    — Posts automatically merged - Please don't double post! —

    Oh God.. Same error happened:r My screen stays black after selecting RXtools. Any help?
     
  15. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    What are you using to boot into RXTools? If you're using CTRBootMger, post your config file.
    If you're using a hax method, make sure its 2.5 and you have the correct FW.

    That and I didn't even think 2.6 was capable of 10.5 emunand, or are you using a nightly now? (I'm assuming O3DS)
     
    Last edited by gunner007, Feb 7, 2016
  16. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    I'm using CTR with default config file. Didn't touch anything.

    I.E. problem fixed. I have download some rxtools files and fixed it. Can you please explain me how to add Rxtools in first place to boot? Instead of other hack which is on first place
     
    Last edited by Virdoo, Feb 7, 2016
  17. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Does it look like this?

    title = "rxTools";
    path = "/rxTools/sys/code.bin";
    offset = "0x12000";

    Also, whats the heirarchy of your RXTools folder? (Also you didnt say which version of RXTools you're on now, nightly/2.6/?)

    My guess is either you have the old 2.6 still on there (pretty sure this doesn't work with 10.5)
    Or you have a nightly, and the incorrect FIRM
     
    Last edited by gunner007, Feb 7, 2016
  18. Virdoo
    OP

    Virdoo GBAtemp Advanced Fan

    Member
    804
    55
    Jan 12, 2016
    Croatia
    I have changed in boot.cfg and it's autobooting and working. Thanks guys. Problem is solved.
     
  19. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    You should post a new question instead of editing the old one I almost missed your 2nd question. Like I said, it sounded like you had a missing/incorrect FIRM.

    Anyways, if you're using CTRBootMgr, the order is whatever you list them in. (though you can set a default boot anyways by editing default = 0; and changing that to whatever number in the list)

    Just edit the boot.cfg and reorder the list (keep in mind you still need to keep the syntax together (open and close brackets etc...)