Homebrew return to usbloader gx after playing a wii title?

eriol33

Well-Known Member
OP
Member
Joined
Jan 2, 2014
Messages
1,251
Trophies
1
Location
Amsterdam
XP
3,296
Country
Netherlands
hello, everytime I finished playing a wii title through usb loader gx, I will be directed to the wii's nand channels. is there any way to redirect it to the usb loader gx?
 

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,399
Trophies
0
Age
54
XP
1,516
Country
United States
That would be the forwarder channel. Don't use the old USB Loader GX channel. It's no longer maintained.
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
what is the proper way to use/install the forwarder channel cuz when I installed it all I get is a black screen upon launching it. I am 4.3e and have iOS 249 and 250 installed.
 

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,399
Trophies
0
Age
54
XP
1,516
Country
United States
what is the proper way to use/install the forwarder channel cuz when I installed it all I get is a black screen upon launching it. I am 4.3e and have iOS 249 and 250 installed.

Make sure you installed the v5.1 forwarder for the proper console (Wii or vWii), you have IOS58, and that you don't have the full USB Loader GX channel installed. (It has a "c" after its version on the credts screen.)

Also, don't post the same issue in multiple threads.
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
Make sure you installed the v5.1 forwarder for the proper console (Wii or vWii), you have IOS58, and that you don't have the full USB Loader GX channel installed. (It has a "c" after its version on the credts screen.)

Also, don't post the same issue in multiple threads.

Ok my apologies on posting the same issue on 2 threads won't happen again. I did install the 5.1 forwarder for wii and not vwii from this page https://sourceforge.net/projects/usbloadergx/. I am not sure if its the full channel though or not as every time I try to run it/load it all I get is a black screen. Also, How do I check what IOS's I have installed? I was under the impression that if you are on 4.3 that IOS58 comes installed with it? Should I just do a system check and post it?

EDIT: I tried to run a syscheck to post the results but I get the following error message: "failed to get the stored TMD size for IOS56"
 
Last edited by r3dxk1ng,

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,399
Trophies
0
Age
54
XP
1,516
Country
United States
It sounds like you have something wrong with your NAND. Follow the instructions in the SysCheck post about disabling that IOS so it can finish the report.
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS61 (rev 4890).

Region: NTSC-U
System Menu 4.3U (v513)
Priiloader installed
Drive date: 02.13.2007
Homebrew Channel 1.1.2 running on IOS61

Hollywood v0x11
Console ID: 111860887
Console Type: Wii
Shop Channel Country: United States (49)
Boot2 v4
Found 63 titles.
Found 39 IOS on this console. 10 of them are stubs.

IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56: Skipped
IOS60 (rev 6174): No Patches
IOS61 (rev 4890): No Patches
IOS80 (rev 6944): No Patches
IOS249[56] (rev 65535, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
IOS250[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS254 (rev 65281): BootMii
BC v5
MIOS v9
Report generated on 08/25/2016.

Done. I skipped the IOS56 since it was causing me issues. What do you make of my syscheck? If have to install missing IOS's (58) I can use d2x-cios-installer for that correct? What settings would I use to install that IOS?
 
Last edited by r3dxk1ng,

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
Yea it happens with every game. Do you have IOS58 installed because I don't think I do based on my system check although from what I understand it SHOULD be included with 4.3U which I do have so I don't understand what is wrong. Do you know how I can install it using d2x-cios-installer (or any other way of installing it for that matter) and what settings to use?
 
Last edited by r3dxk1ng,

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,399
Trophies
0
Age
54
XP
1,516
Country
United States
You can make an IOS58 wad with ModMii and use a mod manager to install it. The forwarder needs it as does Nintendont any quite a few other homebrew apps.
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
You can make an IOS58 wad with ModMii and use a mod manager to install it. The forwarder needs it as does Nintendont any quite a few other homebrew apps.

Ok I will try that thanks but shouldn't I already have 58 being that im on 4.3U? Were you able to see my system check? any insight on what is wrong?
 

GreyWolf

Well-Known Member
Member
Joined
Mar 2, 2015
Messages
5,399
Trophies
0
Age
54
XP
1,516
Country
United States
I'm not sure what's wrong. Yes, IOS58 should have been installed with 4.3 but if the console was updated outside of Nintendo's system it could have been missed. I'm not sure what's wrong with your IOS56 but if it's giving an error about the TMD (title metadata) file then it's probably corrupted. AFAIK a number of games use 56 when launched from retail disc.
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
I'm not sure what's wrong. Yes, IOS58 should have been installed with 4.3 but if the console was updated outside of Nintendo's system it could have been missed. I'm not sure what's wrong with your IOS56 but if it's giving an error about the TMD (title metadata) file then it's probably corrupted. AFAIK a number of games use 56 when launched from retail disc.

Understood. Thank you for the explanation. Is there anyway for me to fix and/or re-install IOS56?
 

r3dxk1ng

Active Member
Newcomer
Joined
Aug 25, 2016
Messages
31
Trophies
0
Age
40
XP
110
Country
United States
You can download it with ModMii, too. Untouched system IOSes are on download page 1. ("56" and "58")

SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.3U (v513)
Priiloader installed
Drive date: 02.13.2007
Homebrew Channel 1.1.2 running on IOS61

Hollywood v0x11
Console ID: 111860887
Console Type: Wii
Shop Channel Country: United States (49)
Boot2 v4
Found 67 titles.
Found 41 IOS on this console. 10 of them are stubs.

IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 512): Stub
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 6174): No Patches
IOS61 (rev 4890): No Patches
IOS80 (rev 6944): No Patches
IOS249[56] (rev 65535, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
IOS250[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS254 (rev 65281): BootMii
BC v5
MIOS v9
Report generated on 08/25/2016.

Ok after (re)installing 56 and and installing 58 using modmii my USB Loader Gx now functions properly and I can do system check without having to skip an IOS and I don't get any errors. When loading GX from the channel using the forwarder I no longer get a black screen and when setting "return to" USB Gx loader after exiting a game it goes back to Gx USB loader. My issue has now been resolved! Thank you very much for your help GreyWolf! I hope this thread is of help to someone else who has the same problem in the future!
 
  • Like
Reactions: GreyWolf

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Xdqwerty @ Xdqwerty: a classic