Retroarch wii 1.2.1 working

Discussion in 'Wii - Emulation and Homebrew' started by Yamawaki, Jul 18, 2015.

  1. Yamawaki
    OP

    Yamawaki Newbie

    Newcomer
    7
    4
    Jul 18, 2015
    I decided to create a new thread about this rather than tag on to the old retroarch one. Ok so many guys are having trouble with the new retroarch 1.2.1 and I was one of those guys having trouble. Black screen, controllers not working, games not booting,etc,etc.. So how do you get it to work?

    Firstly, retroarch is fussy, I recommend you rename your /retroarch folder in the root to something like OLDretroarch this way it won't get confused with old .cfg config files,etc. You can then create a new root folder called retroarch (this is where retroarch stores config files)

    Why are you getting black screen when booting with homebrew loader or channel forwarders? Basically the folder in /apps where you store boot.dol must be called retroarch-wii go ahead and make a folder apps/retroarch-wii and copy all the files from the 1.2.1 archive (the boot.dol, cores and .info files,etc)

    By following the above it will boot up via a channel forwarder or homebrew channel. As stated before, games won't boot from USB (this is a bug I hope they will fix soon), I'm running this new retroarch via Wiiflow and games stored on USB will work if you load them via Wiiflow.

    I hope that helps some people and if you have anything to add to this please let me know. Thanks.
     
    oji likes this.
  2. ngs428

    ngs428 GBAtemp Regular

    Member
    197
    36
    Dec 30, 2014
    United States
    In 1.2.2 I get random black screens/kicking me out of a menu item I selected. Specifically when selecting to get to the core selection screen.

    I have been able to play nes with Nestopia and snes.
     
  3. vEN2

    vEN2 Member

    Newcomer
    46
    2
    Jan 30, 2016
    Afghanistan
    Eh, so sad, but it's not working for me. Tested with newest version 1.3 and old 1.0.0.2
    Every version of this emulator not runs via hbc. I can run core via wiixplorer or usb loader gx homebrew browser. But also if i load this it cant load any settings and i need load it manually. But if i load it manually my wiimote\nc setting will be erased. If i try to saving config i gets error, and i firstly need to load any .cfg file before save new. And input not saves.

    Via WiiFlow i get error, like "error to loading rom" and gets to core gui main menu with standart settings. It lookslike retroarch cant find cfg file and , i think, this makes trouble for loading roms. I use usb drive only, without sd card. Fat 32 primary active 1 partition drice only
     
  4. vEN2

    vEN2 Member

    Newcomer
    46
    2
    Jan 30, 2016
    Afghanistan
    Is there a way to run [make it works for WiiFlow] RetroArch without SD card??