Question RetroArch 1.7.6 Switch - Cannot Do Save States or Save In-game

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by saishowaguu, Mar 23, 2019.

  1. saishowaguu
    OP

    saishowaguu Newbie

    Newcomer
    3
    Oct 21, 2018
    United States
    Hi.
    I am running the latest RetroArch 1.7.6 for switch as NRO hombrew on the latest SXOS CFW 2.6.1
    My SD card is formatted as ExFat. I copied the files over from the RetroArch Switch .7z file to my SD card.
    I can download cores and load games just fine, but when it comes to in-game saves or save states, they don't work.
    When I try to do a save state, no matter the core or game, it just says: "Task failed: Saving state".
    In-game saves, for example: an RPG using PSXRearmed, give no error when saving during the game, but when I quit Retroarch (cleanly) and reload it, it doesn't find the save data and I have to start the game over from the beginning.
    I can confirm that the save state folder is there and is set correctly in RetroArch settings.
    What can I do to fix this?
     
    metal921 likes this.
  2. bad361

    bad361 GBAtemp Regular

    Member
    5
    Jun 18, 2018
    Russia
    Moscow
    You can try another CFW, and also you can try formatting to fat32. There's no doubt the problem is on your end. Firstly try another cfw. If it doesn't work there, do a clean install of RA on f32 sd.
     
  3. metal921

    metal921 Member

    Newcomer
    1
    Aug 28, 2018
    United States
    Having same problem it’s a bummer. I was told to format everything to fat32.
    Maybe file corruption
     
  4. Guaricana

    Guaricana Newbie

    Newcomer
    1
    Apr 8, 2019
    Turkey
    Having the same problem, I tried reinstalling but didn't help sadly. Kinda don't want to format if there's a way to fix without it..
     
  5. dragnipur

    dragnipur Member

    Newcomer
    3
    Jul 26, 2017
    United States
    All your files should already be split in 4GB chunks (unless you have an nsp you didnt delete after installing) so formatting isnt as bad as it might seem.

    But yeah, there’s no way around it.
     
    Guaricana likes this.
  6. Switch_Maniac

    Switch_Maniac Advanced Member

    Newcomer
    3
    Dec 16, 2018
    United States
    More than likely that is 100% corruption if you are using exFAT. Homebrew an exFAT do not play well, especially if the homebrew crashes or is quit using the home button. If you have another SD just format that fat32, put RA and a couple games and test the save state.
     
  7. n0where

    n0where Newbie

    Newcomer
    1
    Dec 3, 2008
    United States
    I had this problem with savestates playing SOTN. I changed the save state from 0 to 1 and it worked. I even have my card formatted as ExFat.
     
Quick Reply
Draft saved Draft deleted
Loading...