Retaining old Homebrew on 4.0

Discussion in 'Wii - Hacking' started by drfsupercenter, Mar 28, 2009.

Mar 28, 2009
  1. drfsupercenter
    OP

    Member drfsupercenter Flash Cart Aficionado

    Joined:
    Mar 26, 2008
    Messages:
    1,886
    Country:
    United States
    Hi,

    So, just earlier today I updated my Wii to 4.0. But I know I did something wrong, and I'm curious how to get 100% of the homebrew stuff working again.

    I was previously having errors with the IOS60 installer not working, but I Googled one of the errors, and realized it was a problem due to cIOS249. So I used AnyTitleDeleter to remove the version I have, and installed the .wad of cIOS249 revision 8. (I was previously on 3.2U hacked using Starfall)

    I then ran the "safe IOS60 installer", to install the Trucha patched IOS60. The "safe updater" installed that just fine, but then gave me an error about creating a directory when downloading the Wii Menu 4.0 update. So I downloaded the update directly from Nintendo. Since the IOS60 was patched, I have confirmed that I can run custom installed WADs (that I did via the WAD Manager) from the SD Card menu.

    However, now some homebrew programs won't work. I went to run the WAD Manger I had from before, and it's giving me an error accessing the /wad folder. From what I understand, it's because the patched IOS60 only patches Trucha in the *Wii menu*, but not elsewhere. Am I correct?

    Any idea how to fix that? I suppose I could use Waninoko's downgrader to go back to 3.2U (That will work, right?) but if I can just patch my 4.0 to work with all old Homebrew programs, I suppose that would work too. (Right?)
     
  2. koji2009

    Member koji2009 GBAtemp Maniac

    Joined:
    Mar 13, 2009
    Messages:
    1,193
    Country:
    United States
    You need to reinstall cIOS249. Most of those programs either use that or the old IOS16... Now they can't use IOS 16 because you updated to version 4.0 of the system menu.

    In the future, read all material before updating... you really shouldn't mess with 4.0 till we have it stable for homebrew including some form of brick protection.
     
  3. drfsupercenter
    OP

    Member drfsupercenter Flash Cart Aficionado

    Joined:
    Mar 26, 2008
    Messages:
    1,886
    Country:
    United States
    Hm.

    I found this hacked WAD manager that works with SDHC, it's a clone of version 1.3. That seems to work fine, but the older one I have won't.

    I ran Waninoko's IOS downgrader, the one that supposedly lets you use Trucha on all parts of your system.

    Any ideas?
     
  4. Screemer

    Member Screemer GBAtemp Maniac

    Joined:
    Sep 21, 2008
    Messages:
    1,248
    Country:
    Germany
    the original release of wadmanager 1.3 doesn't support sdhc cards. maybe wanin will release a new revision someday. but by now we have to go with the hacked version. i have no idea who released it but a link in nearly every thread regarding it should be set.
     
  5. drfsupercenter
    OP

    Member drfsupercenter Flash Cart Aficionado

    Joined:
    Mar 26, 2008
    Messages:
    1,886
    Country:
    United States
    No, that's not what I'm saying.

    I'm not using SDHC - I have a 4GB normal SD (I got it back before 4.0 came out, it's a little known fact that the Wii accepts non-HC 4GB cards, as rare as they are)

    The thing is I was able to use the original WAD Manager (you know, the one without the stupid/annoying technoconsolas ad banner on top?) just fine, and now it's giving me a libfat error on the SD card.
    Someone said it's because I did an official update and didn't patch it.

    So why would the hacked 1.3 work and not the older one?
     

Share This Page