Requesting help updating r4i gold 3ds

Discussion in '3DS - Flashcards & Custom Firmwares' started by Shadow_Boss, Dec 25, 2012.

Dec 25, 2012
  1. Shadow_Boss
    OP

    Newcomer Shadow_Boss Advanced Member

    Joined:
    Dec 19, 2011
    Messages:
    57
    Country:
    Canada
    I bought the card from a site recommended by the gba temp shop and its worked great out of the box. I recently saw a new patch update for the card. Now i remember previously when I asked about which cart to buy, you kind folks had informed me to update the cart first and then the 3ds (unless i misread) sooo

    The back of my cart there's a tiny letter that says "C" so I'm assuming I have the right cart as the patch says only for revision C (from the r4ids.cn site)


    so I've downloaded the patch and i get two files

    R4iGold_3DS45_NDSi145_Patch_NDSi.nds

    and

    R4iGold_3DS45_NDSi145_Patch_NDSL.nds


    I have no clue what I'm suppose to do with those two. The readme says

    " This patch is designed for r4ids gold 3ds(C Version) released by www.r4ids.cn, In order to make your r4ids gold 3ds run on 3DS4.5.0-10 and NDSi V1.4.5, you should update your card with this patch. Please follow the instructions below:

    In case of card broken(no card found, no Icon displayed): Using the patch: R4iGold_3DS45_NDSi145_Patch_NDSL.nds
    You should get a NDSL and another flashcard(called "A"), which works properly on NDSL.

    1.Download the latest WOOD R4 firmware from www.r4ids.cn and unzip it to the root directory of your tf card;"

    which leads on to use an NDSi or NDSL ...i don't have either :( lol so what do i do? My 3ds cart isn't broken



    Also i've read something about a Metroid icon, mine has a Halo ring or something like that.

    Should I even bother to update? lol


    thank you for your time!
     
  2. metroid maniac

    Member metroid maniac An idiot with an opinion

    Joined:
    May 16, 2009
    Messages:
    1,282
    Country:
    United Kingdom
    You need to update your R4 before you update your 3DS in the future. The 3DS update prevents you from running the R4 update, and the R4 entirely.
    You will need to borrow an older DS, DS Lite, DSi or 3DS and run the appropriate update file (DSL for DS Lite or older, DSi for DSi or newer).
    Your R4 will be updated and you will no longer need the old console.
     
    Shadow_Boss likes this.
  3. Shadow_Boss
    OP

    Newcomer Shadow_Boss Advanced Member

    Joined:
    Dec 19, 2011
    Messages:
    57
    Country:
    Canada
    well that was quick, thank you. So I shall hunt down someone with a DS and get this done. thanks again
     
  4. RodrigoDavy

    Member RodrigoDavy GBAtemp Maniac

    Joined:
    Feb 9, 2011
    Messages:
    1,453
    Country:
    Brazil
    You have to use the R4iGold_3DS45_NDSi145_Patch_NDSi.nds on your 3DS. Keep in mind that for some carts, the update won't work but there is no harm in trying. Please tell what happened after you've tried it.
     
    Shadow_Boss likes this.
  5. RodrigoDavy

    Member RodrigoDavy GBAtemp Maniac

    Joined:
    Feb 9, 2011
    Messages:
    1,453
    Country:
    Brazil
    If the cart is working in your 3DS, just do what I suggested in the post above. You don't need a spare DS as long as you can still run the cart in your 3DS
     
    Shadow_Boss likes this.
  6. tranfeer

    Member tranfeer GBAtemp Advanced Fan

    Joined:
    May 23, 2010
    Messages:
    772
    Country:
    Austria
    Shadow_Boss, please do not update your card.
    All cards have been pre-flashed to support the latest 3DS & NDSi system.
    There is no need to update them at all.

    Just goto www.r4ids.cn and download wood r4 v1.56 for r4i gold(r4ids.cn).
    Unzip it to the root directory of your tf card.
    Click start and choose help.
    You'll get a information window which can show the latest system version your card can support.
    For example, if it show:3DS4.5.0-10&NDSi V1.4.5, there is no need to update it at all.
     
    Shadow_Boss likes this.
  7. Shadow_Boss
    OP

    Newcomer Shadow_Boss Advanced Member

    Joined:
    Dec 19, 2011
    Messages:
    57
    Country:
    Canada

    i got my card i think around september or november, I did what you asked and it shows

    " Sys: NDSi 1.44 & 3DS 4.3.0-10 "

    *Edit so i tried the update anyway, was a fail didn't work unfortuantely but nothing happened so its okay haha*
     
  8. RodrigoDavy

    Member RodrigoDavy GBAtemp Maniac

    Joined:
    Feb 9, 2011
    Messages:
    1,453
    Country:
    Brazil
    There are some Rev C carts that just can't be updated for now. They said they will be releasing an updated patch for those cards soon
     
    Shadow_Boss likes this.
  9. Shadow_Boss
    OP

    Newcomer Shadow_Boss Advanced Member

    Joined:
    Dec 19, 2011
    Messages:
    57
    Country:
    Canada
    thanks for the help folks i appreciate it.

    if I get a hold of DS i'll do it the other way but until then I can be patient i guess.
     

Share This Page