[Request] Spider Browser Legit CIA

Discussion in '3DS - Homebrew Development and Emulators' started by E1000, Apr 17, 2015.

  1. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    Hi Guys, I got an old 2DS with an 8.1 firmware which I updated to 9.2 through a "Cooking Mama" EU to use the spider injection, unfortunately that kind of update didn't update the browser as well, which remains at 8.1.
    Other than that I managed to make work both ninjhax and FBI.

    Now, from what I understood, through Funky CIA should be possible to extract legit CIA if preinstalled on the ds default firmware and make them shareable as legit, therefore my request is:
    Would be possible to extract the default browser with FunkyCIA as a legit CIA?

    if so, would anybody be so kind to share to me a legit CIA of the spider browser (with capabilities for injection)?

    thanx everybody ;)
     
  2. MeisterFenster

    MeisterFenster GBAtemp Regular

    Member
    161
    31
    Nov 18, 2014
    Gambia, The
    Only possible if you extract thr browser from your console. If you get it from another console you would have to remove the console id -> breaks the signature -> no longer legit.
     
  3. Brewzip

    Brewzip Advanced Member

    Newcomer
    54
    17
    Feb 6, 2015
    Italy
    Can the extraction be done with "funkycia -personal"?
     
    E1000 likes this.
  4. Stoned

    Stoned GBAtemp Advanced Fan

    Member
    778
    112
    Mar 26, 2014
    Gambia, The
    Use 3dnus and Download a Spoffed Browser Cia. :P
     
  5. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    I tryed with £DNUS but the CIA that I've got results not legit when I try to install through FBI, what do you mean for "Spoffed Browser CIA"?
     
  6. Stoned

    Stoned GBAtemp Advanced Fan

    Member
    778
    112
    Mar 26, 2014
    Gambia, The
    Ohh Sorry. :/
     
  7. pokemoner2500

    pokemoner2500 GBAtemp Advanced Fan

    Member
    845
    273
    Aug 14, 2013
    United States
    The fact that a exploitable browser that's been installed via BBM works in rx-tools (classic mode/do what you would in sysnand) shows that if you install a exploitable browser (downloadable via 3dNUS) then you should be able to use it!
     
    E1000 likes this.
  8. Shadowtrance

    Shadowtrance GBAtemp Addict

    Member
    2,482
    1,513
    May 9, 2014
    Hervey Bay, Queensland
    Just download it through 3dnus but don't spoof anything, just get the right version instead.

    For EUR you want:

    titleid: 0004003000009D02
    version: 4096

    and it should install fine.
     
  9. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    Maybe I got a bad file than, could you please link me the reference to download a proper exploitable browser from 3DSNU?
     
  10. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    oh thanks, I just read the answer. Will test asap and let you know...
     
  11. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    works like a charm.. thanks guys!
     
    kactusss likes this.
  12. pokemoner2500

    pokemoner2500 GBAtemp Advanced Fan

    Member
    845
    273
    Aug 14, 2013
    United States
    Out of curiosity how are you loading FBI?
     
  13. E1000
    OP

    E1000 Newbie

    Newcomer
    6
    1
    Apr 17, 2015
    through ninjhax after a couple of bootstrap patches, necessary for running FBI on old 3ds
     
  14. pokemoner2500

    pokemoner2500 GBAtemp Advanced Fan

    Member
    845
    273
    Aug 14, 2013
    United States
    Thought so, just checking!
     
    E1000 likes this.