RedNAND don't start

Discussion in '3DS - Flashcards & Custom Firmwares' started by myki, Jun 26, 2016.

  1. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    Greetings,

    I am following plailect's guide in order to install A9LH but I'm locked when it's said to launch luma3DS, select "Show current NAND in System Settings" and press start to reboot. After reboot, the result is different with the version of Luma I tried :
    From Luma 5.2 to 5.3.1, I reboot towards sysNAND
    From Luma 5.4 to 5.5 I freeze on a black screen.

    To help you help me, here's the full story :)
    I started with an O3DS v4.5.0, downgraded in the past with Gateway (yes, I know.....).
    Since I could'nt dump my hs.app, I had to dump my CTRNAND, defrag it and then reinject it to the DS.
    I could next follow the rest of the guide, until the point where I'm locked, on a v9.2.0.

    A last thing : I don't know why at a certain point of my tries, I couldn't launch HBL with the browser anymore. Strange, because before, I could launch HBL nearly each time at the first attempt.
    So I decided to change the date to 01/01/2000 00:00 (even if it's an O3DS) and I succeed to access to HBL.
    The interesting part is that it may have revealed another problem : When I got out of the parameters (after changing the time) it asked if I was agree to update the 3DS ! It never asked me before.

    Ha and a last last thing :) Try after try, I don't know why but I lose menuhax and get back to the default theme (that's why I have to use the browser again).

    Finally, my questions are :
    Can you help me please ? :)
    And should I flash my sysnand-old.bin, the one I dumped after having reinjected a clean CTRNAND and start the update to 9.2.0 again ?

    Thanks for reading, and for your help !
     
  2. TechAndrew

    TechAndrew Untitled

    Member
    232
    65
    Aug 6, 2015
    Canada
    Wherever I Am
    Go back to 4.5 and update to 9.2 again, making sure that there's no errors.
     
  3. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    Hum, just to be sure, did you already try this?
     
  4. Arceus922

    Arceus922 Advanced Member

    Newcomer
    68
    10
    Sep 29, 2015
    Greece
    Smal question but it will make all the difference: did you unlink your nands??? (if this sounds stupid forgive me, i have never quite well understood gateway)
     
  5. TechAndrew

    TechAndrew Untitled

    Member
    232
    65
    Aug 6, 2015
    Canada
    Wherever I Am
    Yes, you should always unlink your NANDs, otherwise data could be lost or corrupted when you access Data Management in sysNAND. Unlink your NANDs by doing a System Format on either sysNAND or emuNAND (whichever has no data or useless data).
     
  6. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    Black screen loading of a rednand is kinda normal depending on how many times you tried. Stick to current version of LUMA, and try 2-3 more times to load into Rednand. Dont give up after just one or two failed boots.
     
  7. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    Thanks for your help everybody ! @Kyojin no I didn't follow this step, because I thought that the upgrade to 9.2.0 would solve everything relating to Gateway... After reading more I realized that I was wrong !
    Thanks for pointing that :) @EmperorOfCanada you're right too, at the end I just tried one time... I will try more after resolving my #@!ยง$ problem with CTRNAND !
    @Arceus922 no I didn't format my NAND, just because I'm locked the step before... But yes I will format as soon as I can boot with RedNAND :)
    I will edit my post even if I succeed, thanks for your help and don't hesitate to go back here from time to time ;)

    Edit : Just to be sure, would you advice me to reflash the 9.2.0 upgrade to start with a clean state, or is it unusefull ??
     
    Last edited by myki, Jun 26, 2016
  8. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    My recommend at this point is to go back to 5.5 LUMA, and attempt to enter Rednand 2-3 more times, before considering it 'non working'
     
  9. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    You don't necessarily have to reflash it, just make sure that you install O3DS NATIVE90.cia, not the 104.
     
  10. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    @Kyojin the tuto says to activate "sysnand is updated" in luma, but in luma it says that it is for A9LH only.
    Is it safe to activate and continue even if A9LH is not yet installed ??
     
  11. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    It is safe, but don't enable it. It's useless for non-A9LH. After that, if it continues to fail to boot just do as @EmperorOfCanada suggests and try to boot a few times, and eventually it should boot to RedNAND. :)
     
    EmperorOfCanada likes this.
  12. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    Sorry, I need your help again... How can I install FBI in EmuNAND, please ? ?
    The way I've learnt lead me to reboot and then I go to sysNAND instead of staying to EmuNAND...
     
  13. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    Well, since you are following Plailect's guide, just be patient, you'll get there on part 4.
     
  14. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    I ask because I need it right now, to install 03DS NATIVE90.cia and O3DS AGB and TWL.cia ?? :) :)

    Edit : I am now looking for a way to launch FBI into EmuNAND without having to install it...
    I tried to copy the 3ds folder of FBI. Now it starts well in SysNAND, but it freezes in a black screen in EmuNAND...
    Any idea, please ??
     
    Last edited by myki, Jun 26, 2016
  15. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    Oh yeah sorry, I completely forgot about that. :D Check the section I of part 4 for how to inject FBI into your EmuNAND.
     
  16. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    I am disapointed... I can't get Decypt9 to launch in EmuNAND ! By the way it starts fine on SysNAND...
    Edit : Trying within HBL since I am able to start HBL in EmuNAND...
    Edit2 : No... Decrypt9 won't launch with HBL, it goes back to HBL without starting...
     
    Last edited by myki, Jun 26, 2016
  17. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    If it's on 9.2+ it won't launch since it needs ARM9 access. What version is your RedNAND on? Did you already update it to 11.0?
     
    myki likes this.
  18. myki
    OP

    myki Advanced Member

    Newcomer
    53
    1
    May 25, 2016
    France
    I am still on 9.2, and I don't want to upgrade until the O3DS NATIVE90 and the others stuff are note installed... or I missed someting ?
    Edit : When I copied the firmware.bin from the NTR Firm's package, is it a kind of light EmuNAND, or just a way to launch my Emunand, cloned from my Sysnand ??
     
    Last edited by myki, Jun 26, 2016
  19. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    Why are you even trying to launch it in Emunand?
     
  20. Kyojin

    Kyojin #include "brain.h"

    Member
    467
    232
    Sep 7, 2015
    France
    firmware.bin is basically an older version of the 3DS firmware, not an EmuNAND and does not really help launching EmuNAND AFAIK.

    For Decrypt9, if you are trying to run it to inject FBI into EmuNAND/RedNAND, you have to run it from SysNAND, so don't bother running it from EmuNAND/RedNAND.
     
    EmperorOfCanada likes this.