Random Bug I found when my vWii blackscreened...

Discussion in 'Wii U - Hacking & Backup Loaders' started by Kyouhei, Jun 9, 2014.

  1. Kyouhei
    OP

    Kyouhei Official 任天堂 Lover

    Member
    534
    154
    Aug 18, 2011
    Okay so When you open a homebrew app in vWii when certain reqiurements aren't met, (I used Nintendont without a HID Compatible device) It blackscreens and the only fix is to unplug it. So I unplugged my Wii U, then swiftly plugged it in and hit the power button while the Gamepad said the connection was unstable, It didn't get a chance to say the connection was lost

    To my surprise until it prompted me to select my user the gamepad still thought I was in vWii, and It wouldn't let me use any of the controls on it! A bubble kept popping up Saying "you can't use the gamepad in Wii Mode"
    My question is, Is this just a normal error, Or could it be exploited? I'm not usually one to post these kinda things, (Actually I don't really post at all anymore) But I was really curious.
    Since it thinks it's in vWii mode WHILE the WiiU mode is loading, is there any chance of making a Homebrew App that executes code and imitates the Wii U being unplugged?
    I'm not the most knowledgable about this, sadly..
     
  2. julialy

    julialy Homebrewer

    Member
    1,677
    588
    Nov 26, 2012
    United States
    United States
    I wonder if the Gamepad sends controls over Wifi in vWii mode at all. If possible might sniff the controls coming from the Gamepad.
     
  3. Goku Junior

    Goku Junior GBAtemp Advanced Fan

    Member
    951
    288
    Dec 27, 2013
    Argentina
    Buenos Aires, Argentina
    Interesting BUG, are you on 5.0 system menu? I will try it and see what happends.
    EDIT: I've tried with a game it doesn't work (Paper Mario) and it boots normally.
    EDIT2: I've tried 3 times and the console is booting normally, but in the gamepad something strange happends, when I turn on the Wii U (the gamepad in vWii mode), the gamepad shows the Wii U letters, but suddently goes OFF and it turns on by it self, strange...
    EDIT3: I'm in System Menu 5.0...
     
  4. Kyouhei
    OP

    Kyouhei Official 任天堂 Lover

    Member
    534
    154
    Aug 18, 2011
    I am in 5.0, I booted from the console's power button after unplugging and plugging in, I'll try to get a video up later.