R4i Gold [SDHC] Unable to Read

Discussion in 'R4 DS' started by HaloEffect17, Jul 26, 2015.

  1. HaloEffect17
    OP

    HaloEffect17 Splatoon Fan

    Member
    1,044
    981
    Jul 1, 2015
    Canada
    Quick and simple, I messed up my R4i Gold Card a year ago because it kept getting stuck inside my DS Lite. Yes, literally stuck, as in I couldn't click it back out (it had a bump in the middle that made it slightly larger in width than a regular DS Card). After managing to take the microSD out first, I recall taking a flat head screwdriver sticking it into the microSD Card slot and trying to pull it out. I know, stupid. :(

    It worked. But after several times doing this, I must have partially touched the part of the circuit board and, in turn, scratched it enough that one day, it stopped reading. Tried putting it back in the DS Lite several times, but it refused to read (probably damaged it more by doing this... again, stupid).

    I searched YouTube videos like this one, about physically taking the DS Card apart, cleaning the components a bit, and reassembling it back together like no big deal. I am just curious if any of you have some other tips you'd like to share that could enlighten me in possibly getting this R4i back in working condition. I may have messed with the circuit board a bit, but it really could be a whole bunch of gunk on it since I bought it off a friend and not brand new. Thanks in advance, guys. :)

    Edit: I've got an original fat DS that the R4i Card can easily put in and out of to test it again. I'm never putting back in my DS Lite. :lol:

    Edit #2: I actually pried open my R4i and tried the paper trick as well as cleaning the connectors with rubbing alcohol. Didn't work. I'm still open to your suggestions on how to proceed.
     
    Last edited by HaloEffect17, Jul 26, 2015