Problem with sleep mode (might be linked with keyboard)

Noctosphere

Adoptive father of Zelda
OP
Member
Joined
Dec 30, 2013
Messages
5,923
Trophies
2
Age
29
Location
My own appartment, finally!!!
XP
9,622
Country
Canada
Hello
So yea, for a looooooong while, my computer wouldn't go in sleep mode after not being used for few minutes
I didn't really care about it, I could turn off my monitor with its power button
But now, the power button is broken, I can't turn it off anymore
So the only solution I had was to turn around my monitor face to the wall (because my desk is few meters away from my bed)
This wasn't a problem so far but something intrigued me recently

You see, I had a gaming keyboard and the wire broke (started smoking, no joke)
So I putted it away for recycling later and bought two new one
The first I ordered online wouldn't be delievered before a week, so I bought a cheap one at walmart for waitting

And MAGICALLY, with this cheap keyboard, a non-gaming keyboard, the sleep mode was working again
I really didn't understand at all, but it worked

Then, I received my gaming keyboard, so I putted aside my non-gaming keyboard, keeping it for when my new one would break or something
And now, the sleep mode doesn't work again
I tryed turning off the LED of my keyboard, but still, didn't work

So I was wondering, is it normal that gaming keyboards prevent sleep mode of computer?
Thanks :)
 

console

Elvira fans ❤ :-)
Member
Joined
Mar 1, 2013
Messages
225
Trophies
0
Website
www.startpage.com
XP
1,712
Country
United States
My computer sometimes wake up by self that I never touch it. Just computer sleep mode problems that cause wake up by any devices without our permission. I know devices are very strange to us and people. I use powercfg -devicequery wake_armed on command program to find out which hardware device cause to wake up. Just disabled box for wake up from LAN, Wifi, Keyboard, mouse, etc. Don't disable both keyboard and mouse. Just one keyboard or mouse which person want to press any button to wake up computer from sleep mode.

If anyone have problems with computer that cause wake up from any devices. Everyone must have go in command program then type or paste - powercfg -devicequery wake_armed on command then press enter to show info up on there. Find which devices are bother you then you can disable wake up mode in settings that will fix problems. :)


I find on internet that would help you a lot about info here.


How to Fix a Computer that Keeps Waking Up

https://www.techsupportalert.com/content/how-fix-computer-keeps-waking.htm

Last updated by v.laurie on 07. August 2015 - 18:14

Not too long ago I bought a new desktop PC. Whenever I put it to sleep, in no time flat it was awake again. A little research revealed that this is not an uncommon problem and can have several possible sources. Malware infections are sometimes the cause but more often it is some device that is waking the machine up and that was the case for me. In this tip, I will describe several settings in your system that may keep waking up your PC. The discussion is for Windows Vista/7. You will generally need administrator privileges to make system changes.

Update 08/07/15: Instructions for Windows 8.1/10 are quite similar and have been added.

Stop the mouse from waking up the PC
Mice, especially, wireless mice, can sometimes wake the PC up. In fact, there is a specific setting to allow this. If the mouse turns out to be a problem, you can change the setting with this procedure:

Open the Start menu and type “mouse” (without quotes) in the Search bar
Under the Control Panel list, click “Mouse” (or just press Enter in Vista)
In the dialog box that opens, select the tab “Hardware”
Highlight the entry for your mouse and click the button “Properties”
A new dialog will open. Click the button “Change settings”
In the new dialog that opens, click the tab “Power Management”
Remove the check by “Allow this device to wake the computer”
Click “OK” and close the dialogs.

Added: The mouse properties dialog is the same in Windows 8.1/10. Here is one way to access the mouse settings:

Right-click the Start button
Select "Control Panel" from the context menu
Enter "mouse" in the Control Panel search box
Click "Mouse" in the list that opens
The mouse dialog box will open
Proceed the same as indicated above from step 3 on


Stop a network card from waking up the PC
From what I read, a network card is the most common source of wake-up problems and that was the cause of my own computer never staying asleep. Here is how to configure a network card:

Open Device Manager. There are many ways to do this but a quick way is to enter “dev” (without quotes) in the Start search bar and click “Device Manager”
Expand the list for “Network adapters”
Right-click the adapter to be configured and choose “Properties”. There may be several adapters, one for Ethernet, one for wireless, and others like Bluetooth
In the dialog that opens, click the tab “Power Management”
Remove the check by “Allow this device to wake the computer”
Click “OK” and close up Device Manager

Added: Device Manager remains the same in Windows 8.1/10. To access it:

Right-click the Start button
In the context menu, select "Device Manager"
Proceed as given above from step 2 on
Scheduled tasks , updates, and other causes
Sometimes a task or Windows Update is scheduled for a specific time and will wake up the computer. Dealing with these and other possibilities are discussed at this link

.
Use the command line to find what causes the PC to wake up
One way to find out what is causing a wake-up problem is provided by the command line. Open a command prompt with elevated privileges and enter this command:

powercfg –lastwake

The last device that woke up the system will be shown.

To find out which devices are enabled to wake up the PC, enter this command

powercfg -devicequery wake_armed

These commands are the same in Windows 7 on up through Windows 10.
 
Last edited by console,

You may also like...

General chit-chat
Help Users
    K3N1 @ K3N1: https://m.imdb.com/title/tt17047510/