Problem With Going to the Home Menu

Discussion in '3DS - Homebrew Development and Emulators' started by KeroseneZanchu, Feb 4, 2016.

  1. KeroseneZanchu
    OP

    KeroseneZanchu Member

    Newcomer
    19
    8
    Oct 12, 2014
    United States
    Okay, I probably did something stupid, but here's what happened:
    I was on 10.3 (USA) and one of my friends wanted to play 3DS Smash with me because he didn't yet have a Wii U. I looked up Homebrew compatibility for 10.5, because I couldn't access online services on 10.3. It seemed that it worked on 10.5, and I would only have to update. So, with everything still on my SD card, I updated. The update itself worked, but it had a black screen. I didn't know what to do, so I just held the power button until it powered off. I turned it on again only to get the permanent black screen again. Out of curiosity, I took out the SD card and voila! It worked. I put my SD card back in and everything re-loaded (my digital games appeared, badges appeared, etc.). I went to the friends menu and everything worked, but when I returned to the home menu, the "Home Menu" loading screen was frozen. I took out the SD card and it unfroze and sent me to the main menu like normal. I tried turning it off and looking at the SD card in my computer, but nothing strange was there. I even removed all Homebrew-related files, plus a file in my 'personal' folder that looked strange. (The name wasn't a string of letters like the rest, it was named !! and had a different file extention). Nothing worked. Then I put on the freshest versions of the boot and menuhax files, and tried to see if re-installing menuhax would fix it. I can't even try because browserhax crashes 100% of the time on the orange screen.

    Bottom line is, I updated to 10.5 and now it freezes every time I transition to the home menu while my SD card is in, and I can't access homebrew.

    I thought deleting the extdata file might help, but I don't want to risk that quite yet because I'm not sure what exactly is tied to the extdata besides home menu themes.
     
  2. Vampirex

    Vampirex Dhampir

    Member
    248
    62
    Mar 12, 2008
    Canada
    have you tried another SD card?
     
    Last edited by Vampirex, Feb 4, 2016
  3. pre10c

    pre10c GBAtemp Fan

    Member
    306
    43
    Jan 15, 2016
    Belgium
    you have to update the payloads for the homebrewlauncher, your hbl is set for 10.3 while your device is on 10.5
     
  4. KeroseneZanchu
    OP

    KeroseneZanchu Member

    Newcomer
    19
    8
    Oct 12, 2014
    United States
    I'm using plain firmware, although it might have accidentally become frankenfirmware. Before I tried updating to 10.5, I used a guide that was supposed to install the .cia for online features, so I used that and NASA to install it. I'll link the guide:

    No, I have not tried another SD card as this is the only one I have right now.

    How would I do that? I cannot access homebrew because browserhax gets stuck at the orange screen 100% of the time.
     
  5. Xenosaiga

    Xenosaiga That one guy that doesn't give a shit anymore

    Member
    1,478
    838
    Oct 9, 2015
    United States
    The Shadows
    Homemenuhax is trying to trigger

    Because you were using it in 10.3 your menu theme is "corrupted"

    To fix this boot 3ds without SD card inserted.

    Insert SD card after you get powered on.

    Change your current theme.

    Boot homebrew using browserhax.

    Run menuhax manager to get the new menuhax payload.