Problem trying to play GC games with DM

Discussion in 'Wii - Hacking' started by Exacat, Nov 20, 2013.

  1. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    So I wanted to play GameCube games in my Wii using an USB.
    I installed Dios Mios and Dios Mios Booter, converted the game (Luigi's Mansion) using DMToolbox and attached the USB with it to the Wii.
    However, when I started the booter and opened the game, it said:
    ERROR: Could not read disk ID! (ret = -1)
    Press POWER button to restart the Wii.
    The structure of the USB is:
    K:/Games/GLMP01/game
    The game is PAL.
    Could you help me, please?
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,863
    2,246
    May 11, 2008
    United States
    Things to try:
    • Make sure you are using the latest versions of DIOS MIOS and DIOS MIOS Booter.
    • Make sure your primary USB partition is formatted as FAT32 with 32KB cluster size.
    • Make sure you have a disc of some kind in the disc drive or are using the NoDisc hack.
     
  3. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    • I have DIOS MIOS v2.10 and DIOS MIOS Booter SVN r30 HBC Pack.
    • The USB partition is exactly like you said (it's set as active too)
    • I'm using NoDisc.
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    5,863
    2,246
    May 11, 2008
    United States
    If I were you, I would try using a different loader, such as CFG Loader.
     
  5. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    Tried that loader. It says "Devolution only accepts clean dumps!"
     
  6. Lacius

    Lacius GBAtemp Guru

    Member
    5,863
    2,246
    May 11, 2008
    United States
  7. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    Nothing. I think I'll reinstall DIOS MIOS.
    EDIT: Well, at least now I don't get that problem anymore! However, I get a black screen after the DIOS MIOS logo.
     
  8. tbgtbg

    tbgtbg Shaking the ring ropes up in the sky

    Member
    1,951
    448
    Nov 27, 2006
    United States
    Try another game? Maybe it's a bad dump.
     
  9. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    Okay, tried Mario Sunshine. Now I get a green screen :P
    EDIT: Tried again, and it asks me if I want 60 Hz mode (with a Nintendo logo). I press "yes", a Dolby logo appears and the screen gets black!
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    5,863
    2,246
    May 11, 2008
    United States
    I've noticed that DIOS MIOS can sometimes be finicky. I suggest you try it a couple of times before assuming it doesn't work. As for your specific problem with Mario Sunshine, what happens when you press "no" to the 60Hz request?
     
  11. AwesomeMarioFan

    AwesomeMarioFan RiiConnect24 Dev

    Member
    162
    27
    Jun 21, 2013
    United States
    If I remember correctly, ret -1 refers to the source of the file not being available (Like the SD card being locked or removed), not sure if the error code was the same with other applications on the Wii (I got this from Multi-Mod Manager (MMM)). Make sure the file is not corrupt, since it seems to be compatible with both DIOS MIOS and DIOS MIOS Lite.

    http://wiki.gbatemp.net/wiki/DIOS_MIOS_Compatibility_List#L
    http://wiki.gbatemp.net/wiki/DIOS_MIOS_Lite_Compatibility_List#L

    Regarding the Super Mario Sunshine green screen, there seems to be an old thread on this.
    http://gbatemp.net/threads/dios-mios-super-mario-sunshine.336978/
    Apparently, forcing NTSC most in the loader you are using works, and formatting the drive you are using to FAT32 and using WBFS works as well.

    You also would want to make sure that the launcher and DIOS MIOS are both updated to their latest versions, since bugs are sometimes fixed between versions.
     
  12. Exacat
    OP

    Exacat Member

    Newcomer
    23
    1
    Jun 30, 2013
    The same problem, I tried lots of times with many DIOS MIOS Booter options. I tried Mario Kart: Double Dash, and it runs perfectly at any Hz setting.

    Both problems are resolved now, I don't know how I did it.
    However, when I try Mario Sunshine, it asks me if I want 60 Hz mode (with a Nintendo logo). I press "yes" or "no", a Dolby logo appears and the screen gets black.
    By the way, I have the latest versions of both.

    EDIT: Also, I got another dump, and it has the same problem.