Problem Jailbreaking a Previously Tethered JB Itouch

Discussion in 'iPhone, iPod & iPad' started by DMC23, Mar 27, 2011.

  1. DMC23
    OP

    Newcomer DMC23 Member

    Joined:
    Mar 14, 2009
    Messages:
    26
    Country:
    United States
    I have had my Ipod Touch 3rd Generation Ipod since it's release. The last jailbreak I used was Geohotz tethered jailbreak that upgraded it to 3.1.2. I haven't bothered trying to update it for over a year because there was nothing I wanted to use that required higher than 3.1.2. However, the tethering combined with new programs that require 4.0 and higher make me want to jailbreak it to 4.+ (preferable the lastest stable update - want to avoid 4.3 until it's common and they have worked the bugs out). I read through the jailbreaking section and tried to use Sn0wbreeze to jailbreak the machine. Unfortunately, I kept getting an error 21 message when I Itunes attempted to update the firmware (with shift + upgrade command for custom firmware). After two hours of trying to solve the error code, I reverted back to the tethered 3.1.2 GeoHotz JB. Could someone please help walk me through the best way to upgrade my Jailbreak?
     
  2. Dialexio

    Member Dialexio GBAtemp Advanced Maniac

    Joined:
    Mar 14, 2009
    Messages:
    1,546
    Country:
    United States
    [shameless plug]The guide is an excellent resource.[/shameless plug]

    If you told Cydia to "Make my life easier" (or if the top of the Cydia page showed a bunch of green version numbers), continue reading. If not, you're out of luck until the 4.3(.1?) jailbreak is released.

    Open up TinyUmbrella and then close it. (This will edit your hosts file, so you can restore to iOS 4.2.1.)

    Download a copy of iOS 4.2.1 for the iPod touch 3G. Hold Option (Mac) or Shift (Windows) and click on Restore, then browse to the IPSW. Once iTunes finishes restoring, jailbreak with greenpois0n.

    (NOTE: If your iPod touch 3G's capacity is 8 GB, you actually have an iPod touch 2G, which should use this IPSW of iOS 4.2.1.)

    Hope this helps! [​IMG]
     

Share This Page