Problem after using NOR Clearing option on Acekard 2i

Discussion in 'EZ-Flash' started by Ulttimaa, Oct 10, 2009.

  1. Ulttimaa

    Member Ulttimaa GBAtemp Regular

    Dec 4, 2008
    United States
    Well, basically, I seem to be having a weird issue, and I just want to know if my 3in1 is completely screwed or not.

    So, I've owned an EDGE before, and I've used GBAExploader with no problems. I switched over to the Acekard, and I had a problem, which didn't really bother me. I would load up GBAExploader 0.58b, and then select the game I want. However, then it would freeze. So, I'd restart, then go and try again, and it would work.

    But now, I decided to mess around, and I think I've really screwed something up. I used the "Blank NOR" feature on my Acekard, thinking it would simply clear the game on my NOR. I wanted to test it to compare the speed to GBAExploader's speed. It went by really fast, so I was like "Alright, cool."

    However, then I went into GBAExploader, and tried loading a different game to NOR. It let me select a destination, but then it would freeze upon selecting which save file to pick. Like, the window at the bottom would disappear after selecting a destination, but the save file selector wouldn't show up, and it'd be frozen. I tried restarting a few times, nothing.

    Then I tried booting a game through PSRAM. It would load, but only get past the GBA intro, then freeze at a white screen.
    I took out my 3-in-1, blew in it, and the DS, and put it back in, then loaded up GBAExploader. Now, it asks "Can I use the 3-in-1 for GBAExploader?" (Or something to that effect.). I hit Yes, and I went into my games, tried to boot something through PSRAM, and it white screened again. I did it again, got that prompt again, then white screen.

    However, now it loads, doesn't give me a prompt, but now it freezes upon start-up. It'll start up, but then the top screen shows no games, no file browser, nothing. It's apparently on the Root of my card, but doesn't show any of the files. The bottom screen doesn't show a game, and the Current SRAM Save is < Empty or new state >

    None of the controls work, it's completely frozen. I tried replacing my GBAExploader 0.58b, nothing. I tried booting it up on my EDGE, same result.

    However, the 3-in-1 still functions as a Rumble Pack. I haven't tried using it as a RAM expansion, since I don't have the browser, but I would assume it would still work.

    Is my 3-in-1 completely screwed? Or is there some way to fix it?
    I've read that my battery could be dead, but it was working PERFECTLY before doing this(besides the ocasional freeze, but the game in my NOR still worked fine.).

    EDIT: I'm going to assume my 3-in-1 isn't COMPLETELY screwed. I'm still able to boot up games through AKAIO 1.5's OS. I haven't tested whether saving works, though.

    EDIT-2: I've loaded Mother 3 to my NOR, and it seems to work fine. Both when booted through AKAIO and booted through the DS firmware. Save file sticks around, too. I just can't figure out why GBAExploader broke. [​IMG]
  2. badchilli

    Newcomer badchilli Member

    Oct 23, 2009
    United States
    Yeah. I noticed the same thing with GBAExploder v58a. I've got the same set-up as you. Brand new Acekard2i running AKAIO 1.5 and Ez Flash V 3in1.

    I just got the Ez Flash V 3in1 and I thought maybe it was one of the new ones, 3in1+, as I heard they can cause some problems with stuff because they are new, but apparently its not the new as I read GBAExploder will correctly identify the new 3in1 cards by displaying "3in1+", so mine is just the plain-jane "3in1".

    But same thing as you, GBAExploder v58a app runs under AKAIO, but switching to NOR mode (R-trigger) just freezes GBAExploder. Other than that, GBA games run fine if I run under AKAIO (including flashing to NOR mode) and not GBAExploder.

    I'm having an issue with Pokemon Leaf Green saves, as I sometimes get a message about my save game being deleted when I boot into Pokemon Leaf Green, but I think that's a separate issue. I think I just need to flash that particular game to NOR every time instead of "AUTO". Reason why I wanted to try GBAExploder, to see if that would fix my saves being deleted issue with that particular ROM.
  3. badchilli

    Newcomer badchilli Member

    Oct 23, 2009
    United States
    OK good news. I did further research.

    First off, yeah the issue is with the EZ flash V 3in1, not your flash carts (your Edge or Acekard). I tried my R4 with YSmenu and I got the same results, GBA Exploader freezing, that I did on my Acekard2i with AKAIO v1.5.

    Not a dealbeaker, like you said, as you can still play GBA games with AKAIO. Same with me AKAIO on Acekard2i and YSMenu on original R4 can load GBA games into the 3in1 run fine (PSRAM and NOR).

    The issue is that GBA Exploader can't read the current save management data in the SRAM. It's getting hung up on it, trying to read it, so it'll freeze. I don't know what caused it and the weird thing is that AKAIO and YSmenu have no issues with the SRAM, only GBA Exploader. And like you said, when you ran GBA Exploader the first time, it worked, just like me, but subsequent executions of the program fail by freezing.

    I read about this SRAM issue, in this "broken 3in1" thread, that talked about needing to blank, clear your SRAM, in order to fix it. Someone uploaded a blank SRAM file (sram.bin), available in the gbatemp downloads, but here's the catch. In order to use the blank SRAM.bin file (you put it in your GBA_SAVE directory on your microSD), you'll need to use GBA Exploader to write to it, using the "Y" option in PSRAM mode. Since both you and I can't run GBA Exploader, this is not a solution, a catch-22 if you will.

    Bummer. Sucks to be us.

    But wait. I combed through this epic thread on the EZ Flash forums, about people trying to get Pokemon migration from GBA rom to DS rom using the 3in1 cart on non-EZ flash carts (ie. R4, Acekard, etc), and I read a lot of the posts by cory1492, who seemed to know his stuff. He made a pokepatch (currently v4 see last page of the linked thread for the file) that patched pokemon DS roms that would get migration working and in the process talked a lot about how saving issues, and also SRAM stuff.

    Long story short, he said he used the BigBoss' CopyTest to clear his SRAM. I did a search for it and actually found out cory1492 himself also wrote a new program based on the BigBoss tool, called the GBALdr, which I've read about. The tool is also mentioned in the 3 in 1 Expansion wiki here on GBA temp in the "third party" section.

    Ok so I tried the GBALdr tool on my R4 (I'm sure it would work my/your Acekard too), and it loaded and it asked to save my SRAM data as a file and that it would erase my SRAM. I hit the button for OK and bam it cleared it!

    I restarted by DS and then ran GBA Exploader and it worked! It didn't get hung up on the SRAM anymore.
    Hopefully it'll work for you too. I didn't have to use any blank sram.bin file or anything. Just that GBALdr tool.

    I haven't tried using GBA Exploader to run any GBA games yet, but at least I know I can always fix my SRAM for Gba Exploader now if I get weird SRAM issues.

    Get GBALdr 0.1 Final here off cory1492's site or from the 3 in 1 wiki I mentioned earlier. Probably gbatemp has the file here somewhere too.

    What's cool is that cory1492 also updated the tool for people with the newer 3in1+ models. See the files and blog entry here. Since I don't have a 3in1+, just the regular 3in1, I just used the GBALdr 0.1 Final version.

    Update: I tried a few GBA Exploader versions. GBA Exploader 58b seems to have some issues still for me. It can always run now, since clearing the SRAM with GBALdr, but going into NOR mode with GBA Exploader 58b will freeze GBA Exploader (happened on both Acekard2i/AKAIO v1.5 and with R4/YSMenu). If I restart GBA exploader, I'm still able to run PSRAM mode. I didn't test any writing of PSRAM mode with v58 yet. I did try with other version of GBA Exploader though.

    GBA Exploader v57 seems to be OK. When I downgraded to GBA Exploader v57, I was able to go to NOR mode fine and switch back and forth through all the modes, although I didn't try flashing any games into NOR yet. I did try playing GBA games in PSRAM mode (with GBA Exploader v57) and they worked. PSRAM mode seemed to have better results with my R4/YSmenu however.

    Sometimes with my Acekard2i/AKAIOv1.5, in order for the GBA game to get past the initial white screen with GBA Exploader v57, I would have to PSRAM write the GBA rom TWICE (it would go to white screen first time and second time it would book OK). Not all the time but just sometimes. In contrast, with the R4/YSmenu and GBA Exploader v57 PSRAM mode, I didn't seem to have the same problem. Writing to PSRAM mode worked the first time and launch the game correctly. I did try a lot of GBA loaders (YSMenu, AKAIO, GBALdr, different version of GBA Exploader) which wrote to the SRAM, so that might have been the cause of the double writing sometimes needed for the Acekard + Gba Exploader as maybe it needed to clear a previous tools formatting first. Dunno.

    I haven't tried the official Acekard loaders (just AKAIO) and GBA Exploader so don't know if it works better.

    I didn't try GBA Exploader v58a after fixing my SRAM with GBALdr. Only tried the newer v58b, and the older v57 and v51. I had v58a initially before the GBALdr SRAM fix and v58a was freezing just like v58b, so I assume NOR mode in v58a is problematic and would freeze after SRAM fix just like it did with v58b.

    And to just double check, the EZ flash V 3in1 still works fine when running GBA roms natively (PSRAM & NOR mode) under Acekard2iwith AKAIO 1.5 or the R4 with latest YSMenu.

Share This Page