Power Off USB Ports

Discussion in 'Wii - Emulation and Homebrew' started by gudenau, Nov 27, 2013.

  1. gudenau
    OP

    gudenau Never a unique idea

    Member
    3,257
    1,224
    Jul 7, 2010
    United States
    /dev/random
    Is there any way to power down the Wii's USB ports with software? As some devices do not like to have the ios reload and application changing, this would be a good way to 'reset' those devices.
     
  2. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    4,219
    385
    Feb 7, 2010
    Netherlands
  3. gudenau
    OP

    gudenau Never a unique idea

    Member
    3,257
    1,224
    Jul 7, 2010
    United States
    /dev/random
  4. Maxternal

    Maxternal Peanut Gallery Spokesman

    Member
    5,210
    2,073
    Nov 15, 2011
    Deep in GBAtemp addiction
    unfortunately, from what I've seen I think the IOS resets USB as much as it can in software when reloading from one IOS to another. If this is not enough for the devices you're talking about the it probably doesn't include powering them down, no. (Without checking, though, I can't be 100% sure.)
     
  5. gudenau
    OP

    gudenau Never a unique idea

    Member
    3,257
    1,224
    Jul 7, 2010
    United States
    /dev/random
    Ok then, I will look into this later.
     
  6. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    4,219
    385
    Feb 7, 2010
    Netherlands
    Dude, only for your HDD ( HDD PSU in Remote socket.)
    I use this and it works wonders if you have kids....
    Use a cios that supports hotswap ( latest d2x beta...)
     
  7. gudenau
    OP

    gudenau Never a unique idea

    Member
    3,257
    1,224
    Jul 7, 2010
    United States
    /dev/random
    It is powered from the usb port, so no it would not help at all.
     
  8. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    4,219
    385
    Feb 7, 2010
    Netherlands
    hmm, Ah I see.
    Well it could also be that your HDD is not 100% compatible with Wii homebrew.
    I once had packardbell silver ans returned it for a similar problem you posted.
    I went with A WD elements with a separate psu, and al y problems were gone.