Possible to jailbreak PS3 version 3.50?

Discussion in 'PS3 - Hacking & Homebrew' started by Reysasuke, Nov 21, 2010.

  1. Reysasuke
    OP

    Reysasuke Member

    Newcomer
    23
    0
    Nov 14, 2010
    United States
    I was watching some YouTube videos where people were able to jailbreak the ps3 on version 3.50. Is that really possible?
     
  2. lolzed

    lolzed The GBAtemp Pichu

    Member
    2,466
    13
    Sep 13, 2008
    There
    No as of yet.

    PS3's are hackable only till 3.41. Another method coming soon is downgrading the PS3,which apparently only works once.
     
  3. Sao Mortel

    Sao Mortel GBAtemp Advanced Fan

    Member
    533
    0
    Jul 23, 2008
    Canada
    Montreal
    Downgrade has still yet to be proven. Psjailbreak team has destroyed their own reputation by promising a jailbreak for 3.50 ever since it came out and did not deliver. Videos are not reliable proofs; we have seen our share of fakes on gbatemp over the years lol
     
  4. lolzed

    lolzed The GBAtemp Pichu

    Member
    2,466
    13
    Sep 13, 2008
    There
    Except the downgrade HAS been proven real.

    PSJailbreak team does deserve credit man.They gave the jailbreak,clones and open-source alts appeared afterwards. And now they give us this.
     
  5. Sao Mortel

    Sao Mortel GBAtemp Advanced Fan

    Member
    533
    0
    Jul 23, 2008
    Canada
    Montreal
    Where? Where? [​IMG] nothing was posted on this forum
     
  6. doyama

    doyama GBAtemp Maniac

    Member
    1,288
    3
    Nov 30, 2006
    United States
  7. synce

    synce だいこんちゃんのだいふぁん

    Member
    500
    35
    Nov 5, 2009
    United States
    Seems possible but I'm not sure about playing 3.50+ games. I think the new COD only got hacked so quick because it wasn't actually 3.50. Maybe someone else can better explain the situation
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,045
    8,564
    Oct 27, 2002
    France
    Engine room, learning
    About the PSJailbreak Team, they promised that we could jailbreak 3.50+, but it was a false promise.
    We can't jailbreak it to play 3.50+ games, we can only downgrade to 3.41 to jailbreak 3.41, and we still can't play 3.50+ games.


    If you see jailbroken PS3 with 3.50 firmware, it's because we can replace the number manually in the reported installed firmware version, so the console and games think you are already up to date and won't ask you to update.
    Though, the real 3.50 firmware contains new encrypting key that 3.41 don't have.
    If you are on 3.41 (even if you fake the 3.50 in memory), you still can't decrypt games which were compiled with a 3.50 SDK.


    Two games requiring 3.50 are working because :

    - Medal of Honor : They compiled the game with 3.41 but made the game ask for 3.50
    Solution : Editing the param.sfo to ask for 3.41 is enough to fool the game.

    - I don't remember the name of the second game : They compiled the game with 3.50, and thus having the boot crypted with the new key. The 3.41 firmware can't decrypt the boot file.
    Solution : download the update from PSN server, the update is compiled using 3.41 SDK !
    The 3.41 firmware can now read the new updated boot file [​IMG]
     
  9. Zetta_x

    Zetta_x The Insane Statistician

    Member
    1,844
    257
    Mar 4, 2010
    United States
    Cyan hit everything right on the nail with his post.

    It could be possible that the jailbreak team could release another modded update file to exclude blocking of the exploit from 3.42 and 3.50 while keeping all other current 3.50 functions. However, in order to update to this modded PUP, you would have to downgrade which is possible provided by the jailbreak team.

    Unless you are apart of the Jailbreak team, (I'm not even related to the team so I am only speculating), we really can't say what they have for the future other than prepare to spend shit loads of money.