Please help

Discussion in 'Wii - Hacking' started by coopsy, Jul 15, 2009.

Jul 15, 2009

Please help by coopsy at 11:05 AM (1,319 Views / 0 Likes) 9 replies

  1. coopsy
    OP

    Newcomer coopsy Member

    Joined:
    May 16, 2009
    Messages:
    11
    Country:
    United Kingdom
    Hello everyone and thanks for reading.

    Wii 4.0E


    Please can anyone help?

    Some time ago I installed the HBC and Gamma backup loader using the "ultimate 4.0 virgin mod etc.." i also installed Pre-loader 0.29 and Bootmii.

    I must say this was very easy, had no hic-ups through-out the process and at the end I ended up having what I wanted however, my Gamma 03 backup loader never loaded a game, always game back with an error about reading the disc and some error codes.

    I bought some new Verbatim DVD-r and burnt a game. I somehow updated/replaced the cIOS ( I can’t remember what i did)

    IT WORKED!! my game played and no more USB loader. This was on IOS249 rev 7. I then read somewhere that cIOSrev13b would be better so I updated it via the network installer and got a -1 error.

    I thought "oh damn, what have I done" I get some code-dump messages come up also. Now when I put the same game in and load it I get a ERROR #002.

    I panicked and restored my Wii (full format)

    HBC and Gamma backup were gone so I feel I can just start again and back-track what i have done.


    Upon doing the "ultimate guide..." it advised (as per last time) to downgrade my IOS35, I did and upon this I got a ERROR (-2) This must mean my format didn’t remover EVERYTHING. So I carried on installed the files.

    I now have HBC and Gamma 03 but every time I restart my Wii I get the Pre-loader menu, so the format has left this behind also.

    I am trying to update the IOS`s and anything else to get rid of the #002 error I first encounter with. Upon using the "Custom IOS Installer2.0) to upgrade to the cIOSrev13b but i get a ret-27 error



    I don’t know what to do, I think I have been very lucky not to brick my Wii but feel if i carry on messing, its going to mess up. Is there a way I can remove everything from my Wii (apart from the main Wii file and channels etc) and start again?


    Thank you
     
  2. supermodchips

    Member supermodchips GBAtemp Regular

    Joined:
    May 24, 2009
    Messages:
    291
    Country:
    Australia
    I am assuming you can open the hombrew channel. If not disregard what I will say next. Try to do an official update to your console as that will overright any IOS modules you have installed. Or you could try running NANDClean and that should remove everything except for the hombrew channel.
     
  3. coopsy
    OP

    Newcomer coopsy Member

    Joined:
    May 16, 2009
    Messages:
    11
    Country:
    United Kingdom
    Thanks for replying

    No i can open up the Homebrew channel and i have now installed the #002 fix and my games are now working. What i need to do now is make another copy of my NAND via Bootmii however i cant due to my HBC being on version 1.0.1 so the Bootmii option isnt there in the menu

    HBC isnt yet prompting me to update to 1.0.3 yet, my internet connecting is fine
     
  4. mousex

    Member mousex GBAtemp Advanced Fan

    Joined:
    Jan 23, 2009
    Messages:
    987
    Country:
    United States
    Use the hackmii installer (from bootmii.org) to install HCB 1.0.3.
    If you want to reomve everything (exept from the Systemmenu) you can use comex' new MINI tool:
    http://github.com/comex/formatter/tree/master

    It will remove everything, all savegames, channels, IOS. And then install IOS 30 and Systemmenu.
     
  5. Richy Freeway

    Member Richy Freeway GBAtemp Advanced Fan

    Joined:
    Oct 9, 2006
    Messages:
    776
    Country:
    United Kingdom
    Run the Bootmii installer, install the HBC from there.
     
  6. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Never try to format your Wii again. You just pointlessly lost all of the save data and stuff on your Wii for absolutely no reason and yes you ARE lucky it didn't brick you.

    If you ever get some sort of error, SEARCH IT. Don't randomly do shit on your own. Doing that is a surefire way to screw yourself over.

    The 002 error is a common error that is easily fixed by using a more recent loader like neogamma or pretty much any usb loader.

    The -1 error you originally got with the cios installer is most likely an error in what is on your sd card because you probably told it to do a wad installation without having the necessary wad on the root of your sd card.

    First things first, you said you installed bootmii. Was that only as an IOS or were you able to do a boot2 install on your Wii? If you did do a boot2 install did you follow the instructions that it says in the ultimate guide now to backup your nand? If you did backup your nand when you installed bootmii like you should have then you should just go back to bootmii and restore that backup and everything will be like it was when you made that backup and you can move on properly without doing anything stupid from there.

    If you don't have a backup through bootmii then I suppose you could just try running the cios rev13a installer (13b is kinda buggy as I've heard, and has some different implementation of the 002 fix which may not work with many loaders.) Then when it asks for what IOS to use to install, if it allows you to use IOS249 then you still have some form of older cios on your system and you should just use that to install it and this time select network installation instead of wad installation. If you don't have IOS249 there then try IOS35 to see if that still actually has the trucha bug intact.

    If that still doesn't work and gives you like some error -2011 or something (I forget what it is exactly) Then try using the Trucha Bug Restorer to downgrade IOS15, use IOS15 to then install an IOS36 with the trucha bug, and then restore IOS15, and then run that cIOS rev13a installer again and choose IOS36 to use to install

    At least one of those things should work to at least get a recent cios properly installed on your Wii. As for the state of everything else I don't know what formatting did to it so I can't really say. But just do that for now and then get rid of your gamma 0.3 channel if you installed a wad of that by using wad manager and uninstalling it using the same wad you used to install it. If it's just in the HBC just take it off your SD card and then just put the files for neogamma R6 on your card and use that instead.

    And when something doesn't work after that, look for why it doesn't work first and what you're SUPPOSED to do to fix it instead of trying random things that will probably get your Wii bricked.
     
  7. coopsy
    OP

    Newcomer coopsy Member

    Joined:
    May 16, 2009
    Messages:
    11
    Country:
    United Kingdom
    Thank you for all those who have replied. So far my Wii is ok, its working and so are my back ups

    Nabster92 - Thank you, yes, i lost all my saves, all my SNES, NES, and GC channels that took me ages to install but i suppose the damage has been done.

    When i first used Bootmii and i selected the boot, it said something about the boot wouldnt work, so had to go on the 2nd boot, if that makes sense. There were 2 options and one of them i couldnt use.

    I then made a back-up which i have found. On my PC (as i backed it up on here) there is:

    nand.bin - file.... and
    bootmii folder with another 3 files in it.

    Do i just put these files onto another SD card, load Preloader then select the files from there? i forgot how ti install bootmii, i only have a .elf file and cant install this.

    With regards to the above IOS this IOS that i think im not going to touch any of them again, i clearly dont no 100% yet what im doing and how these files cant be messed with.

    Mousex - had a good option but i think at this time i am lucky. I always read posts on this forum but feel i cant comment as i dont no too much about these.
     
  8. Alexrose

    Member Alexrose Untitled

    Joined:
    Jan 20, 2009
    Messages:
    783
    Location:
    England
    Country:
    United Kingdom
    Ugh.. go to the bootmii website, download the bootmii installer, install bootmii as ios, install homebrew channel, load bootmii through the homebrew channel, do a nand restore, install neogamma (which has 002 error fix).
     
  9. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States

    This.

    Just run the hackmii installer again through your current HBC (rename the installer.elf to boot.elf) then just have that install the new HBC and bootmii as an IOS again which will write the files on your sd card again. Then put that nand.bin file you made on the root of the card, load the HBC press home and click launch bootmii. Then click the fourth icon (using a GC controller) and then the icon with the arrow pointing away from the sd card (should be the one that you DIDN'T click the first time) and it should prompt to restore the nand.bin file, so do that and continue properly from there (installing cios rev 13a properly and using neogamma R6 instead of the gamma 0.3 launcher.)
     
  10. coopsy
    OP

    Newcomer coopsy Member

    Joined:
    May 16, 2009
    Messages:
    11
    Country:
    United Kingdom
    THANKS NABSTER92
     

Share This Page