WIP OpenMW for Switch

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by fgsfds, Jun 6, 2019.

  1. rsn8887

    rsn8887 GBAtemp Advanced Fan

    Member
    10
    Oct 8, 2015
    United States
    I can tell you what worked for me.

    - It is enough to only pack three folders: icons, meshes, and textures. There’s a limit of 20,000 files in .bsa at least when using bsapack.exe, so packing all folders didn’t work for me.

    - Move those three folders into a new folder called “temp”

    - Pack them into a new bsa called archive.bsa using a method of choice (I used bsapack from here http://mw.modhistory.com/download-95-5215 )

    - Copy archive.bsa to Data Files and delete the temp folder (textures, icons and meshes folders are not needed anymore because they are now in archive.bsa)

    - Edit Morrowind.ini and add the line “archive_2=archive.bsa” under the line starting with “archive_1=“

    After doing this, now my OpenMW loads in 10-15 seconds.
     
    notimp and wicksand420 like this.
  2. wicksand420

    wicksand420 GBAtemp Addict

    Member
    9
    Nov 13, 2016
    United States
    Did anyone try packing oblivion like this and see if it can load?
     
  3. octopus

    octopus Custom Title

    Member
    4
    Sep 6, 2013
    Somalia
    /
    I tried packing other folders (except global) into a second archive (fourth if you count tribunal and bloodmoon) and it didn't work--no sounds, no music, no splashes in the menu, no fonts, no videos. It loads almost instantaneously to the progress bar and takes 44 seconds to load the menu.
    Packing meshes, icons and textures works. Loads to the progress bar in 20 seconds here. 1 minute to the menu. SanDisk Class10 A1 UHS-I.
    I think that loading the sounds folder takes those ~15 seconds since the folder has 7000+ files.

    Update: adding two archives (fallback-archive=*; thanks notimp; first is meshes, sounds and icons, second is everything else except global) in openmw.cfg works flawlessly. Now it's almost instant to the progress bar and ~46 to the menu.
     
    Last edited by octopus, Jun 28, 2019
    notimp likes this.
  4. notimp

    notimp GBAtemp Addict

    Member
    10
    Sep 18, 2007
    Worked. :) 17 seconds. :) Thats the main issue with this port fixed once and for all. :)

    If you don't want to mess with a morrowind.ini (because all it does is to serve as a templet for the openmw.cfg to be built) f.e. because you didn't need one for openmw to run, because you imported the openmw.cfg from a PC installation of the game.

    Just edit the openmw.cfg to contain a line

    fallback-archive=archive.bsa

    underneath the main game lines of the same nature (so underneath fallback-archive=Bloodmoon.bsa in my case).

    Works like a charm.

    (Use notepad++ (not notepad) if you are on Windows to make sure line endings get preserved. (Probably not necessary.))

    Dont forget to move the temp folder out of the data folder before trying it the first time. (If you dont want to delete it - before you confirmed it working. :) ) (Not sure if necessary - but I did, on my first attempt that resulted in a 17 second load. :) )
     
    Last edited by notimp, Jun 28, 2019
  5. LSolrac

    LSolrac Advanced Member

    Newcomer
    3
    Oct 26, 2015
    You should try it on PC prior to switch. The Switch version may be based on the git, but I believe that OpenMW still doesn't support Oblivion's physics, it does support the nif files tho.

    I would like to predict, however, once upstream OpenMW supports Oblivion, we'll get Fallout 3/NV and Skyrim shortly after.
     
  6. fgsfds
    OP

    fgsfds GBAtemp Fan

    Member
    8
    Aug 28, 2018
    Russia
    Well I'll be damned. I'll add this to OP later.
     
  7. Csmrcc

    Csmrcc GBAtemp Fan

    Member
    4
    Sep 13, 2018
    Spain
    i dont think we will see that, quite a lot of work to be done, openoblivion or opennuka.
     
  8. LSolrac

    LSolrac Advanced Member

    Newcomer
    3
    Oct 26, 2015
    Actually, some work is already being done, at least for Oblivion. I assume fallout might follow right after. And Skyrim (assuming they start working on that too), a while longer after.
    I do suggest checking out their forums, they have a discussion about it, along with a few 'forks' in development to add to the upstream.
     
  9. wicksand420

    wicksand420 GBAtemp Addict

    Member
    9
    Nov 13, 2016
    United States
    They showed a video of someone loading assets from Fallout 3 with the openmw engine, lots of things where not showing up, but I'd say its exciting none the less.
     
  10. Csmrcc

    Csmrcc GBAtemp Fan

    Member
    4
    Sep 13, 2018
    Spain
    hope you are right, for oblivion at least (and then its the same for others), when i read about it it seems to be on a very early state
     
  11. LSolrac

    LSolrac Advanced Member

    Newcomer
    3
    Oct 26, 2015
    Simple Search Yields these. Think you might want to--
    Take a look around, I'm sure you'll find what you're looking for. If not, give a holler, I might have stored it away.

    https://www.youtube.com/channel/UCYUtvG8296t1xFtTv85Gy_A (The MVP)

    https://forum.openmw.org/viewtopic.php?f=3&t=3017&start=280
     
  12. bitteorca

    bitteorca Member

    Newcomer
    1
    Jul 12, 2018
    United States
    This works for me, I have no subfolders in data files, just each masters, their BSAs, and two BSAs I packed. (One is Textures Meshes and Icons, other is the rest).

    The only issue I've discovered so far is that some of the icons appear PINK or they're slightly corrupted. I'm going to try to BSAPack Icons seperately and see if that helps, or just leave that as the only data folder.

    Also, does anyone have a guide for using the MCP (Morrowind Code Patch) for OpenMW on Switch? I want to enable a bunch of those fixes like fast casting.
     
    Last edited by bitteorca, Jul 5, 2019
  13. BlueCop

    BlueCop Member

    Newcomer
    1
    May 12, 2019
    United States
    Most of the files present in Data directories BookArt, Icons, Meshes, and Textures are duplicates or uncompressed(tga & bmp vs dds) versions of files already present in Morrowind.bsa, Tribunal.bsa, Bloodmoon.bsa.

    I extracted the Morrowind.bsa, Tribunal.bsa, and Bloodmoon.bsa and compared them against the files from the Data directory. These are the only additional files in BookArt, Icons, Meshes, and Textures not in present in the bsa archives.

    Code:
    \icons\a\tx_domina_boots.dds
    \icons\a\tx_domina_cuirass.dds
    \icons\a\tx_domina_glove.dds
    \icons\a\tx_domina_greaves.dds
    \icons\a\tx_domina_helm.dds
    \icons\a\tx_domina_pauldron.dds
    \icons\a\tx_eb_helm_of_tohan.dds
    \icons\a\tx_goldarmor_clpauldron.dds
    \icons\a\tx_goldarmor_cuirass.dds
    \icons\a\tx_goldarmor_helm.dds
    \icons\misc_master_index.dds
    \icons\daedric_runes.ttf
    \icons\gothic.ttf
    \icons\magic cards.ttf
    \icons\morrowind books html.htm
    
    \meshes\a\a_domina_a.nif
    \meshes\a\a_domina_boot_gnd.nif
    \meshes\a\a_domina_cuirass_gnd.nif
    \meshes\a\a_domina_f.nif
    \meshes\a\a_domina_fa.nif
    \meshes\a\a_domina_g.nif
    \meshes\a\a_domina_glove_gnd.nif
    \meshes\a\a_domina_greaves_gnd.nif
    \meshes\a\a_domina_helm.nif
    \meshes\a\a_domina_k.nif
    \meshes\a\a_domina_pauldron_gnd.nif
    \meshes\a\a_domina_skin.1st.nif
    \meshes\a\a_domina_skin.nif
    \meshes\a\a_domina_ua.nif
    \meshes\a\a_domina_ul.nif
    \meshes\a\a_goldarmor_cl.nif
    \meshes\a\a_goldarmor_cuirass_gnd.nif
    \meshes\a\a_goldarmor_f_c.nif
    \meshes\a\a_goldarmor_f_h.nif
    \meshes\a\eb_helm of tohan.nif
    \meshes\f\photodragons.nif
    \meshes\m\misc_index_master.nif
    \meshes\atronach_frost.nif
    \meshes\xatronach_frost.kf
    \meshes\xatronach_frost.nif
    
    \textures\photodragon.dds
    \textures\tx_a_domina_a_boot.dds
    \textures\tx_a_domina_c.dds
    \textures\tx_a_domina_g.dds
    \textures\tx_a_domina_glove.dds
    \textures\tx_a_domina_helm.dds
    \textures\tx_a_domina_shoe.dds
    \textures\tx_a_domina_ua.dds
    \textures\tx_a_domina_ul.dds
    \textures\tx_a_gold_c_female.dds
    \textures\tx_a_gold_helm.dds
    \textures\tx_a_gold_pauldron_f.dds
    \textures\tx_index_master_01.dds
    
    I think all these files are all linked to the official Bethesda mods. https://wiki.openmw.org/index.php?title=Bethesda_Softworks_Mods
    They link to the official mod downloads for these that contain the files in their downloadable archives. They were all bundled in the GOG version for me.

    So you don't really need to repack all these files into a bsa archive because they are duplicates from the bsa files. You can just delete the duplicates if you want.
     
    Last edited by BlueCop, Jul 7, 2019
  14. BlueCop

    BlueCop Member

    Newcomer
    1
    May 12, 2019
    United States
    Switching the A button to Left Click from Return causes many message boxes to require mouse input when before they just required tapping A without mouse input.
    Edit: Maybe the Joystick pressdown could be used for the mouse click? In the context of the game menus it doesn't have a function for the Joystick press I think.
    Edit2: I feel like an idiot. The left thumb click disables the gamepad mouse mode and A works as the space bar again. This works well for pressing A to close message windows.

    Is it possible to link the GUI scaling factor into the interface resolution? on 720p I used 1.5 and 1080 2.25 to increase the HUD and UI to a good size when playing.
    I think it is only modifiable in only in settings.cfg. This helps make the game more playable in higher resolutions though.

    I have been trying to mod the interface to more closely match the Xbox interface for the game. breath1.

    Its pretty easy to mod the mygui xml files to accomplish some of what I want. I was just playing around with interface. Increasing the mini-map size and moving things around. I was just experimenting really.
    screenshot000. screenshot003.
    The lack of multi-button combination support will prevent some things in the xbox controller scheme from working. It is a featured being added though. https://gitlab.com/OpenMW/openmw/issues/4000

    There are many interface items explicitly disabled from keyboard input and require mouse. Simply disabling some of these button tags makes them controlled with directional keys + enter. I took alot of screenshots from the xbox morrowind and I am trying to replicate with the mygui files.

    My goal is to make the mouse not needed as possible. I think the mouse cursor is only used for navigating the map on the xbox version.
     
    Last edited by BlueCop, Jul 9, 2019
    notimp likes this.
  15. DarkSoulFlame

    DarkSoulFlame Advanced Member

    Newcomer
    3
    Jan 20, 2008
    United States
    Could you share your config settings once you get it to a good place? I want to use the controller as much as possible and having to navigate with the mouse isn't ideal.
     
  16. Csmrcc

    Csmrcc GBAtemp Fan

    Member
    4
    Sep 13, 2018
    Spain
    You know you can make touch control for some actions like inventory
     
  17. Bluecloudo

    Bluecloudo Newbie

    Newcomer
    1
    Jun 21, 2019
    United Kingdom
    Is there any way to delete spells on the current control set? All my spells are adding up and scrolling is becoming inconvenient.
     
  18. robrasa

    robrasa Newbie

    Newcomer
    1
    Sep 18, 2019
    Brazil
    First of all fgsfds, thank you, it´s a dream coming through for a 43 yo gamer the possibility to play Morrowind in handheld mode. You are a genious!

    Second, my brother in blue Bluecop, please, did you find a solution to make the mouse not needed?

    I´m finding it difficult to use the joycon, not only because of the mouse cursor, but also because of the absence of shortcuts (sorry if it´s possible, but I´m an ignorant on this matter).

    Thank you all for the infos that made it possible for me to install the game and sorry for my poor english (not a native speaker).
     
    Csmrcc and Traace like this.
  19. burial

    burial GBAtemp Regular

    Member
    5
    Aug 15, 2018
    United States
    As awesome as this is and as grateful as I am.....I simply cant play it.

    Mapping the PC controls to a control just feels terrible IMO.

    I wish there was a way to play the original XBOX port of MW, it had great controls.
     
  20. Rahkeesh

    Rahkeesh GBAtemp Maniac

    Member
    7
    Apr 3, 2018
    United States
    In its current state you pretty much have to use touchscreen for menus, and probably with a stylus for maximum ease. I found going to 720p and editing the config to 1.5x UI scale makes for a slightly larger and very clean UI. Performance is kind of crap then but you can lock the framerate at 30 if needed.
     
Quick Reply
Draft saved Draft deleted
Loading...