NSMB:Wii update?

Discussion in 'Wii - Console and Game Discussions' started by reginator, Nov 10, 2009.

  1. reginator
    OP

    reginator Member

    Newcomer
    28
    0
    Sep 11, 2008
    Canada
    I'm thinking about actually purchasing the New Super Mario Bros for the Wii, but I want to know if the game comes with a forced 4.0 or higher update. I don't want to buy a game only to find I can't play it cause I don't want to update my wii and lose all my customization. D:
     


  2. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    15,774
    3,450
    Nov 17, 2008
    Australia
    Queensland
    it has 4.1
     
  3. Satangel

    Satangel BEAST

    Member
    10,255
    555
    Nov 27, 2006
    Belgium
    Bruges, Belgium
    It has 4.1 on it, so it's kinda safe to update, since 4.1 doesn't add a lot of anti-piracy thingies (none I think).
    So yeah, buy it!
     
  4. reginator
    OP

    reginator Member

    Newcomer
    28
    0
    Sep 11, 2008
    Canada
    Okay, thanks guys. Does 4.1 have anything breaking or specific I should know about? I remember I avoided updating back when it came out, but I can't remember why. [​IMG]
     
  5. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    532
    Sep 12, 2009
    Canada
    Ontario
    it has a fix for wii sports resort, even the store-bought game would crash on v4.0.
     
  6. Satangel

    Satangel BEAST

    Member
    10,255
    555
    Nov 27, 2006
    Belgium
    Bruges, Belgium
    Changes 4.1

    * Fixed a bug with Wii Sports Resort
    * Improve system performance
    * New version of Nintendo Channel (only in Japan and in North America for the moment)

    http://wiibrew.org/wiki/System_Menu_4.1

    Bookmark that site, it's so handy.
     
  7. reginator
    OP

    reginator Member

    Newcomer
    28
    0
    Sep 11, 2008
    Canada
    Thanks again Satangel! The "copy protected save files" is not a big deal i'm guessing, as all updates have done that. So if it won't mess with anything else, NSMB here I come!
     
  8. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Nintendo should of put 4.2, just to piss people off more than they already are.
     
  9. Krestent

    Krestent What to post?

    Member
    3,953
    33
    Mar 31, 2009
    United States
    Just use Gecko OS to load it. Then you don't need to worry about disc updates
     
  10. DarkMatterCore

    DarkMatterCore I like turtles.

    Member
    886
    189
    May 30, 2009
    Venezuela
    Cabimas, Zulia, Venezuela.
    I saw the Boot2v4 on one of the screenshots taken by kongnutz...

    +1.
     
  11. razorback78

    razorback78 GBAtemp Maniac

    Member
    1,183
    0
    Aug 3, 2009
    why worry? you could even run the game at 3.2 system menu. use neogamma off cios249rev14 then you could play the game.
     
  12. Pete666

    Pete666 GBAtemp Regular

    Member
    228
    3
    Nov 12, 2009
    Canada
    hi!

    Where did you get this information?

    I'm on 4.1u so I can buy the game and it won't update with anything with the 4.2 update?

    I want to stay on 4.1u
     
  13. SifJar

    SifJar Not a pirate

    Member
    6,022
    891
    Apr 4, 2009
    I was under the impression it had the 4.2 update including boot2v4?
     
  14. DarkMatterCore

    DarkMatterCore I like turtles.

    Member
    886
    189
    May 30, 2009
    Venezuela
    Cabimas, Zulia, Venezuela.
    Nope. It definitely has the 4.1 firmware + Boot2v4, :/...
     
  15. SifJar

    SifJar Not a pirate

    Member
    6,022
    891
    Apr 4, 2009
    Hmm, interesting. Still if it has boot2v4, I'll still have to update boot2 either way... (I dont wanna use a fail "safe updater")
     
  16. Pete666

    Pete666 GBAtemp Regular

    Member
    228
    3
    Nov 12, 2009
    Canada
    If I'm already 4.1u so no problems if I buy the game?
     
  17. Gamemaster1379

    Gamemaster1379 GBAtemp Advanced Fan

    Member
    588
    82
    May 5, 2008
    United States
    United States
    If you buy an American copy upon release, no, nothing will happen CONSIDERING that the NTSC copy uses 4.1U. If you get a foreign copy (through methods of piracy or importing, I'm not one to judge), then regardless, it'll ask for an update to 4.1E (or 4.XJ if you decide to go that route and (don't know what the version will be, so I'm using X). But most homebrew bypasses updates anyway. I use Neogamma, no update problems. I think that Preloader offers a bypass, and there's brickblocker and all that floating around nowadays anyway.


    tl;dr, there shouldn't be.
     
  18. Pete666

    Pete666 GBAtemp Regular

    Member
    228
    3
    Nov 12, 2009
    Canada

    Ok thanx a lot! Another question, I'm very noob with all those boot thing.. it said in a lot of forum that NSMBW will install boot2v4.. did I have boot2v4 with my 4.1u update?

    How can I know which Boot2 I have on my system?
     
  19. PainToad

    PainToad GBAtemp Regular

    Member
    243
    6
    Aug 31, 2007
    Just use preloader to block updates....
     
  20. Gamemaster1379

    Gamemaster1379 GBAtemp Advanced Fan

    Member
    588
    82
    May 5, 2008
    United States
    United States
    I've very limited knowledge on this and what it does, unfortunately to say. Hopefully somebody can better assist you, but I would assume that you don't. Booting sequence overwriting didn't come out until 4.2 system updates. So I would seriously doubt that NSMBWii would have it. If it were to actually include it, it shouldn't install until it does a system update anyway.