Hacking Neogamma R9 Channels

Do you want all future versions of NeoGamma channels to have autoboot or no autoboot? (Do you need a

  • Autoboot needed

    Votes: 15 36.6%
  • Autoboot NOT needed

    Votes: 10 24.4%
  • Autoboot AND non-autoboot needed

    Votes: 16 39.0%

  • Total voters
    41

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
Multi-Mod Manager Channel - update system menu safely to 4.1 or 4.2, manage wads and ios, apps for homebrew, your wii menu channels and do more things more.

Forwarder link + Info Read this first before using the forwarder:
Forwarders take up less space when it's installed. It allows people to change/update the dol in the the sd card. It searches for a .dol in specific a location made by the creator. All you need to do is update the dol file.

<LINK-->THE NEOGAMMA FORWARDER CHANNEL<--LINK>
MAKE SURE THAT YOU HAVE THE .DOL FILE IN ONE OF THESE DESTINATIONS
it'll check for the .dol in this order
1) SD card: /apps/NeoGamma/boot.dol
2) SD card: /NeoGamma/boot.dol
3) USB: /apps/NeoGamma/boot.dol
4) USB: /NeoGamma/boot.dol
-------------------------------------------------------------
Latest NeoGamma channel:

NeoGamma R9 Beta 56 <--- Link

NeoGamma R9 Beta 56 Autoboot <--- Link
Just press any button repeatedly to cancel the autoboot.

NeoGamma R9 Beta 56 Autoboot (Returns to Wii Menu) <--- Link
This is suppose to not return to the channel when you quit or want to power off.
Also if you have the autoboot above this one, this channel will replace it when when you install it.

Really important info from WiiPower's NeoGamma R9 beta thread:
Gamecube backups on discs mini FAQ:
Requirements for gamecube backup launching from disc with NeoGamma:
- A Wii with a backup compatible drive(if the wii is not white, it's not backup compatible, backup resistant white Wiis were sold since christmas '09, no backup disc compatible Wiis in the shelves anymore 1-2 months later). Easy test: In the latest NeoGamma, remove disc from the drive and select launch game from disc. You will get a read error. If your drive is too new, NeoGamma will say so. (after read errors when trying to read from disc)

- A GC backup compatible cIOS installed and used. For testing until it works, install d2x56v6, as it just works for gamecube games and 95% of all Wii games, including the latest ones. NeoGamma shows at the bottom of the screen which cIOS is used. If does not say: "d2x56v6 (249)", you did not install the cIOS correctly.

- A GC homebrew compatible cMIOS. If you don't know which one you have, just install a the recommend one. cMIOS and MIOS always overwrite any MIOS or cMIOS you currently have installed. Waninkoko's cMIOS up to rev5(including) are not GC homebrew compatible. All of WiiGator's cMIOS should be compatible, but the original WiiGator cMIOS might suffer from stability issues. Well this should only affect the switching into GC mode, once a game is running, there are no differences. Recommend cMIOS: The one from this thread, because: It's NeoGamma compatible, still allows to play retail GC discs from disc channel without issues, it allows to use the debugger when booting with patched MIOS and it's just best tested and known to work.

- The correct options in NeoGamma:
Storage device: SD or USB using cIOS(the others should work too, but most people try everything, so...)
Gamecube Mode: internal (MIOS just boots MIOS like the disc channel does, external boots sd:/NeoGamma/GC.dol in GC mode)
Force Video: Disc(with component cables, you might need to try all options)
Patch Video: No(only relevant on import games with color issues)
Reloader, Backup plugin, Audio fix and Patched MIOS: Auto
GC Ocarina&debugger: No

- A valid game image written on the disc. Well the best way to find out if this is the reason why GC backup launching is not working at all is to create a clean new dump from a retail disc with SuperDump or CleanRip(newer than SuperDump and maybe better). Multi game discs are valid discs, but i can only say that the multi game discs created with MultiGame ISO Creator v3.5.4F+ work for sure. MultiGame ISO Creator v4.x is known to NOT work with NeoGamma! Important: If a game has audio streaming, then shrinking it will break the image. When audio streaming games are shrunk, they also need to be fstfixed with the 32K fix in order to work properly. The 32K fix in NeoGamma might be able to fix this on-the-fly, but it's still experimental. The expected error is that the game crashes or shows a read error when the game tries to play an audio stream.

- Being able to get into the actual GC loader, which requires "GC mode internal" + a compatible cMIOS. When it says "NeoGamma GC Backup Launcher" on top of the screen, only then it is actually executing GC code, only then NeoGamma will do anything more about GC games than Gecko OS or any other loader that just boots MIOS. (which won't even boot all retail GC games correctly right now)

- If you have a modchip, then multi game discs won't work with "GC mode internal", only single game discs. If you boot GCOS from NeoGamma, then GCOS is responsible for compatiblity, video modes, cheats and anything else.

- And last but not least: A good disc. Only use high quality media and never burn slower than 4x. If you believe you need to burn slow, then use 4x, all others try 8x,12x or 16x. And DVD+Rs need the booktype set to DVD-R(dvd-rom) on burning, or the Wii won't be able to read them. This procedure is called bitsetting, just google it. Especially if the games can't be booted at all and NeoGamma doesn't even switch to the internal GC loader, then it's a disc or .iso problem for sure.

Official gamecube compatiblity list:
http://wiki.gbatemp.net/wiki/Gamecube_Back...patibility_List
(NeoGamma should play everything that plays on WiiGator's loader, there's no need to flood the list with "works on NeoGamma" and similar)

Recommended cIOS:
d2x with IOS56 as base IOS installed as IOS249. It's the cIOS with the best compatiblity and the least bugs from all cIOS you can use for NeoGamma(Hermes cIOS are not supported). Only some games that want to use IOS57(some games with microphones) or IOS58(games with usb 2.0 stuff, like a cam) will require to use a different base IOS. Since beta51, NeoGamma supports to automatically load other cIOS when another cIOS with another base IOS is better("IOS for games: Autodetect" setting), so it's recommend to install d2x with base IOS57 as IOS250 as your 2nd cIOS.
How to install:
1. Download ModMii:
http://gbatemp.net/t...mii-for-windows

2a. Run ModMii on your PC, create a wad for the latest d2x cIOS with base IOS56("4"->"249d2x56")
2b. Run ModMii on your PC, create a wad for the latest d2x cIOS with base IOS57("4"->"250d2x57")
3. Copy it to the "wad" folder on your sd card.
4a. If you don't have IOS236, install it, if you have it, skip this step...
4b. Run WAD Manager on your Wii, select to use IOS236 and install the wads.

More info on d2x:
http://gbatemp.net/t277659-ciosx-rev21d2x-...another-hot-fix


Recommend cMIOS for homebrew,retail&backup discs and softmodded&hardmodded Wiis. It's WiiGator's cMIOS just in a new installer(only required for GC mode internal or external):
New version(based on MIOSv10):
http://www.mediafire...4ayvwgqey66qc9v

Other cMIOS:
Old version(based on MIOSv4):
http://www.mediafire.com/?mn2jzmqg0ny

Alternative cMIOS for homebrew but for retail discs only(only required for GC mode internal or external):
http://gbatemp.net/t...n-cmios-now-yay

If you need any of the neogamma r9 betas not included here(old ones or new ones), please tell me. If you have any problems with these, please tell me.

Previous versions (non-autoboots):

Previous versions (autoboots):
---------------------------------------------------------------------------------------------------------------------------------------
Previews:
Video: The video shows 9 because it was recorded at the time Beta 9 was released. Beta 56 has more fixes and options.
http://www.youtube.com/watch?v=QNCInyGZkFU

backgroundpp.png
-http://img87.imageshack.us/img87/8408/backgroundpp.png
logoki.png
-http://img46.imageshack.us/img46/7118/logoki.png
dvdh.png
-http://img404.imageshack.us/img404/7344/dvdh.png

Here you can find the info, the homebrew version and useful tools/softwares
http://gbatemp.net/i...howtopic=219243

NeoGamma R8 version:
http://gbatemp.net/i...howtopic=215142
 
  • Like
Reactions: Lightyose

kakarotto87

Well-Known Member
Newcomer
Joined
May 5, 2010
Messages
70
Trophies
0
XP
177
Country
Brazil
Hello,

I'm having a trouble...
When I try to install this channel (r9) i'm getting error -1029

I have cios 249 and i trying to install with it.

I have uninstalled negamma R7.
------------


So, what can I do?
What cIOS is better?

THanks, im noob
biggrin.gif
 

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
kakarotto87 said:
Hello,

I'm having a trouble...
When I try to install this channel (r9) i'm getting error -1029

I have cios 249 and i trying to install with it.

I have uninstalled negamma R7.
------------


So, what can I do?
What cIOS is better?

THanks, im noob
biggrin.gif

this is at the top of my thread
Try this:

1. download then load cios38 rev19 using any method
2. first install the default(the ones already selected) and choose ios249 and install
3. load it up again and select ios250 then ios38 and install
now you have 2 cios: 1 for backup loading and 1 for wads
Ios249: loading backups
Ios250: Installing wads
4. load up wad manager and select ios 250, you should be able to install any wad
 

Krestent

What to post?
Member
Joined
Mar 31, 2009
Messages
3,953
Trophies
0
Website
Visit site
XP
340
Country
United States
rahoul102 said:
1. download then load cios38 rev19 using any method
2. first install the default(the ones already selected) and choose ios249 and install
3. load it up again and select ios250 then ios38 and install
now you have 2 cios: 1 for backup loading and 1 for wads
Ios249: loading backups
Ios250: Installing wads
4. load up wad manager and select ios 250, you should be able to install any wad
No. The first option to use is not to choose where to install to, it's to choose what IOS to use while installing. The cIOS installer will ALWAYS install to IOS249 and 250 together.
 

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
Gordinio said:
rahoul102 said:
1. download then load cios38 rev19 using any method
2. first install the default(the ones already selected) and choose ios249 and install
3. load it up again and select ios250 then ios38 and install
now you have 2 cios: 1 for backup loading and 1 for wads
Ios249: loading backups
Ios250: Installing wads
4. load up wad manager and select ios 250, you should be able to install any wad
No. The first option to use is not to choose where to install to, it's to choose what IOS to use while installing. The cIOS installer will ALWAYS install to IOS249 and 250 together.
i wasn't talking about where to install it. the new cios lets you choose where you want to install.
btw i had this error before and this fixed it.

look here
http://gbatemp.net/index.php?showtopic=212497

this is from the thread:
IOS249[57]-v19 (rev19 of Waninkokos cIOS) = Recommend by Waninkoko. Improves speed for USB loading. However, some Games might not work.
IOS250[38]-v65535 (rev19 of Waninkokos cIOS) = Stable IOS with the ability to install Wad
 

kakarotto87

Well-Known Member
Newcomer
Joined
May 5, 2010
Messages
70
Trophies
0
XP
177
Country
Brazil
Just saying...

I'm on 3.3u with ios249 rev 19 with trucha bug....

I unable to install Neogama R9...

-----------------

I have to instal hermos cios too?

I didn't install it yet. but FULL OF WIN here!

thanks dude, what more can I do for my wii???

---------------

Is it enough to run New Super Mario Bros?
 

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
kakarotto87 said:
Just saying...

I'm on 3.3u with ios249 rev 19 with trucha bug....

I unable to install Neogama R9...

-----------------

I have to instal hermos cios too?

I didn't install it yet. but FULL OF WIN here!

thanks dude, what more can I do for my wii???

---------------

Is it enough to run New Super Mario Bros?
1st Q: just try to follow the instructions for it at the top of the thread.
2nd Q: you do not need to install hermes cios its similar to Waninkoko's cios. btw read this post
3rd Q: i also like New Super Mario Bros, and i think you can run it. but i have only tried the game with usb loader gx.
 

kakarotto87

Well-Known Member
Newcomer
Joined
May 5, 2010
Messages
70
Trophies
0
XP
177
Country
Brazil
rahoul102 said:
kakarotto87 said:
Just saying...

I'm on 3.3u with ios249 rev 19 with trucha bug....

I unable to install Neogama R9...

-----------------

I have to instal hermos cios too?

I didn't install it yet. but FULL OF WIN here!

thanks dude, what more can I do for my wii???

---------------

Is it enough to run New Super Mario Bros?
1st Q: just try to follow the instructions for it at the top of the thread.
2nd Q: you do not need to install hermes cios its similar to Waninkoko's cios. btw read this post
3rd Q: i also like New Super Mario Bros, and i think you can run it. but i have only tried the game with usb loader gx.

Thank you. I think is better run it with usb loader...
can I run it with a pendrive?
 

kakarotto87

Well-Known Member
Newcomer
Joined
May 5, 2010
Messages
70
Trophies
0
XP
177
Country
Brazil
I tried to run NSMB with usb loader but "an error has ocurred..." with 5 minutes of gameplay...

I have to patch my iso?

some guy told me to instal ios53
 

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
kakarotto87 said:
I tried to run NSMB with usb loader but "an error has ocurred..." with 5 minutes of gameplay...

I have to patch my iso?

some guy told me to instal ios53
ok so maybe you should try to follow the instructions at the top of the first post.
that fixed my friend's error 1029. another person from wiihacks also tried it and it worked.
it's not going to harm your wii.

i don't think it's the iso that's causing the error
btw i never had to install ios53 to make NSMB work

this is what you need to install
IOS249[IOS57]rev19 of Waninkokos cIOS = Recommend by Waninkoko. Improves speed for USB loading. can play backups.
IOS250[IOS38]rev19 of Waninkokos cIOS = Stable IOS with the ability to install Wad
 

kakarotto87

Well-Known Member
Newcomer
Joined
May 5, 2010
Messages
70
Trophies
0
XP
177
Country
Brazil
rahoul102 said:
kakarotto87 said:
I tried to run NSMB with usb loader but "an error has ocurred..." with 5 minutes of gameplay...

I have to patch my iso?

some guy told me to instal ios53
ok so maybe you should try to follow the instructions at the top of the first post.
that fixed my friend's error 1029. another person from wiihacks also tried it and it worked.
it's not going to harm your wii.

i don't think it's the iso that's causing the error
btw i never had to install ios53 to make NSMB work

this is what you need to install
IOS249[IOS57]rev19 of Waninkokos cIOS = Recommend by Waninkoko. Improves speed for USB loading. can play backups.
IOS250[IOS38]rev19 of Waninkokos cIOS = Stable IOS with the ability to install Wad

I already made that and with it, I can use neogamma now. but the NSMB freezes and give me the erroer "An error has ocurred..." when i play for 5~6 minutes...

Did you patched your iso?
 

rahoul102

Well-Known Member
OP
Member
Joined
Mar 18, 2010
Messages
171
Trophies
0
Age
30
Location
Ottawa, Ontario
XP
91
Country
Canada
kakarotto87 said:
rahoul102 said:
kakarotto87 said:
I tried to run NSMB with usb loader but "an error has ocurred..." with 5 minutes of gameplay...

I have to patch my iso?

some guy told me to instal ios53
ok so maybe you should try to follow the instructions at the top of the first post.
that fixed my friend's error 1029. another person from wiihacks also tried it and it worked.
it's not going to harm your wii.

i don't think it's the iso that's causing the error
btw i never had to install ios53 to make NSMB work

this is what you need to install
IOS249[IOS57]rev19 of Waninkokos cIOS = Recommend by Waninkoko. Improves speed for USB loading. can play backups.
IOS250[IOS38]rev19 of Waninkokos cIOS = Stable IOS with the ability to install Wad

I already made that and with it, I can use neogamma now. but the NSMB freezes and give me the erroer "An error has ocurred..." when i play for 5~6 minutes...

Did you patched your iso?
the iso is not patched, i think.
did you download it or extract the game from a disk?
 
General chit-chat
Help Users
    Veho @ Veho: Apply orally for Aspergers, apply rectally for COVID.