Need help installing rxTools on this European 3DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by StriderVM, Oct 19, 2015.

  1. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    Need more help trying to install

    (Can't find my previous thread)

    As an update to my previous thread, I just received the Sky3DS to get a euro game to update the firmware of this O3DS. It has been successful, it's now on 4.5.0.5E

    But the same issues persists. Usage of camera crashes the 3DS. All NDS games/flashcarts just whitescreen then immediate "this game has closed" (So cannot use NDS Flashcart to make a fast mset exploit.). Since 4.5.0.5 is the firmware I think Ninjhax is also out right?

    So now I'm trying to work this out using this :
    https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/

    I'm now in step 3 and it isn't working. It just crashes without any rxTools menu.

    Any help guys? Getting seriously depressed here.

    PS. Being terribly outdated isn't helping things, before it's launcher.dat, then rxtools.dat and now it's rxTools/sys/code.bin? Which is which? :(

    Worst case scenario I'm gonna update it to 9.2 using a ROM update then downgrade using Gateway.

    I'm even starting to think this might be a 3DS that has stopped midway thru a system update. :(
     
  2. Quantumcat

    Quantumcat Dead and alive

    Member
    9,913
    5,230
    Nov 23, 2014
    Australia
    Canberra, Australia
    Tell us what your file structure is on your SD card to make sure you have the right files in the right places. You probably do but at least it will stop people suggesting you got it wrong :-p
     
  3. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    I'm confused, so maybe it's wrong.... :P


    Inside rxTools directory :
    [​IMG]
    Root Directory :

    [​IMG]

    Inside sys directory :
    [​IMG]

    Anyway is it risk free to update to 9.2 using cart updates then downgrade using Gateway?
     
    Last edited by StriderVM, Oct 20, 2015
  4. Quantumcat

    Quantumcat Dead and alive

    Member
    9,913
    5,230
    Nov 23, 2014
    Australia
    Canberra, Australia
    ***EDIT: Don't do anything until someone more knowledgeable than me advises you - if you don't have a fully working browser then updating past 4.5 will screw things up. ***

    Yeah you can definitely do that, but triple check the firmware that comes with the game you're thinking of using; US and Eur games sometimes come with different updates (due to being released at slightly different times), and really popular games can have a variety of updates even in the same region (due to being produced more than once). I don't *think* there's any games that come with over 9.2 but not 100% certain. I've heard people being recommended Code Name Steam to update with. But double check for yourself.
     
    Last edited by Quantumcat, Oct 20, 2015
  5. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    Update :

    I just looked at the current version of the browser : 1.7455

    According to the Spider Exploit page on GBATemp wiki :
    • 3DS System version 2.1-3.X = "Mozilla/5.0 (Nintendo 3DS; U; ; en) Version/1.7455.US"

    ... I think this is a problem right? This is probably the reason the Gateway menu thru browser works while rxTools doesn't?
     
  6. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    More stuff :

    OK, it's confirmed that a lot is probably broken in this 3DS, both cameras are broken (Both internal and external / 3D camera) .

    Is it possible that the camera being broken could interfere with the exploit? Any game/app that accesses the camera just crashes.

    If nothing changes, I'll be trying to update this 3DS to 9.2 then try out ThemeHax, if it doesn't work.... I'm gonna downgrade using Gateway

    It's so bizarre that Gateway works and rxTools doesn't.... what's the difference between the two?
     
    Last edited by StriderVM, Oct 20, 2015
  7. Cavioe

    Cavioe GBAtemp Fan

    Member
    308
    72
    May 28, 2015
    United States
    There are game carts out that have higher than 9.2. Code name steam has 9.4 i think. Super smash newest revision has 9.5. And there are 2 others I ran across recently. So you do have to be careful and not play any cartridges on sysnand without reading that popup.

    — Posts automatically merged - Please don't double post! —

    Shouldn't the firmware.bin be inside the sys folder?
     
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,474
    4,782
    Mar 17, 2010
    Norway
    Alola
    The -5 in your firmware version means that Ninjhax won't work. Ninjhax requires a -7 minimum I believe.
    In your case it's best to stay on 4.5 for now. You can launch rxTools through the DS Profile exploit on that firmware. If you want you can make a full update to 9.0/9.2 later to get cold boot CFW, but you need working CFW first in order to do that.
    You can try installing the DS Profile exploit with the "install nvram" option in the Gateway menu. I'm not sure if this works on o3DS though, but it won't hurt to try. If it works, then once you enter the DS Profile settings, it should load the GW menu. If you can get to that point, then you can replace the GW launcher with the rxTools 2.6 one, but you may have to encrypt the rxTools launcher so the GW ROP chain recognizes it. There's a tool that can do just that, so that's not a problem.

    In rxTools 3.0, firmware.bin and slot0x25keyX.bin go inside rxTools\sys although that shouldn't make it crash. Do you get the rxTools logo before the crash or does it just crash the browser?
     
    Last edited by The Real Jdbye, Oct 20, 2015
  9. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    So I just tap on install NVRAM? That's it?
     
    Last edited by StriderVM, Oct 20, 2015
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,474
    4,782
    Mar 17, 2010
    Norway
    Alola
  11. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    OK more update. I just found my old copy of rxTools 2.6..... Tried to run it using launch.rxtools.net ..... And it worked....... OK.... That means I just suck. And installed the latest rxTools incorrectly I think.......

    So now how do I setup mset to run rxTools 2.6 at least I'm relieved it's working...... :)

    To Answer jdbye's question : The browser just crashes. So either something's wrong.... So probably I'm putting the files in the wrong location.
     
    Quantumcat likes this.
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,474
    4,782
    Mar 17, 2010
    Norway
    Alola
    I'm not sure if the rxtools Web launcher works with rxTools 3.0 yet, since the files are in dlfferent locations, so that may have been your issue all along. I'm not at home now so i can't help you at the moment.
     
  13. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    Well, since it works with rxTools 2.6 I'm just gonna try this one just to make it run on mSet. For now.

    Also I just discovered the L and R buttons are also broken on this thing. Looks like this is a bust. Paid $40 on this thing. :(

    How much those flex/cables for the camera / L + R Buttons cost anyway?
     
  14. StriderVM
    OP

    StriderVM GBAtemp Fan

    Member
    424
    87
    Jan 16, 2015
    Final update.

    Finally something that worked. Used the latest version of FBI on sysNAND to install the ROP for rxTools 2.6. And temporarily fixed the L + R issue by blowing on it. :P

    Thanks for the help guys. :)