1. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    So I moved a few titles from sysnand to HDD. The transfer showed seemed to work with no errors but going back to the main menu the games no longer show up there. They are visible in data management and can be loaded with no problems using sysconf tool they are just not showing on the main menu for some reason. Anyone know how I can fix this please.

    Edit forgot to say I have less than 100 games installed so it's not the 300 limit causing issues lol
     
    Last edited by AmandaRose, Feb 24, 2021
    Lostbhoy and alexander1970 like this.
  2. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    So as Wind Waker was one of the disappeared games I decided to delete the game from the hdd and then reinstall it back on but is still missing from the main menu. I then deleted it again and tried installing it to nand but no luck it's still not showing on main menu.
     
  3. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    never heard of this problem, but I can tell you it's not a meta folder issue. that usually causes a question mark tile if something is wrong. it sounds like something is wrong with the barista file. if that is the case, there's no way to fix it probably, because unlike the ps3, the wii u has no way to fix database errors, that I know of.

    — Posts automatically merged - Please don't double post! —

    you might try installing it as a different user. iirc, each user has its own barista file.

    — Posts automatically merged - Please don't double post! —

    another suggestion is to try installing the games with system config tool (unless doing that already) or try installing them with wup if you've already tried that. I installed all my games with system config tool, then deleted the app.
     
    AmandaRose likes this.
  4. alexander1970

    Member

    Joined:
    Nov 8, 2018
    Messages:
    13,040
    Country:
    Austria
    Hello.:)

    :sad:


    Can you maybe check your HDD with "disappeared" Games with the Wii U DumpsterU ?
    https://github.com/GaryOderNichts/DumpsterU

    To get sure your Wii U HDD/your installed Games are ok.:unsure:

    I am sorry,I have no Idea what causes your Troubles,Amanda....

    Good Luck
    Thank you.:)
     
    AmandaRose and godreborn like this.
  5. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    she can also use ftpii u everywhere. iirc, it works on the hdd, because I remember going into the usr folder on there. just look for the title id. there should be three+ folders inside like 00050000 00050000c and 00050000e. there may be more like one that ends with a 2 (demos). each indicates what the files are like dlc, title updates, or games. games are 00050000. inside there will be the title id of the game. check if it's listed and the meta folder exists.

    — Posts automatically merged - Please don't double post! —

    yeah, for sure they're accessible. I just remembered changing all ds games but the cbhc to full screen by replacing some files. I can't really think of anything else to try other than another sd card maybe or if the sd card and usb are failing at the same time somehow.

    — Posts automatically merged - Please don't double post! —

    you'll probably need the seeprom and otp.bin for dumpsterU if you use that. don't initialize the hdd when plugging it in or else it will no longer work with the wii u unless you format it. you can get drive id from power shell if that's needed.
     
    alexander1970 likes this.
  6. alexander1970

    Member

    Joined:
    Nov 8, 2018
    Messages:
    13,040
    Country:
    Austria
    Thank you for reminding.
    Yes,please.:)
     
    godreborn likes this.
  7. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    it happened to me when I pushed yes by accident, and I didn't have a backup of my saves either. since then, I've been much more careful. I got almost all of my saves back by going through the game again. yoshi's island is pretty damn hard to get 100% in every stage, but I managed to do it again. the only game I didn't get back was super mario 64, but since that doesn't have your name, I just used someone else's save. I had 120 stars in it, and it was a nightmare, so I didn't want to go through it again. I'll have to go through it on the switch, because I bought 3d all stars, but I'm currently stuck in one stage of sunshine.

    — Posts automatically merged - Please don't double post! —

    mario 64 and new super mario bros ds are the two games I used to figure out that you could use emulator and flash cart saves on the wii u. you just had to hex edit and trim ds saves, which is very easy. I think mario 64 can just be a drag and drop. seems flash carts over pad the ds saves, so what you're deleting is a bunch of either 0s or Fs 'til I think you hit 8 kilobytes iirc.

    — Posts automatically merged - Please don't double post! —

    not doing that causes the save to be undetectable I believe.

    — Posts automatically merged - Please don't double post! —

    you do have to rename them to what the wii u looks for (use saviine or something to find this out), and it's best to delete the file that causes the system to save state whenever you exit or else the old save will be reborn. I learned that the first time I tried it.
     
    AmandaRose and alexander1970 like this.
  8. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    @alexander1970 and @godreborn first of all thank you for all the help. I have been trying to fix it for the last few hours and things are starting to get back the way they should be (Kinda lol). So after starting each game from sysconfig I can then turn the WiiU off then switch it on and select the game from quick start menu doing this makes the game then reappear on the main menu for some reason. I think whatever has happened is to do with the nand because I now have no software on the nand but in data management the nand is showing zero space is available even though there is no software on the nand.
     
    godreborn and alexander1970 like this.
  9. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    sounds like software corruption. I don't know how that could've happened beyond misuse of system config tool. that app can brick your system if you're not careful. I only used it to install games and backup saves. though, I've also heard you can use an out of region gamepad with an option in there too. for some reason, it had no option to restore saves, at least the version I have. in the pics on analtrade with the pdf of how to use the app, it shows a button to restore saves, but that button doesn't exist in the version I got from @punderino .
     
    alexander1970 and AmandaRose like this.
  10. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    Definitely not the fault of sysconfig the first time I used it was after the issue started and all I did was go to titles and launch the missing games.
     
    alexander1970 likes this.
  11. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    @GaryOderNichts is more knowledgeable than I am about the wii u, so he may have a suggestion or know what's going on.
     
  12. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    Thanks again for all your help @godreborn yep hopefully Gary knows what is happening.
     
    Lostbhoy, godreborn and alexander1970 like this.
  13. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    he's the only still active wii u dev I know of, so hopefully he responds.
     
  14. Lostbhoy

    Lostbhoy HEY YOU GUYS!
    Member

    Joined:
    Aug 23, 2009
    Messages:
    932
    Country:
    United Kingdom
    Did you move them one by one or as batch and does the issue happen if you copy a game over or is it just by moving?
     
  15. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    I actually copied instead of moved my haxchi game for cbhc, and the game's original icon and text, redNAND, are still there instead of do not touch. I think the app still works too as usb seems to take priority over the internal flash.
     
    AmandaRose and alexander1970 like this.
  16. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    When the issue first happened I batch moved a load of stuff from the nand to HDD. Since then I have tried everything you mentioned but always ends up with the missing icon on homescreen. The weird thing is even though the nand shows zero space I was able to install a brand new game to it that was never on the WiiU until today but still ended up with no icon on the homescreen. God knows what is going on I have been trying to fix it since early afternoon. I have decided to have a break and take the doggo for a long walk in the hope I can clear my head and come up with a solution. It's the first time ever on any system where I haven't managed to fix it with my own knowledge lol.
     
    Lostbhoy, alexander1970 and godreborn like this.
  17. Lostbhoy

    Lostbhoy HEY YOU GUYS!
    Member

    Joined:
    Aug 23, 2009
    Messages:
    932
    Country:
    United Kingdom
    Weird. It does sound like a corruption of sorts to the data management. Worse case scenario would be formatting it to try wipe any errors or bad sectors but..... Yeah!
     
    alexander1970 likes this.
  18. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    OK so a little update I decided to see what would happen if I downloaded something from the eshop to see if that would fix things and it somewhat has. The missing icon problem no longer seems to be a thing and a good chunk of my missing nand storage is back. It's still saying there is 4gb of data on the nand even though there is nothing on the nand. So I can only assume that the 4gb of data is all system software.
     
    alexander1970 likes this.
  19. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    16,906
    Country:
    United States
    iirc, system software is only 528MBs, and it's on a separate partition as well, the slc partition. internal memory is the mlc partition.
     
  20. AmandaRose

    OP AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,198
    Country:
    United Kingdom
    Just checked Nintendo's own website to see why my nand is short by about 5gb and it seems it it reserved for system data after all.

    Screenshot_20210225-134235_Samsung Internet.jpg
     
    Lostbhoy and alexander1970 like this.
Draft saved Draft deleted