1. AlhazenTheMad

    OP AlhazenTheMad Member
    Newcomer

    Joined:
    Apr 27, 2013
    Messages:
    13
    Country:
    United States
    What 3DS firmware version is required to play MH4U? Thanks in advance.
     
  2. illicit

    illicit GBAtemp Regular
    Member

    Joined:
    Sep 28, 2010
    Messages:
    159
    Country:
    United States
    nothing higher than 9.2
     
  3. illicit

    illicit GBAtemp Regular
    Member

    Joined:
    Sep 28, 2010
    Messages:
    159
    Country:
    United States
  4. lemanuel

    lemanuel Maxconsole's All-Knowing Lurker
    Member

    Joined:
    Dec 11, 2014
    Messages:
    2,095
    Country:
    Portugal
  5. Treflex

    Treflex GBAtemp Regular
    Member

    Joined:
    Feb 1, 2008
    Messages:
    189
    Country:
    United States
    Plays fine on 9.2
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Ultimate, Required, Firmware