messed up rxtools installation.

Discussion in '3DS - Flashcards & Custom Firmwares' started by drakegraves, Dec 9, 2015.

  1. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    i have an o3ds xl running 9.2.0-20. made a nand dump.

    i then formatted emunand, and when i went to check the SD directory, sysnand and emunand were still linked (only one folder).

    i forgot to perform that beginning step where i spoof title.db, so thats probably why.

    my question is, how far back do i go? should i use my nand dump to restore the device and start over?
     
  2. Ammako

    Ammako GBAtemp Guru

    Member
    6,404
    3,535
    Dec 22, 2009
    Canada
    What's the problem, exactly?
     
  3. Amapola62

    Amapola62 GBAtemp Advanced Fan

    Member
    932
    263
    Oct 25, 2015
    France
    I may be mistaken but I think the Nands are supposed to be linked at first after formating Emunand for the first time and that unlinking them is a further step, done buy formatting sysnand with the SD card out of the 3ds...So I don't think you messed up yet...I don't remember when one is suppose to take the sd card out of the 3ds though...that is probably written on the guide though...
     
    Last edited by Amapola62, Dec 9, 2015
  4. wormdood

    wormdood pirate booty inspector

    Member
    3,093
    1,271
    Jan 3, 2014
    United States
    behind a parental advisory sticker
     
  5. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    so here is what I've done:

    1. backed up NAND/SD card
    2. formatted emunand
    3.created title.db and import.db in dba, went to data MGMT and reset.

    I'm afraid i did things out of order. is it okay? can i proceed to setup emunand?
     
  6. Ammako

    Ammako GBAtemp Guru

    Member
    6,404
    3,535
    Dec 22, 2009
    Canada
    No, you can proceed. Just you may want to system format sysnand, taking out the SD card before clicking for Format button, to unlink nands.

    You can repeat that same step making title.db and import.db for emunand later if needed.
     
  7. KazoWAR

    KazoWAR GBAtemp Advanced Maniac

    Member
    1,791
    673
    Aug 12, 2008
    United States
    Winter Haven
    formatting emunand(creating it from gateway launcher) is not the same as formatting the system(from system settings) after you make emunand, you need to format the system.
     
  8. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    Alright, thanks. I'm at work right now, but I'll post how it goes. There are probably many documented cases of installing this software on this model, but it's always good to have more data, right?
     
  9. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    Okay, so I unlinked sysnand, booted rxtools 2.6. I went to injection options>inject emunand partitions>and instead of giving me more options, it just says "press a to exit"

    EDIT: Duh, it installed them and went back to the menu. sorry.

    I'm just so skittish. I feel like I'm trying to decide to cut the blue wire or red wire with 5 seconds left on the clock.

    — Posts automatically merged - Please don't double post! —

    When installing FBI.CIA to Health and Safety:

    Opening SecureInfo_A... Error.
    Trying with SecureInfro_B... OK!
    Region: USA
    TMD Version: v2051.
    NAND H&S TMD backup created.
    NAND H&S content backup created.
    Editing Hleath & Safety Information...
    Error opening FBI TMD.

    EDIT: Jesus I'm sorry. I see now that it was also supposed to do this. I need to breathe.
     
    Last edited by drakegraves, Dec 11, 2015
  10. 3DS4FUN

    3DS4FUN Member

    Newcomer
    32
    9
    Dec 9, 2015
    United States
    Well remember there is no rush to do anything. I tend to read things over a couple of times along with watching any youtube vids that may cover the same information.
     
    wormdood and drakegraves like this.
  11. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    alright. I booted to emunand. I don't have a signed CIA file to test with, yet, though. When I go to system settings it displays 3DSX 9.2.0-20U, but as soon as I exit, whenever I check again, it just says Sys Ver 9.2.0-20U. Am I still in emunand?
     
  12. Ammako

    Ammako GBAtemp Guru

    Member
    6,404
    3,535
    Dec 22, 2009
    Canada
    Unless you autoboot emunand with menuhax, exiting system settings will put you back onto sysnand. If you just go back to system settings then you'll be on your sysnand's system settings.

    Technically-speaking, it always puts you back onto sysnand whenever you exit system settings, but when you have autoboot emunand, it triggers menuhax right away and you end up back on emunand.
     
  13. drakegraves
    OP

    drakegraves Advanced Member

    Newcomer
    78
    12
    Aug 26, 2012
    United States
    Seattle
    Wow, your signature image is even radder than it was earlier today!

    I'm going to make a new post for further questions I might have, because this one's title doesn't really reflect where the issues have gone (if I have any)