M33 Or GEN?

Discussion in 'PSP - Games & Content' started by rockstar99, Nov 2, 2009.

Thread Status:
Not open for further replies.
  1. rockstar99
    OP

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    Which one should i get and why?
    *flameshield on*
     
  2. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Easy answer - GEN.
    Medium answer - M33 is now outdated, GEN have done so much better (aside from the bugs, that they have fixed now) and it also can play 5.55+ games (GEN D or 5.03 GEN B)
    But some fan boys/girls still stick with M33 saying "WE CAN STILL PLAY GAMES, AND ITS WAY BETTER THAN GEN"
    They forget that the Game Decrypter was made by Yoshihiro who is from GEN.
     
  3. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    GEN because:

    1 - M33 seems no longer supported by its own devlopers. (It did not get any updates for a long time)
    2 - It supports 5.55+ and protected games.

    Basicly the only thing M33 has that GEN does not is the fast memstick hack.
    However if games do not run what use is that.

    Greetz, Vistabuser.
     
  4. rockstar99
    OP

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    what are
    5.55+ and protected games.
     
  5. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    M33 is only on 5.03 firmware and lower right?
    So if you would of put a un-patched game on it, then it wouldn't load.
    the game needs to be decrypted to play on firmware lower than it actually needs.
    So GEN D and 5.03 GEN B made it so we don't need to use it ever.
     
  6. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    Games that require a firmware higher than 5.55.
    GEN has a on the fly game decrypter.

    Meaning it can decrypt both UMD`s and backup`s on the fly.
    So thats yet another thing M33 can not do: Play official UMD that need 5.55+

    What are protected games you ask?
    New games that have a anti piracy protection like for example: Evangelion Jo and there are others.

    Sure there are perhaps ways to play this on M33.
    But face the fact.... it is die-ing.

    Look at the R4 users that have to patch their games and then still have chance it does not run.
    I think it will not be long untill a range of games is released that do not even work on M33 with patch.
    That will be the moment also M33 fanboys will stop bashing GEN and join them.

    Greetz, Vistabuser.
     
  7. wyndcrosser

    wyndcrosser GBAtemp Advanced Fan

    Member
    720
    17
    May 28, 2009
    United States
    Any game that requires 5.55 or above, or requires a .txt edit to make it run.

    Wynd
     
  8. rockstar99
    OP

    rockstar99 Hi

    Member
    7,375
    156
    Dec 3, 2008
    Canada
    Toronto
    lol so gen=m3 and m33=r4 [​IMG]
    thanks guys im going with gen but wht dont m33 guys update i mean its free its not like the ds when you have to buy a new flashcart
     
  9. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    LOL, yeah it's like that.
    And M33 doesn't update because Dark Alex (who made M33) left the hacking. I don't know where he's gone, but i'm glad the fans have calmed down now.
     
  10. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    Hehe that is true.
    However some people just can not let go of their M33 version.
    Its like they feel its their pet or something.

    Greetz, Vistabuser.
     
  11. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Nope..it's because flashing a redundant upgrade that adds little but takes away more is counter intuitive. These topics are getting so boring.....where's the link to the GEN 1.50 Kernel add on again?
     
  12. Law

    Law rip ninjacat that zarcon made me

    Member
    4,132
    217
    Aug 14, 2007
    ‭jerkland
    Go with GEN if you're a pirate kiddy.
     
  13. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    You can always run M33 from memstick using timemachine.
    So I do not see what all the whine trouble is about.

    And rofl no Law, GEN-D can decrypt official UMD`s.
    Where on M33 you must download the ISO or rip your UMD.

    Greetz, Vistabuser.
     
  14. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    6,036
    928
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    If you have Gen-D2 then you dont need to decrypt them at all. I have 6.00 firmware game that didnt decrypt at all and run just fine on Gen-D2.
     
  15. Law

    Law rip ninjacat that zarcon made me

    Member
    4,132
    217
    Aug 14, 2007
    ‭jerkland
    So? That doesn't mean that the people who don't care about game compatibility are pirates. Sounds like you're trying to say the true pirates are those on M33, and not all the kiddys who complain that their ISOs don't work so they use GEN instead, whilst most people on M33 don't actually give a crap about games.

    Greetz, Trollbot.
     
  16. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    Dont be an ass now.
    You started the "Kiddie pirate" stuff yourself.
    Now dont go hating me because you have to defend yourself because of something stupid you said yourself.

    And you are even taking it personal to me lol.
    You are a sad lil fucker my friend.

    Also note you are the only fucker who recommends M33.
    Perhaps you are just jalous or sad your pet died?

    Greetz, Vistabuser.
     
  17. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Err...hello?
     
  18. Law

    Law rip ninjacat that zarcon made me

    Member
    4,132
    217
    Aug 14, 2007
    ‭jerkland
    Hi!
     
  19. Evilmaster1985

    Evilmaster1985 GBAtemp Fan

    Member
    456
    0
    Nov 23, 2008
    United States
    Middle of nowhere
    Wtf just look back dude.
    Everyone recommend something because of a reason right?

    Then you jump in calling everyone using GEN: Pirate kiddies. Right?

    So then before that there was no trouble at all.
    I say GEN can run UMD and M33 cant.

    You call a cheap reason and call me a troll.

    Greetz, Vistabuser.
     
  20. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    wow, this thread has gone downhill.
    Anyway pick GEN [​IMG]
     
Thread Status:
Not open for further replies.