iTunes Genius won't turn on

Discussion in 'iPhone, iPod & iPad' started by Jamstruth, Jun 9, 2011.

Jun 9, 2011

iTunes Genius won't turn on by Jamstruth at 9:18 AM (1,139 Views / 0 Likes) 0 replies

  1. Jamstruth
    OP

    Member Jamstruth Secondary Feline Anthropomorph

    Joined:
    Apr 23, 2009
    Messages:
    3,456
    Location:
    North East Scotland
    Country:
    United Kingdom
    SO earlier this week I managed to corrupt my iTunes Library files and had to rebuild it from scratch (and I succeeded too) but there's one problem now. Genius will not turn on. I go to turn on Genius, put in my login credentials, get to the ToS, click the accept button then click continue but I get the error "Your request is temporarily unable to be processed". Once this has happened none of the buttons on the page will respond at all, all returning the same error. If I don't tick the box, however, then iTunes tries to contact iTunes and returns saying that I have to agree to the ToS. If I tick the box I don't think it even contacts iTunes. I've got no idea what is wrong. I've tried deleting the Genius Library file severaltimes to no avail. Does anybody have any idea how to get this to work?
     

Share This Page